Support » Allgemeine Fragen » Umstellung von http auf https Bilder falsch

  • Gelöst chaossemmel

    (@chaossemmel)


    Hallo,
    ich habe meine Seite kürzlich von http auf https umgestellt. Es hat soweit alles geklappt bis auf das grüne Schloss welches im browser angezeigt werden sollte fehlt. Nun bin ich darauf gekommen dass es an meinen Bildern liegt. Diese werden anscheinend über http geladen. Daraufhin habe ich mir das Plugin „Better Search Replace“ installiert und ausgeführt. Leider kommt der Fehler immer noch. Wenn ich in der Mediathek den Pfad anschaue, steht allerdings https in der URL.
    Vielen Dank im Vorraus 🙂

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Wenn du z.B. mit dem Firefox F12 drückst und die Konsole auswählst, kannst du erkennen was noch fehlt!
    Dein Bild „Ich-selbst-168×300.jpg“ wird noch mit http geladen!

    Was muss ich ändern damit dieses über https geladen wird?

    Lösche die entsprechenden Bilder und füge sie neu ein.

    Alternativ kannst du auch nach einem Plugin suchen, dass dir dabei hilft.

    google => wordpress plugin http to https

    Hallo,
    über den folgenden Link kannst Du auch sehen, wo genau das Problem liegt.
    Da es sich offensichtlich nur um ein Bild handelt, ist der Vorschlag von @bscu sicher richtig. Bei mehreren Bildern würde ich das über das plugin „better search and replace“ machen, aber das hast Du ja offensichtlich schon getestet.
    Eine weitere Alternative wäre notfalls das plugin „Really Simple SSL„, wenn Du das nicht in den Griff bekommst. Ich bin ehrlich gesagt kein Freund davon, weil ich der Ansicht bin, dass man dafür in der Regel kein (zusätzliches) plugin benötigt.
    Viele Grüße
    Hans-Gerd

    Okay vielen Dank mit dem Plugin „Really Simple SSL“ hat es funktioniert und ich habe ein Schloss im Browser :). Mit dem Bild neu uploaden hat es auch nicht funktioniert.
    Vielen Dank 🙂

    perfekt – freut mich 🙂

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „Umstellung von http auf https Bilder falsch“ ist für neue Antworten geschlossen.