Support » Allgemeine Fragen » Umstellungsprobleme PHP 7.4>8.0 und auf SSL … Kein Login mehr möglich :-(

  • Gelöst salbei

    (@salbei)


    Hallo!

    Leider habe ich offenbar nach Jahren ohne Probleme meine WordPress-Installation „zerschossen“. 🙁

    Die Seite ist bei Strato und dort sollte die PHP-Version von 7.4 auf 8.0 (bei Strato als „empfohlen“ gekennzeichnet) umgestellt werden, da der Weiterbetrieb sonst relativ viel Geld kosten sollte.

    Nachdem ich das erledigt hatte, war die Seite jedoch gar nicht mehr aufrufbar. Ich bekam lediglich die Fehlermeldung „Es gab einen kritischen Fehler auf deiner Website.“ angezeigt, ohne weitere Hinweise.

    Zum Glück konnte ich die Umstellung rückgängig machen, und habe dann (wieder mit PHP 7.4) unter WordPress dieses und alle Plugins/Themes aktualisiert, alle nicht benutzten Themes gelöscht, alle Plugins deaktiviert und gelöscht (ich glaube keins davon war wichtig).

    Dann hat WordPress Verbesserungsvorschläge angezeigt, z.B. dass ich SSL aktivieren solle. Das habe ich dann auf Strato getan, WordPress hat sich aber weiter beschwert und http: anstatt https: angezeigt, mit dem Hinweis, dass ich auf 2 Seiten die Pfade richtig einstellen soll (Leider weiss ich nicht mehr genau wie die Einstellung hiess, jedenfalls stand da jeweils an 2 Stellen der Pfad zur Seite drin).
    Dort hab ich beide Male http durch https ersetzt und bei Strato SSL erzwingen (oder so ähnlich) gewählt.

    Naja, und jetzt geht eigentlich gar nichts mehr. Ich bekomme die Fehlermeldung

    Fehler: Gesicherte Verbindung fehlgeschlagen
    Beim Verbinden mit ##### trat ein Fehler auf. Sichere Kommunikation mit der Gegenstelle ist nicht möglich: Keine gemeinsamen Verschlüsselungsalgorithmen.
    Fehlercode: SSL_ERROR_NO_CYPHER_OVERLAP

    angezeigt, und beim Eingeben der URL wird automatisch https davorgesetzt …

    Ich weiss, dass sich da jetzt 2 verschiedene Probleme verschlungen haben, aber ich habe leider überhaupt keine Ahnung wie ich das wieder zum Laufen bekommen soll …

    Für jede Hilfe bin ich sehr sehr dankbar!!!!

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Gibt’s auch noch eine URL zur Website?

    Tja, die ‚Umgebung‘ wäre auch interessant. Webspache, vServer, etc.. Prinzipiell hat die Verschlüsselung des Webangebots nichts mit php zu tun. Die WordPress Version wäre vielleicht auch aufschlussreich.

    Hallo,
    evtl. hast du auf der Seite Einstellungen > Allgemein Eintragungen mit https vorgenommen. In dem Fall muss aber auch ein entsprechendes SSL-Zertifikat (z. B. über Let’s Encrypt bei Strato eingerichtet worden sein. Wenn das nicht der Fall ist, dann gibt es u. a. zwei Möglichkeiten, wenn du …

    • entweder im Kundenmenü deines Webhosters die Datenbankverwaltung öffnest (üblicherweise über phpMyAdmin) und dort in der für WordPress genutzten Datenbank in der Tabelle wp_options die korrekten Einträge für die Felder siteurl und home einträgst (Das Präfix wp_ kann auch anders lauten),
    • oder indem du per FTP in der Konfigurationsdatei wp-config.php mit einem geeigneten Code-Editor (z.B. VS Code oder Notepad++, beide kostenlos erhältlich) die Zeile define( 'RELOCATE', true ); oberhalb von /* That's all, stop editing! Happy blogging. */ einfügst.
      Danach solltest du dich über ...\wp-login.php anmelden und unter Einstellungen > Allgemein die URL ändern können. Wurde der Eintrag korrigiert und die Einstellungen per Button aktualisiert, muss man sich erneut anmelden. Die Website sollte dann aber wieder funktionieren. Vorsichtshalber sollte nun noch die in der wp-config.phpeingefügte Zeile wieder entfernt oder die Konstante auf false gesetzt werden: define( 'RELOCATE', false );

    Du solltest vor entsprechenden Änderungen in der von mir genannten Art auf jeden Fall eine Sicherung erstellen.

    Viele Grüße
    Hans-Gerd

    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von Hans-Gerd Gerhards. Grund: Tippfehler
    Thread-Starter salbei

    (@salbei)

    vielen Dank für die Antworten!

    dies:

    „entweder im Kundenmenü deines Webhosters die Datenbankverwaltung öffnest (üblicherweise über phpMyAdmin) und dort in der für WordPress genutzten Datenbank in der Tabelle wp_options die korrekten Einträge für die Felder siteurl und home einträgst (Das Präfix wp_ kann auch anders lauten)“

    war der absolut hilfreiche Tipp, dank dem ich wieder auf die Seite zugreifen konnte! Tausend Dank! Den anderen Tipp mit der eingefügten Zeile („define( 'RELOCATE', true );„) hatte ich schon gelesen (sorry dass ich das nicht erwähnt hatte) – dies hatte jedoch leider gar nicht geholfen.

    Leider habe ich jetzt herausgefunden, dass das Theme nicht mit PHP 8 funktioniert, so dass ich noch 3 Tage Zeit habe dieses auf ein anderes umzustellen bzw. die aktualisierte Version zu kaufen …

    Zu den anderen Antworten: Ja, es gibt auch eine URL, die hatte ich aber für das Problem nicht für relevant gehalten. Welche Websprache und vServer verwendet werden … da habe ich leider überhaupt keine Ahnung. Die Version von WP ist denke ich die neueste, da ich dies im Dashboard aktualisiert habe.

    Danke für Die Hilfe soweit!

    Hallo,
    super – freut uns. Danke für die Rückmeldung.

    Leider habe ich jetzt herausgefunden, dass das Theme nicht mit PHP 8 funktioniert, so dass ich noch 3 Tage Zeit habe dieses auf ein anderes umzustellen bzw. die aktualisierte Version zu kaufen …

    Da hast du ja nicht gerade die große Auswahl. 🤷‍♂️

    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

    Viele Grüße
    Hans-Gerd

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Umstellungsprobleme PHP 7.4>8.0 und auf SSL … Kein Login mehr möglich :-(“ ist für neue Antworten geschlossen.