Support » Allgemeine Fragen » Umstrukturierung WP-Online-Shop

  • Gelöst Thobie

    (@thobie)


    Moin,

    ich habe einige Umstrukturierungen, Upgrades und Zusammenlegungen von Paketen mit Domains bei meinem Provider durchgeführt und einige alte Zöpfe abgeschnitten.

    Dadurch habe ich derzeit nicht mehr so viele SSL-Zertifikate zur Verfügung wie bisher.

    Daher hat nun mein kleiner Buch-Shop, der bisher unter https://www.buch-schmie.de zu erreichen war und auch so in den Einstellungen von WP eingetragen war, kein SSL-Zertifikat mehr und sollte nun nur noch unter http://www.buch-schmie.de zu erreichen sein.

    Leider kann ich aber sowohl Frontend als auch Backend des Shops nicht mehr erreichen, unter keiner der genannten URLS.

    Wie bekomme ich wieder Zugang zum Backend und kann auch die Website wieder aufrufen?

    Geüße aus Hamburg

    Thobie

    • Dieses Thema wurde geändert vor 1 Jahr, 8 Monaten von Thobie.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Dass du „derzeit nicht mehr so viele SSL-Zertifikate zur Verfügung [hast] wie bisher“ und für die URL mit www kein Zertifikat hast, für die ohne www schon … ist alles kein Thema für ein WordPress-Supportforum (auch dann nicht, wenn du dann unter diesen Domains WordPress-Installationen hast). Bitte wende dich an den Support deines Webhosters. Die erklären dir sicher gerne, wie du ein SSL für die komplette Domain (mit und ohne www) nutzen kannst und was die Ausstellung weiterer Zertifikate unter Umständen kostet.

    Wenn du die WordPress-URL auf verschlüsselte Übertragung mit https://… umgestellt hast, aber kein Zertifikat eingerichtet ist, läd der Webbrowser die Webseiten nicht, weil er die Verschlüsselung nicht herstellen kann – es fehlt ja das benötigte Zertifikat.
    Wie du die fehlerhafte Einstellung wieder ändern kannst, haben wir hier im Forum ein gutes dutzenmal besprochen. Ich verstehe aber, wenn du die nicht besonders hilfreiche Suche nicht nutzen möchtest. Meine Anleitung dazu habe ich deshalb hier abgelegt: https://pixolin.de/website-und-wordpress-url-korrigieren/

    Hallo,
    und ergänzend zu der Antwort von Bego wundere ich mich, dass dir dein Hoster keine kostenlosen Letsencrypt-Zertifikate anbietet. Dann wäre die ganze Prozedur nicht notwendig. Da würde ich an deiner Stelle über einen Wechsel zu einem anderen Hoster nachdenken.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller Thobie

    (@thobie)

    Moin,

    mir ist heute auch noch eingefallen, dass sich der Eintrag der URL in der Datenbank ändern lässt.

    Aber: Nichts geht!

    Folgende drei Versuche:

    1. Datenbankeintrag-Änderung

    siteurl: Geändert.
    home: In der Datenbank nicht vorhanden.

    2. Wp-config.php mit dem auf der Website angegebenen Eintrag ergänzt. Backend lässt sich über die angegebene URL nicht aufrufen.

    3. Die harte Tour. Ich habe in meinem Paket bei meinem Provider fünf Domains und ein freies SSL-Zertifikat. Ich habe dem Buchshop das Zertifikat wieder zugewiesen. Erwartungsgemäß kann ich Front-/Backend wieder aufrufen. Ändere ich in den Einstellungen sowohl WordPress- als auch Website-Adresse auf http://, muss ich mich neu einloggen. Die Website-Adresse ist dann korrekt, WordPress ändert aber die WordPress-Adresse wieder auf https, einerlei, ob das Zertifikat noch zugewiesen ist oder zwischenzeitlich wieder beim Provider auf eine andere Domain zurückverwiesen wurde.

    Cache des Browsers mehrfach gelöscht.

    Der Browser greift in jedem Fall immer wieder auf das Front-/Backend mit dem Zertifikat zu.

    Ich weiß im Moment keine Lösung.

    Grüße aus Hamburg

    Thobie

    • Diese Antwort wurde geändert vor 1 Jahr, 8 Monaten von Thobie.

    1. Datenbankeintrag-Änderung
    siteurl: Geändert.
    home: In der Datenbank nicht vorhanden.

    Das wäre recht ungewöhnlich. Meistens wird aber einfach übersehen, dass Tabellen in phpMyAdmin auf mehreren Seiten angezeigt werden und man blättern muss, um an den Eintrag home zu kommen. Eine unvollständige Änderung erzeugt Probleme.

    Die Website-Adresse ist dann korrekt, WordPress ändert aber die WordPress-Adresse wieder auf https …

    In diversen Tutorials wird empfohlen, in der wp-config.php Konstanten für die Website- und WordPress-URL einzutragen, z.B.

    define( 'WP_SITEURL', 'http://example.com/wordpress' );
    define( 'WP_HOME', 'http://example.com' );

    Dieser Eintrag überschreibt dann den Eintrag in der Datenbank. Ich halte es für den besseren Weg, die Konstanten nicht fest vorzugeben (und sofern in der wp-config.php vorhanden, zu löschen) und statt dessen die Änderung in der Datenbank vorzunehmen.

    Grundsätzlich sollte für die Anmeldung im Backend immer eine verschlüsselte Verbindung verwendet werden, weil sonst jeder im gleichen Netzwerk die Zugangsdaten im Klartext (!) mitlesen kann. Das ist so sicher, als würdest du im Café, in der Bahn oder wo auch immer du dich gerade in deine Website einloggst, laut die Zugangsdaten in den Raum rufen. Allerdings setzt eine verschlüsselte Verbindung (wie bereits erläutert) zwingend ein SSL-Zertifikat voraus.
    In der wp-config.php kann eine weitere Konstante definiert werden, damit das Backend ausschließlich über eine verschlüsselte Verbindung aufgerufen werden kann:
    define( 'FORCE_SSL_ADMIN', true );

    Schau mal, ob diese Zeile vorhanden ist und lösche sie ebenfalls. Du solltest dir aber darüber klar sein, dass die Anmeldung dann unsicher ist (siehe oben).

    Thread-Ersteller Thobie

    (@thobie)

    Moin, Bego,

    ich sage ja, ich verstehe es nicht. Nichts geht.

    Ich habe nun in der Datenbank die Einträge siteurl und home gefunden und beide in http://www.buch-schmie.de geändert.

    Beim Aufruf von Front-/Backend ruft der Browser wieder die https-Site auf und gibt eine Fehlermeldung.

    Grüße aus Hamburg

    Thobie

    Hast du denn mal einen Blick in die wp-config.php geworfen?

    Thread-Ersteller Thobie

    (@thobie)

    Moin, Bego,

    Problem gelöst. Aber auf andere Weise.

    Ich habe ja ein Upgrade meines Pakets bei meinem Provider durchgeführt. Ich habe übersehen, dass ich nicht nur 5 inklusive Domains, sondern auch 5 inklusive, freie SSL-Zertifikate in diesem Paket habe.

    Also habe ich dem Buchshop nun eines dieser Zertifikate zugewiesen.

    Alles funktioniert. Zugriff zu Frontend und Backend.

    Woran das eigentliche Problem aber lag, ist mir unklar.

    Grüße aus Hamburg

    Thobie

    Thread-Ersteller Thobie

    (@thobie)

    Moin,

    ich reiche diese Antwort des Supports meines Providers nach, das das Problem eventuell auch ohne Zertifikat gelöst hätte:

    „Damit die Webseite ohne HTTPS erreicht wird, muss die Option Force SSL entfernt werden.

    Im [Provider] Kunden-Login ist diese Einstellung in Ihrem Paket bei der linken Menüleiste unter „Ihr Paket- Troubleshooting – Force SSL entfernen“ zu entnehmen.

    Sollten Sie eine weitere 301 Weiterleitung, sei es mit .htaccess oder auch über ein Plug-in haben, deaktivieren Sie diese, damit die Webseite ohne SSL Verschlüsselung zugreifen kann.“

    Grüße aus Hamburg

    Thobie

    Hallo,
    na ja, dass der Eintrag (Force SSL) aus der .htaccess in dem Fall gelöscht werden muss, dürfte eigentlich klar sein. Davon waren wir an sich ausgegangen. Aber danke für die Info.
    Viele Grüße
    Hans-Gerd

    Wenn alle Hinweise (auch zu define( 'FORCE_SSL_ADMIN', true );) mit stoischer Gelassenheit ignoriert werden, überlege ich mir auch zweimal, ob ich künftige weitere Frage beantworte. ¯\_(ツ)_/¯

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Umstrukturierung WP-Online-Shop“ ist für neue Antworten geschlossen.