Support » Installation » Umzug auf anderen Server, Seite baut nicht auf

  • Gelöst kle907

    (@kle907)


    Hallo!

    Ich bin gerade dabei, mehrere WordPress Seiten zu einem anderen Provider umzuziehen.

    Ich bin wie folgt vorgegangen:
    – Domain umgezogen und auf das Verzeichnis verlinkt
    – Datenbank Backup aufgespielt, auch mal überprüft im PHPMyAdmin, alles da
    – Backup der HTML/PHP Daten aufgespielt
    – wp-config.php auf die neuen Datenbankdaten editiert

    Sollte es gewesen sein – nur wird derzeit eine weiße Seite angezeigt. Was kann ich tun? URL siehe Link zur Seite.

    Ich würde eventuell WordPress einfach drüberinstallieren, aber sind dann meine Daten in der Datenbank pfutsch?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Im Moment habe ich den Eindruck, dass PHP nicht gerendert sondern als HTML-Kommentar angezeigt wird.

    Erstell doch mal eine Datei phpinfo.php mit folgendem Inhalt: <?php phpinfo(); und ruf dann https://example.com/phpinfo.php (natürlich mit deiner Domain) im Browser auf. Da müsste dir angezeigt werden, welche PHP-Version aktuell verwendet wird.

    PHP Version 7.2.32

    Schön. Es ging aber nicht darum, welche PHP-Version du verwendest, sondern ob dieser einfache PHP-Befehl von deinem Webserver ausgeführt wird. Und genau das wird er nicht. Statt dessen sehe ich wieder eine leere Seite und in den Entwickler-Tools des Browsers:

    Screenshot Einstellungen

    So, zweite Seite – gleiches Problem:
    http://www.jaegergarde.de

    Auf dem selben Account läuft noch eine WordPress Installation, die ich aber neu aufgesetzt habe – am Server kann es eigentlich nicht liegen…

    und uneigentlich sieht das so aus, als ob da PHP nicht richtig läuft.

    Wenn du eine einfache .php-Datei mit einem einfachen PHP-Befehl nicht ans Laufen bekommst, ist es ganz bestimmt kein WordPress-Problem. 🙂

    Oh, Antwortüberschneidung.
    Du hast recht, die vorgeschlagene Datei wird in DEM Verzeichnis nicht ausgeführt.

    Ich hatte eine ähniche Datei ein Verzeichnis eine Ebene tiefer, da ging es. Wie kann ich machen, dass das in dem Verzeichnis ausgeführt wird? Ich hab mal alle Rechte auf 755 gesetzt – hat keine Besserung gebracht. Und in einem anderen Unterverzeichnis geht es ja komischwerweise

    Die WordPress-Dateien müssen auf 644, die Verzeichnisse auf 755 gesetzt werden und dem Benutzer zugewiesen sein, der PHP-Befehle ausführen darf. Aber ich glaube weniger, dass es sich um ein Problem mit den Dateirechten handelt, sondern PHP fehlerhaft aufgesetzt wurde. Bei welchem Webhoster bist du denn?

    Entwickler-Tools zeigt PHP 5

    PHP5?

    Fehler gefunden an der Hotline dess Providers!
    In der .htaccess war ein Bug.


    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Da hatte ich wohl auf dem alten Server die PHP Version erzwungen und diese erzwungene Version war nicht verfügbar. Aber danke, durch die Antworten bin ich dem auf die Spur gekommen!

    …und wieder haben sich die Antworten überschnitten…

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)