Support » Installation » Umzug von com nach org – Fotos fehlen

  • Gelöst reisezeiten

    (@reisezeiten)



    Hallo! Ich bin von WP.com nach WP.org „umgezogen. Meine Beiträge konnte ich importieren inklusive der Bilder. Ich bekomme aber jetzt die Rückmeldung, dass ein Benutzer (Leser, Abonnement) die Texte zwar lesen kann, aber keine Bilder sieht.
    2. Ich habe die Beiträge auf „privat“ gestellt, weil sie nur für registrierte Leser zu lesen sein sollen (bzw. die Seite zu sehen); es sind nur kleine Reiseberichte für den privaten Kreis. Allerdings haben die Überschriften meiner Beiträge jetzt den Zusatz „Privat“…
    3. habe jetzt die WP-App geladen auf dem Smartphone. Dort sind keine Beiträge zu sehen…
    Danke für eine Unterstützung.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Im Moment bekomme ich bei allen im Menü verlinkten Beiträge nur den Hinweis, dass der Inhalt nicht existiert. Irgendwas ist da nicht richtig eingestellt, aber ich kann dir mit den wenigen Informationen nicht sagen, was. Sind die in der Navigation verlinkten Beiträge veröffentlicht oder aktuell als Entwurf gespeichert?

    WordPress fügt privaten Beiträgen automatisch einen Zusatz „Privat“ hinzu. Wenn du das nicht möchtest, kannst du die Funktion durch ein Code Snippet ändern, das du mit dem Plugin Code Snippets hinzufügst:

    function title_format($content) {
    return '%s';
    }
    add_filter('private_title_format', 'title_format');
    add_filter('protected_title_format', 'title_format');

    (vgl. CSS-Tricks: Remove Private Protected from Posts)

    Danke für Deine Antwort. Ja, alles ist veröffentlicht. Ich selbst kann auch alles sehen an PC undTablet, nur die App meldet auch, dass es keine Inhalte gibt. Der Besucher sieht
    den Text, aber keine Bilder.-
    Irgendwie fange ich ein bisschen wieder von vorne an… Aber .com ist nicht .org, das wusste ich leider vorher nicht, habe mich immer wieder nur gewundert bei den Beschreibungen.

    Danke. Und auch für den „Privat“-Tipp. Ich hoffe, ich komme dahinter, wo das Häkchen fehlt… oder Ähnliches….
    Schöne Grüße, Renate

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Meine Stichprobe zeigt, dass die Bilder aktuell womöglich noch auf den alten Blog verlinken. Zum Beispiel:
    https://winteradeblog.files.wordpress.com/2018/09/20180915_1642183651481648012314972.jpg

    Aber das Bild ist dort nicht zu erreichen. Da kommt ein 403.

    War der WP.com-Blog noch erreichbar, als du den Impoprt angeworfen hast? Sonst wird er die Bilder nicht geholt haben können … In der Export-Datei sind die Bilder ja nicht enthalten.

    Gruß, Torsten

    Hallo Torsten, vielen Dank.
    Ja, der Gedanke, dass die Fotos nicht verlinkt sind, kam mir heute auch – die einzig logische Erklärung. Der WP.com-Blog existiert noch; ich konnte allerdings die Bilder aus der Mediathek nicht importieren, das habe ich dann „per Hand“ nachgeholt (sind nicht so viele). Insofern…
    Ich habe aber noch nicht herausgefunden, wie ich sie neu verlinken kann.. die einzige Idee ist löschen und wieder einfügen… 🙁
    Dieser ganze Import war nicht so einfach, ich musste Seiten neu anlegen etc.
    In der wordpress-android-App werden gar keine Beiträge angezeigt, nur das Menü und die Startseite. Das heißt, ich kann z. B. auf die Seite „Archiv“ klicken, die Beitragsüberschrift wird dann auch angezeigt, aber nichts sonst, kein Text und Fotos ja sowieso nicht – siehe oben.
    Danke und Grüße! Renate

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Wenn der Blog noch online ist, dann kannst du beim Import unten den Haken setzen, dass er die Bilder importieren soll. Dann holt er sich die Daten online und überträgt sie in das Blog.

    Dazu musst das Blog (https://winteradeblog.wordpress.com/) aber wieder auf öffentlich gestellt werden, sonst kommst du an die Bilder nicht ran.

    Vielleicht startest du nochmal von vorne?

    Oder du importierst im Nachinein, dann hättest du die Bilder schon mal in der Mediathek und musst nur überall die Links dann manuell ändern.

    Gruß, Torsten

    Hallo Torsten, gute Idee: Ich habe den alten Blog auf „öffentlich“ gestellt, und dann funktionierte der Umzug mit Fotos – jedenfalls mit den allermeisten, nacharbeiten muss ich trotzdem. Aber ich bin SEHR zufrieden!
    Danke! Grüße – Renate

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)