Support » Installation » Uncaught Error – /script-loader.php

  • Sehr geehrtes Support Team,

    Ich erhalte folgenden Fehler in meinem error_log angezeigt:

    Stack trace:
    #0 ./wp-includes/class-wp-hook.php(288): wp_localize_jquery_ui_datepicker(“)
    #1 ./wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array)
    #2 ./wp-includes/plugin.php(478): WP_Hook->do_action(Array)
    #3 ./wp-includes/script-loader.php(2670): do_action(‚wp_enqueue_scri…‘)
    #4 ./wp-includes/class-wp-customize-manager.php(455): wp_enqueue_scripts()
    #5 ./wp-includes/class-wp-customize-manager.php(552): WP_Customize_Manager->wp_die(0, ‚Non-existent ch…‘)
    #6 ./wp-includes/class-wp-hook.php(288): WP_Customize_Manager->setup_theme(“)
    #7 ./public_html/sites/lifep in ./wp-includes/script-loader.php on line 2355
    [15-Mar-2020 08:12:26 UTC] PHP Warning: array_values() expects parameter 1 to be array, null given in ./wp-includes/script-loader.php on line 2346
    [15-Mar-2020 08:12:26 UTC] PHP Warning: array_values() expects parameter 1 to be array, null given in ./wp-includes/script-loader.php on line 2347
    [15-Mar-2020 08:12:26 UTC] PHP Warning: array_values() expects parameter 1 to be array, null given in ./wp-includes/script-loader.php on line 2350
    [15-Mar-2020 08:12:26 UTC] PHP Warning: array_values() expects parameter 1 to be array, null given in ./wp-includes/script-loader.php on line 2351
    [15-Mar-2020 08:12:26 UTC] PHP Warning: array_values() expects parameter 1 to be array, null given in ./wp-includes/script-loader.php on line 2352
    [15-Mar-2020 08:12:26 UTC] PHP Fatal error: Uncaught Error: Call to a member function is_rtl() on null in ./wp-includes/script-loader.php:2355

    Ich habe alle updates durchgeführt und nutze die WP Version 5.3.2.
    Ich hoffe Ihr habt hierzu eine Lösung und könnt mir helfen.

    LG, Alex

    • Dieses Thema wurde geändert vor 4 Jahren, 3 Monaten von wci.
Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Dazu benötigen wir mehr Infos:
    Werkzeuge > Website-Zustand (gibt es hier Fehlermeldungen? Welche?) > Bericht > per Button in die Zwischenablage kopieren, dann hier unverändert in eine Antwort einfügen.

    Thread-Starter wci

    (@wci)

    Hallo Bego Mario,

    So wie ich das sehe sieht alles OK und normal aus.
    Website Zustand – GOOD
    Screenshot – https://www.screencast.com/t/cbYFR5BE8NmZ

    Den Fehler habe ich bemerkt als ich beim Sydney Theme eine Einstellung ändern wollte. Design > Customer
    Screenshot > https://www.screencast.com/t/ol2ytMisL

    Dann habe ich das letzte Update des Themes ein downgrade gemacht durch backup files und habe WP nochmals neu installiert.

    Aktuell ist der Fehler nur im error_log zu sehen, aber nicht mehr bei dem Theme selbst.

    LG, Alex

    • Diese Antwort wurde geändert vor 4 Jahren, 3 Monaten von wci.
    • Diese Antwort wurde geändert vor 4 Jahren, 3 Monaten von wci.
    • Diese Antwort wurde geändert vor 4 Jahren, 3 Monaten von wci.

    Das hilft uns nicht weiter.

    War an der Beschreibung, wie du an den Website-Bericht kommst, irgendwas missverständlich?

    Thread-Starter wci

    (@wci)

    Hallo nochmal,

    jetzt habe ich es begriffen. Bericht in Zwischenablage kompieren und einfügen. Wer lesen kann ist im Vorteil 🙂

    
    ### wp-core ###
    
    version: 5.3.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%category%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: .
    wordpress_size: loading...
    uploads_path: ./wp-content/uploads
    uploads_size: loading...
    themes_path: ./wp-content/themes
    themes_size: loading...
    plugins_path: ./wp-content/plugins
    plugins_size: loading...
    database_size: loading...
    total_size: loading...
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Sydney Child (sydney-child)
    version: 1.0
    author: aThemes
    author_website: http://athemes.com
    parent_theme: Sydney (sydney)
    theme_features: siteorigin-panels, post-thumbnails, automatic-feed-links, title-tag, menus, html5, post-formats, custom-background, align-wide, custom-header, infinite-scroll, widgets
    theme_path: ./wp-content/themes/sydney-child
    
    ### wp-parent-theme ###
    
    name: Sydney (sydney)
    version: 1.58 (latest version: 1.60)
    author: aThemes
    author_website: https://athemes.com/
    theme_path: ./wp-content/themes/sydney
    
    ### wp-themes-inactive (5) ###
    
    Neve: version: 2.5.4, author: ThemeIsle (latest version: 2.6.2)
    Twenty Nineteen: version: 1.4, author: WordPress-Team
    Twenty Seventeen: version: 2.2, author: WordPress-Team
    Twenty Sixteen: version: 2.0, author: WordPress-Team
    Twenty Twenty: version: 1.1, author: WordPress-Team
    
    ### wp-plugins-active (51) ###
    
    Add-on Contact Form 7 - Mailpoet 3: version: 1.3.13, author: Tikweb
    Add Categories to Pages.: version: 1.2, author: a.ankit
    Akismet Anti-Spam: version: 4.1.3, author: Automattic
    Anti-Malware Security and Brute-Force Firewall: version: 4.19.50, author: Eli Scheetz
    Autoptimize: version: 2.6.2, author: Frank Goossens (futtta)
    Bounce Handler Mailpoet: version: 1.3.20, author: Tikweb
    Broken Link Checker: version: 1.11.11, author: ManageWP
    Cloudflare Flexible SSL: version: 1.3.0, author: One Dollar Plugin
    Collapse-O-Matic: version: 1.7.11, author: twinpictures, baden03
    Contact Form 7: version: 5.1.7, author: Takayuki Miyoshi
    Contact Form 7 Captcha: version: 0.0.3, author: 247wd
    Contact Form 7 Conditional Fields: version: 1.8.3, author: Jules Colle
    Contact Form 7 Datepicker: version: 2.6.0, author: Aurel Canciu
    Contact Form 7 Skins: version: 2.2.2, author: Neil Murray
    CP Media Player - Audio Player and Video Player: version: 1.0.38, author: CodePeople
    Download Manager: version: 3.0.9, author: W3 Eden
    Duplicate Page: version: 4.1, author: mndpsingh287
    Easy Table of Contents: version: 2.0.3, author: Steven A. Zahm
    Elementor: version: 2.9.6, author: Elementor.com
    Email Log: version: 2.3.2, author: Sudar
    Enable Media Replace: version: 3.3.11, author: ShortPixel
    EWWW Image Optimizer: version: 5.2.2, author: Exactly WWW
    Exit Notifier: version: 1.7.5, author: Curtis V. Schleich
    Flamingo: version: 2.1.1, author: Takayuki Miyoshi
    Font Awesome: version: 4.0.0-rc17, author: Font Awesome
    FooTable: version: 0.3.1, author: Brad Vincent
    Google Tag Manager for WordPress: version: 1.11.3, author: Thomas Geiger
    Honeypot for Contact Form 7: version: 1.14.1, author: Nocean
    Insert Headers and Footers: version: 1.4.5, author: WPBeginner
    Insert HTML Snippet: version: 1.3.1, author: xyzscripts.com
    Internal Links Manager: version: 1.2.7, author: webraketen
    LearnPress: version: 3.2.6.6, author: ThimPress
    MailPoet 3 (New): version: 3.46.2, author: MailPoet
    Quiz And Survey Master: version: 6.4.4, author: ExpressTech
    Redirection for Contact Form 7: version: 1.3.5, author: Query Solutions
    Share Buttons by AddThis: version: 6.2.6, author: The AddThis Team
    Shortcodes Ultimate: version: 5.8.0, author: Vladimir Anokhin
    Simple Calendar: version: 3.1.22, author: Simple Calendar
    Simple Custom CSS: version: 4.0.3, author: John Regan, Danny Van Kooten
    SSL Insecure Content Fixer: version: 2.7.2, author: WebAware
    Standout CSS3 Buttons: version: 0.3.0, author: Jimmy Peña
    The GDPR Framework: version: 1.0.34, author: Data443
    TinyMCE Advanced: version: 5.3.0, author: Andrew Ozz
    Tracking Code Manager: version: 1.12.1, author: IntellyWP
    Ultimate FAQ: version: 1.8.31, author: Etoile Web Design
    Ultimate Nofollow: version: 1.4.8, author: 5fifty
    Website Tools by AddThis: version: 3.2.6, author: The AddThis Team
    Woody ad snippets (PHP snippets | Insert PHP): version: 2.3.1, author: Will Bontrager Software, LLC <will@willmaster.com>, Webcraftic <wordpress.webraftic@gmail.com>
    Wordfence Security: version: 7.4.6, author: Wordfence
    WP Super Cache: version: 1.7.1, author: Automattic
    Yoast SEO: version: 13.2, author: Team Yoast
    
    ### wp-plugins-inactive (12) ###
    
    Classic Editor: version: 1.5, author: WordPress Contributors
    Gutenberg Blocks and Template Library by Otter: version: 1.4.1, author: ThemeIsle
    Health Check & Troubleshooting: version: 1.4.2, author: The WordPress.org community
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg
    MP3-jPlayer: version: 2.7.3, author: Simon Ward
    One Click Demo Import: version: 2.5.2, author: ProteusThemes
    Popups - WordPress Popup: version: 1.9.3.8, author: timersys
    ProfitBuilder: version: 2.5.9, author: Sean Donahoe
    Redirection: version: 4.7.1, author: John Godley
    s2Member Framework: version: 200301, author: WP Sharks
    Sydney Toolbox: version: 1.09, author: aThemes
    WP-Optimize - Clean, Compress, Cache: version: 3.0.16, author: David Anderson, Ruhani Rabin, Team Updraft
    
    ### wp-media ###
    
    image_editor: EWWWIO_GD_Editor
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.25
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.0-957.21.3.el7.x86_64 x86_64
    httpd_software: Apache
    php_version: 7.1.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 9999
    time_limit: 120
    memory_limit: 3072M
    max_input_time: 120
    upload_max_size: 64M
    php_post_max_size: 512M
    curl_version: 7.68.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.29
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: ./wp-content
    WP_PLUGIN_DIR: ./wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 3072M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Auch wenn deine WordPress-Installation scheinbar einen sehr üppig bemessenen Arbeitsspeicher zugewiesen bekommen hat, ist die Anzahl an (nicht unbedingt leichtgewichtigen) Plugins enorm. Ich würde auf jeden Fall versuchen, das zu reduzieren: Simple Custom CSS brauchst du nicht, wenn du deine CSS-Regeln im Customizer einträgst, SSL Insecure Content Fixer ist überflüssig, wenn deine Website korrekt auf https umgestellt wurde, Aksimet entspricht nicht einmal unseren Datenschutzvorgaben, usw.

    Dein Child-Theme kann ich nicht beurteilen, aber dein Parent Theme ist nicht aktuell. Hier solltest du auf die neueste Version updaten.

    Die verwendete PHP-Version ist inzwischen veraltet, hier solltest du auch ein Update vornehmen.

    Wenn dann der Fehler weiter auftritt (du hast geschrieben, er wäre inzwischen nicht mehr sichtbar), solltest du mit dem Plugin Health Check unter Werkzeuge > Problembehandlungsmodus ausprobieren, ob sich die Fehlerursache eingrenzen lässt.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das Thema „Uncaught Error – /script-loader.php“ ist für neue Antworten geschlossen.