Support » Allgemeine Fragen » Unendlich Scrollen ausschalten auf der Newspage

  • Hallo,

    bin ein wenig am verzweifeln und hoffe ihr könnt mir helfen.
    Ich versuche in den News das unendlich Scrollen abzuschalten, da bei Handys das immer wieder zu Problemen führt. Bei PC, IPAD etc. nicht.

    Ich habe Jetpack installiert und diese Funktion versucht zu nutzen mit dem umschalten „wie früher“ mehr Beiträge laden. Leider ohne Erfolg.
    Früher ging das mal, da ich aber immer das aktuelle WordPress nutze, würde ich gerne das irgendwie wieder hinbekommen.

    Ich nutze WordPress 5.7 mit der Theme – LandscapeVersion: 2.0.1 (letzte Version)
    Falls es einen Experten unter euch gibt, wäre ich für jede Hilfe dankbar.

    Bei Jetpack habe ich alle Versionen versucht und auch mal ohne Jetpack.
    Leider ist das Verhalten gleich. Hätte das gerne so eingestellt.

    Unendlich Scrollen
    Sorge für ein reibungsloses, unterbrechungsfreies Leseerlebnis, indem mehr Inhalte geladen werden, wenn Besucher auf deinen Archivseiten nach unten scrollen.

    Mehr Beiträge in Seite mit einem Button laden

    Vielen Dank für eure Hilfe.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Hallo,
    ich habe das Theme gerade mal auf einer Testinstanz mit vielen Beiträgen installiert. Wenn ich das richtig unter Design > Customizer sehe, berücksichtigt das Theme nicht die bei Einstellungen > Lesen angegebene Option „Blogseiten zeigen maximal 12 Beiträge“ (Die Anzahl kann man bei den Einstellungen entsprechend seinen Wünschen ändern). Zumindest konnte ich das bei mir reproduzieren. In der Regel bringt in dem Fall das Theme nach 12 Beiträgen im unteren Bereich über dem Footer eine Paginierung, so dass man dann auf eine Seite mit weiteren (ältere) Beiträgen klicken kann. Das sieht dann z. B. so aus:
    Paginierung
    Vermutlich wird dir in dem Fall nichts anderes übrig bleiben, als ein anderes Theme zu wählen.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu bitte auch mal die Informationen in dem Beitrag zu Health Check durch.
    Jetpack ist übrigens auch unter datenschutzrechtlichen Gesichtspunkten problematisch, siehe hier
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller hatscher4711

    (@hatscher4711)

    Vielen Lieben Dank für deine Unterstützung.

    Was merkwürdig ist, das es mal funktioniert hat, bei einer älteren WordPress Version. Ich werde deinen Rat hier folgen und mich hier einlesen und das versuchen. Danke auf jeden Fall an dich Hans-Gerd.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    hast du denn schon überprüft, was bei Einstellungen > Lesen unter „Blogseiten zeigen maximal xx Beiträge“ eingetragen ist?
    Es wäre etwas seltsam, wenn ein Entwickler, diese Option wieder entfernt. Evtl. ist es hilfreich, wenn du das Problem im Support-Forum des Entwicklers ansprichst.
    Abgesehen davon ist es keine gute Lösung, wenn keine Paginierung vorgesehen ist. Wir haben beispielsweise eine Webseite mit knapp 800 Beiträgen. Das würde in dem Fall endlos dauern, bis die Seite komplett aufgebaut ist.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller hatscher4711

    (@hatscher4711)

    Hallo Hans-Gerd,

    ja, die steht bei uns auf 3 derzeit haben auch 5, 10, 15 versucht, alles ohne Erfolg. Früher hat diese Funktion zu 100% funktioniert und am Template hat sich zwar mal ein Update ergeben, allerdings ging es vorher auch schon nicht mehr.
    Habe aber auch das mal zurückgesetzt und das alte Template genutzt, gleiches Ergebnis, es kommt immer zum Endlos Scrollen auf der Newspage.

    Habe selbst mal das Jetpack komplett gelöscht und nur die WordPress Einstellungen versucht, gleiches Ergebnis.

    Ich mein es hat vor ca. 6-7 Monaten noch einwandfrei funktioniert, ich weiß aber nicht welche WordPress Version das damals war. Seit dem ist dieses endlos „scrollen“ aktiviert. Ohne das ich hier was selbst verändert habe.

    Ich melde das mal bei den Entwicklern und hoffe das die hier mir was sagen können.
    Danke und viele Grüße Christian

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    danke für die Info. Dann warten wir mal ab, was sich ergibt.
    Viele Grüße
    Hans-Gerd

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)