• Gelöst groanz

    (@groanz)


    Hallo Zusammen

    Hab hier ein eher untypisches WordPress Problem…
    Das Problem was bei mir besteht, ist das bei jedem internen und externen verlinkungen ein Neuer Tab im Webbrowser geöffnet wird, und dies Seit gestern.

    Da ich ein gekauftes Theme verwende und seit ungefähr 7 Monaten nichts mehr aktualisiert habe, denke ich mal das es nicht an einem solchen Problem liegen kann (OK. Sicherheitgründen) Jedoch muss ich noch erwähnen das in diesem Theme vieles noch nachträglich von mir überarbeitet wurde, hatte aber nie probleme mit den Neuen TABS.

    Was ich noch erwähnen muss, habe mit dem HostSupporter kontakt aufgenommen, versuchten das Problem zu finden, doch fanden es nicht. Wir gingen in die üblichen Einstellungen: Design > Menü, Seiten > Bearbeiten, Permalink > Einstellungen und fangen rein garnichts was das NEUE TAb generiert.

    Also nach dem Telefonsupport, kontaktierte ich vor 2 Stunden den Mail Support, da hies es vor circa 15minuten. WordPress Support kontaktieren. OK nun bin ich hier.

    Hab zwar gestern eine .hacces datei überarbeitet bzw. diese unbenannt in irgendetwas (Damit diese Datei nicht mehr funktionsfähig ist) Wozu ich das gemacht habe? Nun ich hatte vor kurzem festgestellt das eine .hacces datei zuviel im WP vorhanden war, genau gesagt eine, die Javascripte blockierte, aber da bin ich selber schuld! Deshalb hab ich sie gestern gelöscht und auch, erst seit Gestern besteht das Problem.

    Alles fing damit an: Ich wollte mein Formular mit einem Google recaptcha ausrüsten.

    PS: Alle HTML verlinkungen sind sauber programmiert und es sind keine _blank hinterlegt. Ausgenommen bei dennen gbewusst ein neuer tab erscheinen soll.

    So ich hoffe, das ich mein Problem gut geschildert hab.

    • Dieses Thema wurde geändert vor 7 Jahren, 10 Monaten von groanz.
Ansicht von 1 Antwort (von insgesamt 1)
  • Thread-Starter groanz

    (@groanz)

    Problem gelöst…
    Das Problem war schlichtweg ein versteckter <base href=“http:wwww.meine-seite.de“ target=“_blank“>

    Diese eine Codezeile vermieste mir heute den ganzen Tag!
    Jedoch war diese Codezeile nicht im Header.php sondern woanders versteckt.

    NORMALERWEISE ist dieser Code in der Header.php in <header> falls jemand ein gleiches Problem haben sollte.

    Wie kam ich zu dieser lösung? Ich fand diesen Code per zufall und wusste zunächst nicht was es bewirkte, so recherierte ich im internet nach dem befehl <base> und fand die lösung auf https://wiki.selfhtml.org/wiki/HTML/Kopfdaten/base

Ansicht von 1 Antwort (von insgesamt 1)
  • Das Thema „ungewollte neue Tabs – Webbrowser“ ist für neue Antworten geschlossen.