Support » Installation » ungültige JSON Antwort/unerwartetes REST-API Ergebnis

  • Gelöst kirstenmanert

    (@kirstenmanert)


    Guten Tag!
    Ich versuche aktuell WordPress auf einem virtuellen Ubuntu 18.04 Server manuell zu installieren. Das habe ich schon mehrere Male mit verschiedenen Anleitungen versucht. Aber im Endeffekt habe ich diese Anleitung befolgt: https://www.digitalocean.com/community/tutorials/how-to-install-wordpress-with-lamp-on-ubuntu-18-04-de
    WordPress ist unter der Domain erreichbar und es hat alles geklappt. Ich habe 1:1 die Anleitung befolgt. Als ich nun meine erste Seite veröffentlichen wollte kam die Fehlermeldung: Veröffentlichung fehlgeschlagen. Fehlermeldung: Die Antwort ist keine gültige JSON-Antwort. Ich habe mir das Plugin Health Check & Troubleshooting geholt und mir die empfohlenen Optimierungen angeschaut. Dort werden die optionalen PHP-Module bcmath und imagick empfohlen. Es wird empfohlen PHP von 7.2 auf 7.3 zu aktualisieren und die REST-API kam zu einem unerwartetem Ergebnis. Hier der Pastebin Link zum Bericht des Plugins: https://pastebin.com/xwkE6Zy2
    Ich hoffe irgendjemand kann mir bitte helfen!

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hast du das Modul mod_rewrite aktiviert (a2enmod rewrite) und den Apache-Server anschließend neu gestartet (systemctl restart apache2)?

    Ändere in der /etc/apache2/sites-available/wordpress.conf den Inhalt auf

    <Directory /var/www/wordpress/>
            Options FollowSymLinks
            AllowOverride All
            Order allow,deny
            Allow from all
    </Directory>

    (mit deinem Web-Stammverzeichnis)

    Vielen Dank für die Antwort! Es hat geklappt! Man muss den Directory Block unter den Virtualhost Block schreiben!
    Vielen Vielen Dank!!!

    Moderator Bego Mario Garde

    (@pixolin)

    Freut mich, Danke für die Rückmeldung.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)