Support » Themes » Unterschiedliche Header Navigation in TwentyTwentyFour

  • Gelöst Blue2 GmbH

    (@blue2shop)


    Hallo,
    ich probiere mich gerade an dem neuen Theme. Mir ist aufgefallen dass der Navigation Block für die Blog-Startseite einen Zeilenumbruch in den Unterpunkten erzeugt

    Von jeder anderen Seite aus gehend passt die Ansicht

    Der Navigation Block ist im Header platziert. Er scheint sich jedoch auf dieser einen Seite anders darzustellen.
    Weiß jemand wie man das fixen kann, bzw. wo und wie ich mir einen Fehler eingehandelt habe?

    Vielen dank für die Unterstützung!

    Johannes

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Hallo,
    kann es sein, dass du das Problem gerade gelöst hast? – wenn ja, wäre die Lösung auch für Leserinnen und Leser des Forums interessant.

    Denkst du bitte daran, dann auch das Thema als gelöst zu markieren (siehe Eintrag in der Seitenleiste).

    Viele Grüße
    Hans-Gerd

    Es sieht so aus, als ob das Padding der „UL“ (unsortierte Liste der Navigation) unterschiedlich eingestellt ist. Hast du eigentlich zwei verschiedene Navigationen? Meint auf der Startseite eine andere als auf den anderen Seiten? Das würde ich noch mal über den Editor prüfen.

    Thread-Starter Blue2 GmbH

    (@blue2shop)

    Danke für die raschen Rückmeldung!

    @Hans-Gerd -> Nein, bisher leider keine Lösung gefunden. Und natürlich gebe ich es hier auch wieder sobald ich den Fehler behoben habe 😉

    @jonas -> Irgendwie schaut der Editor unterschiedlich aus.
    Gehe ich über den Website-Editor

    auf die Blog-Startseite (wo ich den Zeilenumbruch in der Navigation habe), dann schaut der Editor so aus – im Editor selbst wird das Dropdown ohne Zeilenumbruch dargestellt, im Frontend hat es wieder einen Umbruch (siehe Screenshot in meinen ersten Post).

    Gehe ich über den Website-Editor auf eine andere Seite (z.B. Büromöbel), dann wird der Editor so dargestellt

    Natürlich gibt es auch nur eine Header Vorlage, die bei allen Seiten, die ich bisher bearbeitet habe, auch so eingebaut ist.
    Einen Unterschied in den einzelnen Einstellungen zu der Navigation (auf z.B. der Blog-Startseite & Bürobel-Seite) kann ich nicht entdecken.
    Wo man das Verhalten der UL anpassen kann sehe ich leider nicht.

    Liebe Grüße
    Johannes

    Hallo,
    ich glaube, dass dir das Konzept des Website-Editors beim FSE (Full Site Editing) noch nicht klar ist.
    Leider kann ich im Rahmen des Forums das Thema sicherlich nicht ausführlich darstellen.
    Seiten und Beiträge werden ganz normal im Backend wie gehabt erstellt bzw. der Content eingepflegt, während die Templates den Rahmen für Beiträge und Seiten darstellen, also in welcher Form der Content dargestellt wird.

    Beim Wesite-Editor gibt es den Punkt „Templates“. Hier werden sozusagen die Vorlagen für Seiten und Beiträge angepasst. Da gibt es auch seit WordPress 6.3 (?) den Punkt „Seiten“. Da kann man in der Tat auch die Seiten bearbeiten.

    Hier ein Screenshot dazu (bei Klick auf das Bild, wird das Bild vergrößert):

    Website-Editor

    An sich wird es in vielen Fällen so sein, dass man (zumindest) Templates je nach Bedarf für die Seiten anpasst und damit festlegt, ob z. B. Seitenleisten verwendet werden.

    Hier ein Video dazu (bei Klick auf das Video, wird das Video vergrößert dargestellt):

    Video

    In dem Video wird hoffentlich das Konzept mit den Templates deutlich. Leider war da noch ein Fehler bei der Verlinkung im Menü. Deswegen kommt hier ein Video nach der Korrektur mit dem Frontend, wo die verschiedenen Templates verwendet werden.

    Video

    Viele Grüße
    Hans-Gerd

    @blue2shop

    Bist Du sicher, dass Du dieselbe Navigation für Startseite und die anderen Seiten nutzt? Guck mal unter Design > Website Editor > Navigation nach.

    Wenn da wirklich nur eine Navigation vorhanden ist, fällt mir nicht mehr ein, als ein BackUp herstellen, die Navigation löschen und neu erstellen. Es ist, wenn man sich die Navigationn mit den Entwickler-Tools anschaut, ein Padding „Thema“.

    Thread-Starter Blue2 GmbH

    (@blue2shop)

    @hage
    Danke für Deine Informationen! Sicherlich habe ich noch nicht den Sinn und die Funktion hinter allen Punkten durchschaut. Daher bin ich auf für Tipps und Infos, wie von Dir, sehr dankbar!
    Du schreibt das Seiten und Beiträge ganz normal über das Backend (wie bisher) bearbeitet werden sollten und der Website-Editor eher zum Erzeugen von Vorlagen verwendet wird. Das sehe ich ja auch so, bis auf eine Ausnahme halt.
    Die Startseite wird nur im Website-Editor als Blog-Startseite angezeigt (und kann dort editiert werden). Über den bisherigen Weg, der normalen Seiten-Bearbeitung, ist besagte Startseite gar nicht vorhanden.
    Ich kann diese eine Seite, die auch das gemeldete Probleme in der Anzeige der Unterpunkte der Navigation hat, ausschließlich über den Weg des Website-Editors editieren.

    Ich habe auch schon überlegt eine Home-Seite selbst zu erstellen, da habe ich aber in weiterer Folge das Problem dass die Verlinkung von z.B. Websiten-Logo nur automatisiert auf die Blog-Startseite zulässt…

    Die schritte in den kleinen Videos gehe ich auch so durch, da sehe ich keinen Unterschied zu meiner Herangehensweise.

    Liebe Grüße
    Johannes

    Thread-Starter Blue2 GmbH

    (@blue2shop)

    @elbsegler
    Hallo Jonas,
    danke für den Tipp, aber ich habe nur eine einzige Navigation – ich wusste gar nicht das mehrere möglich sind – das sehe ich alleine an dem Umstand das sich die Änderung des Inhalts der Navigation, dafür gehe ich über den Website-Editor weiter zu obersten Punkt Navigation und dort auf Bearbeiten, auf allen Webseiten auswirkt.

    Ich suche noch weiter nach dem Auslöser des Problems. Danke Dir für die Hilfestellung!

    Liebe Grüße
    Johannes

    Thread-Starter Blue2 GmbH

    (@blue2shop)

    Hallo,
    ich habe von meiner Seite eine Lösung für das beschriebene Problem gefunden und möchte meine Erfahrung hier kurz teilen.
    Das Problem und dessen Ursprung: Auf der Blog-Startseite wird das Untermenü vom Navigation Block herausgerückt und somit mit einem Zeilenumbruch dargestellt. Dies sieht man nur im Frontend, im Editor selbst wird es anders dargestellt

    Der Grund hierfür ist eine zugewiesene Farbe im Untermenü- und Overlay-Hintergrund

    Ab Zuweisung einer Hintergrundfarbe rückt der Text vom Untermenü etwas raus und verursacht somit (in meinen Fall) einen Zeilenumbruch.
    Dieser Effekt tritt ausschließlich auf der Blog-Startseite auf, auf allen anderen Seiten wird die Ausrichtung nicht verändert!

    Somit ist meine Lösung die Blog-Startseite komplett auszulassen und nicht in die geplante Webseiten-Struktur einzubinden.

    Danke für eure Unterstützung!
    Johannes

    Hallo,
    super, dass du eine Lösung gefunden hast und hier erläutert hast.

    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Gelöst
    Die Option findest du rechts in der Sidebar. Das habe ich jetzt schon gemacht.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)