Support » Allgemeine Fragen » Unterseiten nach gescheiterter Migration nicht mehr aufrufbar

  • Hallo,

    ich habe ein neues Template auf einer Subdomain erstellt und wollte dieses nun auf die Hauptdomain umziehen. Dafür habe ich zuerst der live-URL den Subdomain-Folder zugewiesen und dann im Backend unter „Einstellungen -> Allgemein“ die neue WP- und Website-URL eingetragen, also statt der Subdomain-URL die Hauptdomain-URL. Nach dem Abspeichern war dann Front- und Backend nicht mehr erreichbar. Nur durch Einträge in der wp-config.php habe ich es geschafft, wieder Zugang zu beidem zu bekommen. Doch im Frontend ist nur die Hauptseite zu sehen, alle Unterseiten verursachen einen 404er. In beiden Backends (live und Subdomain) sind nun in „Einstellungen -> Allgemein“ die Felder für WP- und Website-URL nicht mehr beschreibbar, weil ich die jeweils durch die wp-config.php „eingesetzt“ habe.

    Sieht jemand, wo mein Fehler liegt und wie ich den ursprünglichen Zustand wiederherstellen kann? An die Migration werde ich mich selbst nicht mehr rantrauen, ich will jetzt nur Hauptdomain und Subdomain wieder normal am Laufen haben, damit sich dann jemand drum kümmern kann, der sich besser mit der Migration auskennt.

    Zwei Themen waren für mich bei der Migration unklar: Kann sich durch den Umzug von http auf https ein Problem ergeben und vor allem: Ich arbeite nur mit einer Datenbank und verweise dann in der wp-config.php per table_prefix auf die verschiedenen Einträge.

    Würde mich sehr über Hilfe freuen.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)
  • dann im Backend unter „Einstellungen -> Allgemein“ die neue WP- und Website-URL eingetragen, also statt der Subdomain-URL die Hauptdomain-URL.

    Keine gute Idee

    wie ich den ursprünglichen Zustand wiederherstellen kann?

    Idealerweise mit einem Einspielen eines Backups.

    Kann sich durch den Umzug von http auf https ein Problem ergeben

    Ja, da in der Datenbank jede Menge URL’s noch mit http stehen. Diese müssen als angepasst werden, dafür bietet sich das Plugin „Better Search & Replace“ an.

    Die fehlerhaften URL’s dürften auch das Problem sein, warum die Seite nicht mehr erreichbar war.

    Ich arbeite nur mit einer Datenbank und verweise dann in der wp-config.php per table_prefix auf die verschiedenen Einträge

    Das ist nicht optimal, da du so doppelt aufpassen musst, wenn du mit dem Plugin URL’s anpasst.

    Thread-Starter petrichor256

    (@petrichor256)

    Vielen Dank für die schnelle Hilfe! Ich habe ein Backup mit Duplicator erstellt und mache mich dann wohl mal da ran.

Ansicht von 2 Antworten - 1 bis 2 (von insgesamt 2)