Support » Themes » Unteruntermenü taucht auf der Internetseite nicht auf

  • Gelöst cfredricksen

    (@cfredricksen)


    Hallo,

    ich habe auf der Seite unter dem Punkt „Aktuelles“ einen Unterpunkt „Letters from America“ erstellt. Dieser soll nun wiederum 4 weitere Unterpunkte haben.
    Ich kann dies zwar in WordPress so einrichten (die Seite ist dann dort in der Menü-Übersicht noch einmal seitlich nach rechts verschoben), aber in der Internetseite tauchen diese Unterseiten nicht auf, es gibt auch kein Pfeil o. Ä. um sie auszuklappen.
    Was muss ich hier tun?
    Das Theme nennt sich Lighthouse.

    Damit die Beiträge nun überhaupt online stehen, habe ich sie direkt ins Menü „Aktuelles“ gestellt. Also nicht wundern 😉

    Vielen Dank schonmal!

    • Dieses Thema wurde geändert vor 4 Wochen von cfredricksen.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Moderator Bego Mario Garde

    (@pixolin)

    Hast du das Menü gespeichert, nachdem du die weiteren Unterseiten hinzugefügt hast? Arbeitest du im richtigen Menü? Ist dieses Menü, in dem du arbeitest, als Primär-Menü (Kontrollkästchen unter den Menüeinträgen) festgelegt?

    Moderator Angelika Reisiger

    (@la-geek)

    Hm. es wird zumindest vom System erkannt, dass ein Unter-unter-Menü existiert:

    <li id="menu-item-942" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-942 dropdown">
        
    <a title="Letters from America" href="https://hochschulinitiative-ds.de/letters-from-america/">Letters from America</a>
    
    </li>

    Sieht man an der CSS-Klasse menu-item-has-children

    Allerdings ist das Unter-unter-Menü selbst nicht im Quelltext vorhanden. Ich bin mir eigentlich sicher, dass es KEIN CSS-Problem ist.

    Ich denke, es wird am Theme liegen (JavaScript oder PHP?). Einfach mal das Theme wechseln (auf eins, das zwei Unterebenen darstellen kann) und schauen, ob das Unter-unter-Menü dann angezeigt wird.

    Du kannst auch testweise das Enable jQuery Migrate Helper installieren.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    wenn ich das richtig sehe, ist das Theme Lighthouse seit mehr als zwei Jahren nicht mehr aktualisiert worden. Da würde ich dir sowieso raten, dich mal nach einem anderen Theme umzuschauen.
    Du kannst ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße,
    Hans-Gerd

    Vielen Dank für die Antworten.
    Ist natürlich ungünstig, wenn das Theme diese Unter-unterstufe nicht darstellen kann. Ich hatte die Seite erst vor ein paar Monaten gebastelt und eigentlich keine Lust, nun alles wieder neu einzurichten, da mir das Layout hier ansonsten gut gefällt.
    Das ist ein kostenloses Good-Will-Projekt von unserer Seite aus, das ich nebenbei mache. Und für eine aufwändige Umstellung habe ich ehrlich gesagt keine Zeit.

    Trotzdem Danke für die Tipps. Ich werde – wenn ich mal wieder mehr Zeit habe – vielleicht mal rangehen. Dann achte ich vor allem darauf, ein Theme zu finden, das diese Untermenüs darstellen kann. Wo würde man die Info finden bzw. wie wäre das dann formuliert?

    Schade, dass du nicht auf einen einzigen der Vorschläge hier eingegangen bist. Da hätten wir uns auch die Zeit für Antworten sparen können.

    Wie auch immer … viel Erfolg.

    Ich verstehe, was du meinst und werde das auch machen, aber momentan habe ich so viele andere Dinge um die Ohren, dass ich nicht dazu komme. Glaub mir das einfach.
    Ich bin überhaupt nicht firm in der Gestaltung der Seite und habe Angst, dass es mir was zerschießt und ich es nicht wieder herstellen kann. Das ist für euch vielleicht einfach und mit ein paar Handgriffen in ein paar Minuten gemacht, für mich bedeutet es, dass ich ein bis zwei Stunden daran sitze. Und diese Zeit habe ich nicht.
    Ich finde daher nicht, dass ihr euch die Antwort hättet sparen können, denn es ging mir darum, ob ich was falsch gemacht habe oder ob das Theme die Unterhierarchie einfach nicht hergibt. Letzteres ist der Fall. Und das muss ich momentan so akzeptieren.

    • Diese Antwort wurde geändert vor 3 Wochen, 6 Tage von cfredricksen.
    • Diese Antwort wurde geändert vor 3 Wochen, 6 Tage von cfredricksen.

    @cfredricksen

    Nun ja, wenn du hier nach Hilfe suchst und dir werden dazu Fragen gestellt, hättest du diese wenigstens beantworten können. Ich verstehe auch nicht, wie man einen Thread erstellt, dann aber keine Zeit hat, die vorgeschlagenen Lösungen zu testen.

    Im Übrigen kannst du das von mir vorgeschlagene Plugin ohne Probleme installieren, es benötigt auch keinerlei Einstellungen.

    es ging mir darum, ob ich was falsch gemacht habe oder ob das Theme die Unterhierarchie einfach nicht hergibt. Letzteres ist der Fall.

    Dann ist es ja für dich gelöst. Ich setze den Thread auf gelöst und schließe ihn.

    Solltest du

    Ich werde – wenn ich mal wieder mehr Zeit habe – vielleicht mal rangehen.

    es vielleicht mal irgendwann in Angriffe nehmen, öffne bitte einen neuen Thread, mit konkreten Fragen zum evtl. dann neu aufgetauchten Problem.

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Unteruntermenü taucht auf der Internetseite nicht auf“ ist für neue Antworten geschlossen.