Support » Allgemeine Fragen » UPDATE – Bilder laden nicht mehr

  • Hallo Zusammen 🙂

    ich habe leider seit dem letzten Update das Problem, dass sämtliche Bilder auf meiner Seite nicht mehr geladen/angezeigt werden.

    Ich habe bereits über Stunden versucht, dass Problem zu beheben. Hab es leider nicht hinbekommen.

    Hat jemand eine Idee?

    Vielen Dank 🙂

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 54)
  • Du hast einen Mischmasch aus http und https, allerdings hast du kein Zertifikat für die Domain.

    Hm – und wie bekomme ich das hin, ohne ein kostenpflichtiges Zertifikat zu kaufen?

    Moderator Bego Mario Garde

    (@pixolin)

    Überprüf zuerst einmal die URLs in Einstellungen > Allgemein. Dort dürfen ohne vorhandenes SSL-Zertifikat nur Adresse mit http:// stehen.

    Inzwischen bieten viele Webhoster die Einbindung kostenloser Let’s Encrypt-Zertifikate an, mit denen eine Verschlüsselung der Websites möglich ist. Bietet dein Webhoster das nicht, kannst du über einen Wechsel nachdenken.

    Hallo,
    die Fehler sieht man über die Developer Console (bei Chrome mit Shortcut für Developer Console (STRG+SHIFT+J)).
    Prüfen kannst Du das Problem mit dem Zertifikat z. B. über https://www.ssllabs.com/ssltest/
    Viele Grüße
    Hans-Gerd

    In den Einstellungen steht:

    WordPress-Adresse (URL)
    https://iwb-sundern.de/iwb

    Website-Adresse (URL)
    http://www.iwb-sundern.de

    Ich kenne mich mit der Thematik leider gar nicht aus. Bisher lief alles ohne Probleme auch so. Mein Webhoster ist Celeros.

    Vielen Dank bereits jetzt für eure Mühe!

    Moderator Bego Mario Garde

    (@pixolin)

    Was fehlt dir denn jetzt an Informationen?

    Überprüf zuerst einmal die URLs in Einstellungen > Allgemein. Dort dürfen ohne vorhandenes SSL-Zertifikat nur Adresse mit http:// stehen.

    Wenn eine Adresse nun auf https:// lautet, dann machst du … na, was wohl?

    ¯\_(ツ)_/¯

    Das habe ich damals auch schon probiert und die Seite und der Admin-Bereich waren danach nicht mehr aufrufbar.

    Moderator Bego Mario Garde

    (@pixolin)

    Das nennt man dann wohl beratungsresistent. 🙂

    Viel Erfolg mit deiner Website.

    Sorry, hab mich geirrt. Wenn ich das auf http:// ändere und abspeicher, werde ich automatisch aus dem Admin-Bereich ausgeloggt und zur Loginseite weitergeleitet. Beim Wiedereinloggen ist keine Änderung geschehen: steht wieder https://

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn ich das auf http:// ändere und abspeicher, werde ich automatisch aus dem Admin-Bereich ausgeloggt und zur Loginseite weitergeleitet.

    Das ist korrekt, weil der Anmelde-Cookie für die Adresse mit https gilt.

    Beim Wiedereinloggen ist keine Änderung geschehen: steht wieder https://

    Dann hast du vielleicht eine Weiterleitung in der .htaccess eingetragen, die automatisch auf https://… weiterleitet? Schau auch mal in der wp-config.php, ob da eine Zeile define( 'FORCE_SSL_ADMIN', true ); vorhanden ist – ggf. mit vorangestelltem // auskommentieren.

    Schau auch mal, ob du in der wp-config.php eventuell die Adressen mit

    define( 'WP_HOME', 'http://example.com' );
    define( 'WP_SITEURL', 'http://example.com' );

    vorgegeben hast. Dann müsstest du das ebenfalls auskommentieren.

    In der wp-config.php ist kein define( ‚FORCE_SSL_ADMIN‘, true ); vorhanden.

    In der .htaccess steht nur:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /iwb/
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /iwb/index.php [L]
    </IfModule>

    # END WordPress

    Moderator Bego Mario Garde

    (@pixolin)

    Wenn in der Datenbank die URLs für die Bilder mit https:// abgespeichert sind, kannst du mit dem Plugin Better Search Replace noch die Adressen korrigieren. Bei Suchen gibst du https://iwb-s ein, bei Ersetzen http://iwb-s, alle Tabellen wählen, Häkchen bei Testlauf raus und absenden.

    Vor solchen Aktionen empfiehlt sich immer ein Backup der Datenbank – steht auch so auf der Menüseite des Plugins.

    Gerade durchgeführt – leider kein positives Ergebnis. So ein Misst!

    Moderator Bego Mario Garde

    (@pixolin)

    Verwendest du einen Cache?
    Irgendwelche Pagebuilder-Plugins (z.B. Elementor)?
    Hast du beim Ersetzen das Häkchen bei „Testlauf“ rausgenommen?

    Webseiten erfordern ein wenig Geduld. 🙂

    Ja, das habe ich gemacht. Er hat nur eine Sache dabei geändert in „options“

    http://www.iwb-sundern.de/Unbenannt.jpg

    http://www.iwb-sundern.de/Unbenannt2.jpg

    Das verwende ich

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 54)
  • Das Thema „UPDATE – Bilder laden nicht mehr“ ist für neue Antworten geschlossen.