Support » Installation » Update geht nicht mehr

  • Im Dashboard wird eine Aktualisierung angezeigt. Wenn ich die Aktualisierung ausführen möchte kommt die Fehlermeldung: Forbidden You don’t have permission to access this resource.
    Klicke ich im Menüpunkt „Werkzeuge“ führt das zum gleichen Fehler.

    Ich habe schon alle Plugins deaktiviert. Dadurch ändert sich nichts. Beim anklicken des Unterpuntes „Plugins -> Installieren“ bekomme ich wieder die Fehlermeldung: Forbidden.

    Beiträge lassen sich nicht mehr veröffentlichen -> offline Meldung

    Die Webseite selber läuft.

    Hat jemand eine Idee?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 30)
  • Thread-Starter norbertkut

    (@norbertkut)

    wp_capabilities a:1:{s:13:“administrator“;b:1;}
    wp_user_level 10

    ist so in der Datenbank eingetragen.

    Hast du mal die Datei- und Ordnerberechtigungen überprüft?
    Die WordPress-Dateien müssen auf 644, die Verzeichnisse auf 755 gesetzt werden und dem Benutzer zugewiesen sein, der PHP-Befehle ausführen darf. Bei der wp-config.php kann das auch schon mal anders eingestellt sein. Mehr dazu siehe hier. Hier eine Anleitung, wie man das per FTP einrichten kann.

    Moderator Bego Mario Garde

    (@pixolin)

    @hage

    Hast du mal die Datei- und Ordnerberechtigungen überprüft?

    – wie würde fehlerhafte Dateirechte zu einer fehlenden Berechtigungen führen, den Website-Bericht abzurufen?

    Ich würde eher darauf tippen, dass in der .htaccess oder wp-config.php ein Eintrag gemacht wurde oder ein All-in-One-Security-Plugin alles blockiert. Aber das ist mangels Informationen alles Spekulation.

    @pixolin
    das war eine (zugegebenermaßen eher unwahrscheinliche) Idee zur Lösung des Problems.
    Die von dir genannten Dinge dürften sicher eher eine Möglichkeit für diese Problematik darstellen.
    Dazu müssten wir aber in der Tat mehr Infos erhalten.
    Zumindest könnte @norbertkut ja per FTP feststellen, welche Plugins installiert sind und uns diese dann mitteilen.

    Thread-Starter norbertkut

    (@norbertkut)

    Zu den Berechtigungen: Die Ordner stehen auf: 755 die Dateien auf 644
    wp-admin -> .htaccess:

    <FilesMatch '.(php|php5|phtml)$'>
    Order allow,deny
    Deny from all
    </FilesMatch>
    <FilesMatch '^(index.php|auto_seo.php|wp-blog-header.php|wp-config-sample.php|wp-links-opml.php|wp-login.php|wp-settings.php|wp-trackback.php|wp-activate.php|wp-comments-post.php|wp-cron.php|wp-load.php|wp-mail.php|wp-signup.php|xmlrpc.php|edit-form-advanced.php|link-parse-opml.php|ms-sites.php|options-writing.php|themes.php|admin-ajax.php|edit-form-comment.php|link.php|ms-themes.php|plugin-editor.php|admin-footer.php|edit-link-form.php|load-scripts.php|ms-upgrade-network.php|admin-functions.php|edit.php|load-styles.php|ms-users.php|plugins.php|admin-header.php|edit-tag-form.php|media-new.php|my-sites.php|post-new.php|admin.php|edit-tags.php|media.php|nav-menus.php|post.php|admin-post.php|export.php|media-upload.php|network.php|press-this.php|upload.php|async-upload.php|menu-header.php|options-discussion.php|privacy.php|user-edit.php|menu.php|options-general.php|profile.php|user-new.php|moderation.php|options-head.php|revision.php|users.php|custom-background.php|ms-admin.php|options-media.php|setup-config.php|widgets.php|custom-header.php|ms-delete-site.php|options-permalink.php|term.php|customize.php|link-add.php|ms-edit.php|options.php|edit-comments.php|link-manager.php|ms-options.php|options-reading.php|system_log.php)$'>
    Order allow,deny
    Allow from all
    </FilesMatch>
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . index.php [L]
    </IfModule>

    WP-Config:

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'DB3*****');
    
    /** MySQL database username */
    define('DB_USER', 'U3******');
    
    /** MySQL database password */
    define('DB_PASSWORD', '******');
    
    /** MySQL hostname */
    define('DB_HOST', 'rdbms.strato.de');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    define('AUTH_KEY',         '*****');
    define('SECURE_AUTH_KEY',  '*****');
    define('LOGGED_IN_KEY',    '*****');
    define('NONCE_KEY',        '*****');
    define('AUTH_SALT',        '*****');
    define('SECURE_AUTH_SALT', '*****');
    define('LOGGED_IN_SALT',   '*****');
    define('NONCE_SALT',       '*****');
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    // Einschalten des Debuggings
    define( 'WP_DEBUG', false );
    
    // Warnmeldungen anzeigen
    /*define( 'WP_DEBUG_DISPLAY', true );
    @ini_set( 'display_errors', 1 );
    define( 'WP_DEBUG_LOG', true );*/
    
    define( 'RELOCATE', true ); // Hinzugefügt Norbert
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    
    define( 'WP_ALLOW_MULTISITE', false );
    
    define ('FS_METHOD', 'direct');
    
    // Eingefügt für DOMPDF
    // use landscape A4 sized paper @ 180 DPI
    define('DOMPDF_PAPER_SIZE', 'A4');
    define('DOMPDF_PAPER_ORIENTATION', 'landscape');
    define('DOMPDF_DPI', 180);

    Auf die installierten Plugins kann ich im Dasboard zugreifen, jedoch sieht die Seite so aus, als würde das CSS nicht geladen. Vor der Aktualisierung von WordPress war die Seite noch OK.
    Plugins sind:
    akismet
    all-in-one-seo-pack
    audio-and-video-player
    aws-cookies-popup
    ffv-wordpress-flowplayer
    gutenberg
    login-logout-register-menu
    megamenu
    newsletter
    pdf-print
    photo-gallery
    post-expirator
    titled-gallery-carousel-without-jetpack
    utlimate-dasboard

    Moderator Bego Mario Garde

    (@pixolin)

    Wir hatten vor zwei Monaten einen Thread, bei dem der Webseitenbetreiber auf Nachfrage auch von ähnlichen Regeln in der .htaccess berichtete. Die Website war gehackt, ein Malware-Skript legte die Regeln immer neu an um dem Angreifer einen unbefugten Zugang zur Website zu sichern (Backdoor). Es hat recht lang gedauert, bis wir das durch Abfrage verschiedener Informationen herausgefunden haben. Die index.php enthielt in der zweiten Zeile Schadcode, sinngemäß sowas wie

    <?php
    $OO0__00_OO=urldecode("%6f%41%2d%6… //Malware-Code gekürzt;
    

    Prüf doch bitte mal, ob bei deiner WordPress-Installation ähnlicher Code in der index.php vorkommt. Die ersten 8 Zeilen der .htaccess würde ich auskommentieren (wobei bei genanntem Thread beschrieben wurde, dass die Zeilen immer wieder neu eingefügt wurden).

    Es kann natürlich andere Ursachen haben, dass die Zeilen eingetragen wurden und es gibt keinen Grund, gleich in Panik zu geraten. Prüfen solltest du es trotzdem.

    Zu deinen Plugins: Akismet ist nicht datenschutzkonform, du solltest besser AntispamBee nutzen. Das Plugin Gutenberg ist eine Entwicklungsversion des ohnehin eingebauten Block-Editors und braucht nur installiert werden, wenn du auf Beta-Versionen stehst und mit Fehlern zurechtkommst.

    Moderator Bego Mario Garde

    (@pixolin)

    Achso, ganz vergessen – wp-config.php.

    Die Zeile define( 'RELOCATE', true ); sollte nur eingefügt werden, wenn die Website auf einen anderen Server übertragen wird. Danach bitte auskommentieren oder ganz löschen, damit kein Unfug getrieben wird.

    Die wp-config.php enthält eine Zeile /* That's all, stop editing! Happy publishing. */. Heißt auf Deutsch soviel wie: „Trag hier nichts mehr ein, weil es ggf. gar nicht ausgeführt wird.“ Da hast du dich leider nicht dran gehalten. Die Zeilen

    define( 'WP_ALLOW_MULTISITE', false );
    
    define ('FS_METHOD', 'direct');
    
    // Eingefügt für DOMPDF
    // use landscape A4 sized paper @ 180 DPI
    define('DOMPDF_PAPER_SIZE', 'A4');
    define('DOMPDF_PAPER_ORIENTATION', 'landscape');
    define('DOMPDF_DPI', 180);

    gehören alle über die Zeile /* That's all, stop editing! Happy publishing. */

    // Einschalten des Debuggings
    define( 'WP_DEBUG', false );

    gehört eher in die Rubrik „unfreiwilliger Humor“. 😉

    Thread-Starter norbertkut

    (@norbertkut)

    In der index.php stehen nur zwei Zeilen Code:
    define( ‚WP_USE_THEMES‘, true );

    /** Loads the WordPress Environment and Template */
    require __DIR__ . ‚/wp-blog-header.php‘;

    Moderator Bego Mario Garde

    (@pixolin)

    Das ist ja schon mal erfreulich.
    Kommentier die Zeilen in der .htaccess doch mal aus.
    Kannst du dann auf den Website-Bericht zugreifen?

    Thread-Starter norbertkut

    (@norbertkut)

    Ich habe die ersten 8 Zeilen auskommentiert, aber es ändert nichts.
    Die wp-config.php habe ich korriegiert. Danke für die Hinweise.

    Moderator Bego Mario Garde

    (@pixolin)

    Hm, aber die Website ist inzwischen auf WordPress 6.1.1 aktualisiert worden?

    Moderator Bego Mario Garde

    (@pixolin)

    Schau bitte auch mal, ob z.B. im Unterverzeichnis wp-admin ähnliche Regeln in der .htaccess eingetragen wurden.

    Thread-Starter norbertkut

    (@norbertkut)

    Ich habe jetzt die Regeln in .htaccess in root und in wp-admin auskommentiert.
    Jetzt sind die Zugriffsfehler weg !! Sehr schön!
    Vielen Dank

    Seit heute ist je nachdem wie und was ich im Dashboard aufrufe die Darstellung falsch, sieht aus als wenn die CSS Dateien fehlen.
    Aber die Netzwerkanalyse im Browser meldet keine nicht geladenen Dateien. Die CSS Daten werden geladen. Alle Dateien haben den Status 200.

    Thread-Starter norbertkut

    (@norbertkut)

    WordPress ist auf Version 6.1.1

    Moderator Bego Mario Garde

    (@pixolin)

    Eigentlich gibt es gar keine .htaccess in wp-admin. Keine Ahnung, wer die da reingesetzt hat – im besten Fall ein All-in-One-Security-Plugin. Ich würde nun auch noch in den anderen Unterverzeichnissen nach einer .htaccess suchen und die ggf. umbenennen oder die genannten Zeilen auskommentieren.

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 30)