Support » WooCommerce » Updateprocedere von 3.3.6 auf 7.7.0

  • Hallo verehrte Forumsgemeinde,
    herzlichen Dank für die Aufnahme im Forum, wodurch ich mir Hilfe zu meinem Updateproblemen erhoffe.
    Ich habe eine bestehende ältere Webseite übernommen, in der ich bislang alles Plugins, Themes sowie WP (6.2) aktualisieren konnte.
    Leider macht mir nun noch das Update von WooCommerce von 3.3.6 auf die neuste Version 7.7.0 Kopfschmerzen. Leider habe ich die Seite dabei schon zweimal abgeschossen, konnte sie doch dank Updates wieder herstellen. Mir ist dabei klar, dass es sich um ziemlich große Updatesprünge handelt.

    Die angezeigten Warnhinweise im Menü Plugins sind zwar plausibel, jedoch weiß ich leider nicht, was ich zuerst und zuletzt aktualisieren muss.

    Dort wird innerhalb des WooCommerce Plugins folgendes angezeigt:

    Achtung! Die Versionen der folgenden Plugins, die Sie verwenden, wurden nicht mit WooCommerce 7.0 getestet. Bitte aktualisieren Sie diese oder bestätigen Sie ihre Kompatibilität, bevor Sie WooCommerce aktualisieren, andernfalls können Probleme auftreten:

    PluginGetestet bis zur WooCommerce-Version
    WooCommerce Germanized 3.3
    WooCommerce Coupon Generator unbekannt

    Achtung! Die Versionen der folgenden Plugins, die Sie verwenden, wurden nicht mit der neuesten Version von WooCommerce (7.7) getestet.

    Plugin Getestet bis zur WooCommerce-Version
    Dynamic Product Gallery for WooCommerce 7.2
    Import Export WordPress Users and WooCommerce Customers 7.5

    Auch wenn ich z.B. das WooCommerce Germanized 3.3 deaktiviert hatte/habe und dann WooCommerce upgedatet haben, wurde die Seite abgeschossen.

    Daher bitte ich das Forum um Antworten, mit welchem Procedere ich auf die aktuellsten Versionen abdaten kann.

    Vielen Dank im Voraus.

    Jörg

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 1 Antwort (von insgesamt 1)
  • Moderator Torsten Landsiedel

    (@zodiac1978)

    Hi @bigmie

    das wird dir kaum jemand mit Sicherheit sagen können. Daher mein Tipp: Mache dir ein Backup mit Duplicator (o.ä.) und installiere dir das lokal (oder auf einer Testumgebung) und spiele es immer wieder durch, bis es klappt.

    Was du testen könntest:

    Alles deaktivieren, aktualisieren und dann nach und nach aktivieren.

    Oder über Zwischenversionen gehen, also nicht direkt auf 7.x aktualisieren, sondern einzeln die Hauptversionen durchgehen, und wenn etwas kaputtgeht, die Logs anschauen bzw. Changelogs lesen, woran es gescheitert sein könnte.

    Manchmal gibt es Abhängigkeiten, die erfüllt sein müssen. Aktuelles Germanized erfordert mind. WooCommerce x, aktuelles WooCommerce funktioniert nur mit Germanized y. Da wird es also beim einzelnen Updaten immer einen Moment geben, wo es kaputt ist …

    Viel Erfolg!

    Beste Grüße
    Torsten

Ansicht von 1 Antwort (von insgesamt 1)