Support » Installation » Updates funktionieren nicht mehr seit 4.2

  • Gelöst Satyrography

    (@satyrography)


    Seit dem Update auf die neuste WP-Version lassen sich Updates nicht mehr einspielen.
    Ich bekomme von Chrome nur die Fehlermeldung:

    „Server hat die Verbindung geschlossen. Es wurden keine Daten gesendet.“

    Was ist da los, wie bekomme ich die Updates wieder zum Laufen?

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)
  • w14r

    (@w14r)

    Also erst mal Danke für den Hinweis zur Lösung. PHP Versin 5.4.38 war bei mir schon aktiviert und ich habe nur die Besitzrechte wie angegeben auf den PHP-user umgestellt (Besitzer und Gruppe ist nun jeweils www-data). Die Plugin-updates haben nun ohne Abfrage von Username und PW funktioniert.

    Aber warum ist diese Änderung erforderlich und was hat das möglicherweise Auswirkungen auf die Sicherheit und andere Aktivitäten, die man als Admin so tun muss? Vor der Version 4.2 ist es ja auch gegangen (eben mit Abfrage der FTP-Zugangsdaten).

    Gruß
    Wilhelm

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Das hat mit einem Bug zu tun, der nur in dem FTP-Fall auftritt:
    https://core.trac.wordpress.org/ticket/32135

    Daher ist das Umgehen die Lösung.

    (Sofern ich das richtig verstanden habe.)

    Gruß, Torsten

    Satyrography

    (@satyrography)

    Ich steh immer noch auf dem Schlauch. :/

    Sollte ich nicht besser die PHP-Version aktualisieren?

    Ich bin immer noch völlig ratlos, wie ich das Problem nun lösen soll. 🙁

    Gebastel mit add-handler hinzufügen ist wohl nicht so passend. :/

    Sollte ich also am besten mal den gesamten Ordner auf den PHP-User umstellen?

    Wenn ich dann aber nachträglich mit FTP Dateien verändere, habe ich da keine Probleme zu befürchten?

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Ich verstehe das Problem nicht.

    Ergänze deine htaccess wie in dem Artikel angegeben mit
    AddHandler php53-cgi .php

    Aber am besten mit einer neueren Version von PHP, also:
    AddHandler php56-cgi .php

    (Falls das zu einem Internal Server Error führt, weil der Server das nicht unterstützt, versuche php55-cgi bzw. php54-cgi)

    Danach sollten ggf. noch die Benutzerrechte angepasst werden. Ich zitiere aus dem Artikel:

    Anschließend lohnt sich ein Besuch des Kunden-Administrationssystems (KAS). Hier sollte man unter Tools/Besitzrechte alles dem normalen Kontonutzer zuweisen, nicht dem PHP-User, denn PHP läuft jetzt nicht mehr als Apache-Modul, sondern per FastCGI, also mit den Rechten, mit denen man auch per FTP oder SSH zugreift (SSH gibt es freilich nicht im Billigpaket). Bei WordPress-Updates hat man jetzt den angenehmen Nebeneffekt, daß man nicht mehr nach den FTP-Daten gefragt wird.

    (Hervorhebung von mir.)

    Alternativ wartest Du auf den Fix in WP 4.2.2

    Gruß, Torsten

    Satyrography

    (@satyrography)

    Die Besitzrechte sind ja schon alle beim FTP-User, wenn ich das richtig sehe.
    Geht es wirklich nicht ohne Gebastel in Htaccess-Dateien? :/

    Auf ein nächstes Update warten ist keine Option, da ich zur Zeit ja gar kein Update mehr einspielen kann, es geht nichts mehr. 🙁

    Satyrography

    (@satyrography)

    Ich könnte die PHP Version auf 5.6 aktualisieren lassen.
    Wäre es also sinnvoll, dieses Upgrade durchführen zu lassen?

    Wären da irgendwelche Probleme mit den Scripts (WordPress, Coppermine) zu erwarten?

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Die Lösung steht oben. Ich weiß nicht, was ich noch dazu schreiben könnte.

    Gruß, Torsten

    Satyrography

    (@satyrography)

    Wenn ich den Eintrag in der Htaccess hinzufüge, funktioniert die Seite nicht mehr.
    Fehlermeldung wäre:

    (Warning: session_start(): open(/tmp/sess_2698db339760f7e9ab7380558cd54daf, O_RDWR) failed: Permission denied (13) in /www/htdocs/w00d28dd/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/functions-wpmulib.php on line 69

    Warning: session_start(): Cannot send session cache limiter – headers already sent (output started at /www/htdocs/w00d28dd/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/functions-wpmulib.php:69) in /www/htdocs/w00d28dd/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/functions-wpmulib.php on line 69

    Warning: Cannot modify header information – headers already sent by (output started at /www/htdocs/w00d28dd/wp-content/plugins/custom-sidebars/inc/external/wpmu-lib/functions-wpmulib.php:69) in /www/htdocs/w00d28dd/wp-includes/pluggable.php on line 1196

    Warning: Unknown: open(/tmp/sess_2698db339760f7e9ab7380558cd54daf, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

    Satyrography

    (@satyrography)

    Kommando zurück, der Eintrag in der Htaccess hat gereicht.

    AddHandler php56-cgi .php

    WP war dann auch so nett, sich automatisch zu updaten, auch die Plugins liessen sich aktualisieren.

    Eine Frage hätte ich noch:

    Was unterscheidet PHP im CGI-Modus vom „normalen“ Modus?

    Wenn ich nun die Serverversion auf PHP 5.6 aktualisieren lasse, habe ich also denselben Zustand wie jetzt, nur dass ich keinen Eintrag in der Htaccess brauche?

Ansicht von 9 Antworten - 16 bis 24 (von insgesamt 24)
  • Das Thema „Updates funktionieren nicht mehr seit 4.2“ ist für neue Antworten geschlossen.