Support » Allgemeine Fragen » Upload-Fehler Bilder

  • Gelöst SchulerGaetjens

    (@schulergaetjens)


    Seit einigen Tagen kann ich viele Bilder nicht mehr uploaden. Die Größe liegt jeweils bei unter 1 MB. Fehlermeldung: HTTP-Fehler.

    Ich habe
    – mit dem Provider Strato gesprochen (sie sagen, es liegt nicht an ihnen)
    – die PHP-Version gewechselt (auf 7 und wieder zurück auf 5.6)
    – den Code-Schnipsel

    add_filter( 'wp_image_editors', 'change_graphic_lib' );
    
    function change_graphic_lib($array) {
    return array( 'WP_Image_Editor_GD', 'WP_Image_Editor_Imagick' );
    }

    eingefügt. Alles ohne Erfolg.
    Seite: http://www.lenagaetjens.com
    Theme: Touchfolio-Child

    Was könnte ich noch versuchen?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 41)
  • Das sind noch sehr wenig Informationen.

    PHP 5.6 ist OK, 7.0 verwende ich für meine Websites und habe bisher noch keine Probleme damit gehabt.

    Was die Bildgröße angeht, ist hier weniger das Dateivolumen, als vielmehr die Abmessung des Bildes in Pixeln und der zur Verfügung stehende Arbeitsspeicher. Der ist, wenn ich mich recht entsinne, bei Strato mit 128 MB zwar nicht allzu knapp bemessen, könnte aber Schwierigkeiten bereiten, wenn viele Plugins eingesetzt werden.

    Plugins ist das nächste Stichwort. Hast du mal versucht, ob der Upload funktioniert, wenn du alle Plugins vorübergehend deaktivierst?

    Hast du mal das Debugging aktiviert? (In der wp-config.php die entsprechende Zeile auf define( 'WP_DEBUG', true ); wechseln.) Erhältst du dann mehr Informationen zum Fehler? Werden Bilder in das Verzeichnis wp-content/uploads/2016/05 übertragen? Manche? Alle? Gar keins? Wenn sie übertragen werden, kannst du sie im Browser unter der Adresse ansehen?

    Hallo Bego Mario,

    danke für Deine Antwort!
    1) Folgende Plugins sind am Start: BackWPUp, Broken Link Checker, Cachify, Jetpack, Statify.
    2) Die Plugins hatte ich bereits einzeln deaktiviert, ohne Erfolg.

    Eigenartigerweise kann ich zum Beispiel ein Bild nicht uploaden, das vor dem WordPress-Update keine Probleme machte. Ich habe es probehalber einmal im Photoshop mit der Funktion Für Web speichern neu ausgegeben. Diese Datei lässt sich uploaden!

    Daraufhin habe ich zwei der Problem-Bilder ebenfalls aus Photoshop neu abgespeichert – auch sie lassen sich jetzt uploaden.

    Deine weiteren Hinweise probiere ich in den nächsten Tagen aus und melde mich gesondert.

    Anna

    Hast du ganz zufällig in der wp-config.php selber angaben für den UPLOADS ordner gemacht? Dann schau bitte das die angaben über:

    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    stehen und nicht darunter.
    Ich hatte in letzter Zeit ein paar Supporte die deswegen Probleme hatten.

    Spontan fallen mir noch zwei mögliche Ursachen ein:

    1. das Farbprofil verursacht Probleme bei der Neuberechnung der Bildgrößen (das würde zumindest erklären, wieso sich die Dateien hochladen lassen, wenn sie mit der Variante „für Web speichern“ angelegt wurden),
      • in der .htaccess ist ein AppHandler eingetragen, der tatsächlich eine andere PHP-Version lädt, als im Kundenmenü eingestellt

    An den Plugins sollte es eher nicht liegen.

    Ich hatte auch etwas von Stratos Sicherheitseinstellungen gelesen, nur würde der Upload dann generell nicht funktionieren.

    Wie wär’s, wenn du uns per Dropbox oder Google Drive Zugang zu einem Foto gibst, das sich nicht hochladen lässt?

    @daniel:

    Danke für Deine Antwort. Und nein, ich habe in der wp-config.php keine Angaben über den Uploads-Ordner gemacht.

    @bego Mario:

    Danke für Deine Antwort. Hier ein Dropbox-Link:
    https://www.dropbox.com/sh/uoc9pupfm3wp3cw/AAAwMEjdqLbQ49cEei5-3pF_a?dl=0
    Es steht ein Bild in der von mir neu abgespeicherten (_b) und in der ursprünglichen Version drin. Die Bilder kamen aus dem Raw-Format. Die erste Umwandlung hatte aber nicht ich erstellt.

    Ich habe den Upload einmal lokal und einmal auf meiner Homepage hochgeladen. Beide Bilder werden korrekt im Frontend angezeigt und es gab beim Upload keine Probleme.

    Hast du mal versucht, WordPress erneut zu aktualisieren?
    Was war mit der Einstellung „AppHandler“ in der .htaccess?

    Edi

    (@psychosopher)

    Vielleicht ist ImageMagick deaktiviert. Wäre nicht das Dümmste:

    ImageMagick Vulnerability Information

    @bego Mario:
    – Habe Deinen Rat befolgt und WordPress erneut aktualisiert. Kein Effekt.
    – Leider bin ich nicht wirklich PHP- und WordPress-Entwicklungs-fit. Sollte ich im Strato-Backend eine andere PHP-Version einstellen? Oder umgekehrt die .htaccess ändern?

    Was steht denn in der .htaccess drin?
    Ist dort eine Zeile AppHandler … vorhanden?

    Hier der Inhalt:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Edi

    (@psychosopher)

    Auch wenn sich ein Teil der WordPress-Community bei Twitter über den Hinweis aus dem offiziellen Blog lustig macht (und behauptet, dass die Sicherheitslücke nichts mit WordPress zu tun habe, als hätte PHP nichts mit WordPress zu tun), würde ich doch einmal schauen, ob ImageMagick derzeit aktiviert ist.

    Moderation:[*Du* hast missverständlich getwittert, es handele sich um eine WordPress-Sicherheitslücke. Ich habe dich nur korrigiert. Deine Zusammenfassung ist nicht mal in der Nähe der Wahrheit. – Gruß, Torsten ]

    Anyway: Ist das der Fall sowohl bei Uploads aus dem Editor über die Mediathek als auch bei Uploads direkt in der Mediathek?

    @edi:
    Wie bereits geschrieben: Ich bin nicht PHP-firm. Wie finde ich raus, ob ImageMagick aktiviert ist?

    Den Codeschnipsel von oben habe ich ja bereits getestet – verändert nichts.

    @edi 2:
    (Ich meine den Codeschnipsel aus meinem ersten Beitrag.)
    Die Uploads hatte ich alle aus der Mediathek heraus gestartet.

    @anna:
    Hast du mal Browser- und Cachify-Caches gelöscht und danach erneut getestet?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 41)
  • Das Thema „Upload-Fehler Bilder“ ist für neue Antworten geschlossen.