• Hallo allerseits,

    ich habe im Forum gesucht, mein Problem so allerdings nicht gefunden.

    Wenn ich versuche Medien hochzuladen bekomme ich die Fehlermeldung

    „Das Verzeichnis wp-content/uploads/2016/06 kann nicht angelegt werden. Ist das übergeordnete Verzeichnis durch den Server beschreibbar?“

    ich habe allerdings in meiner FTP alle Verzeichnisse mit den Schreibrechten 755 ausgestattet. WP müsste also die Berechtigung haben, zu schreiben.

    Habe ich etwas falsch gemacht oder übersehen?

    Oder kann es sein, dass die Fehlerursache eigentlich eine ganz andere ist und WP bloß falsch „vermutet“?

Ansicht von 8 Antworten – 16 bis 23 (von insgesamt 23)
  • Hallo Thomas,

    vielen Dank für deine Antwort und den Lesetipp!

    Siehe http://www.schmager.de/chmod.shtml für eine relativ gute Doku zu Dateirechten bzgl. Besitzer/Gruppen/“anderen“..

    Ich muss doch noch mal nachfragen: Aber der Upload-Ordner ist doch keine Datei, sondern ein Verzeichnis, und in dem von dir verlinkten Artikel schreibt der Autor doch auch:

    Vorbeugend sei erwähnt, dass für HTML-, Text-, Bilddateien usw. der CHMOD 644 und für Verzeichnisse der CHMOD 755 korrekt ist. Dies sind i.d.R. auch die Standardeinstellungen für die Rechte beim Provider und daher muss man hier nichts ändern.

    Daher bin ich über deinen Einwand bzgl. 755 für den Upload-Ordner und stattdessen die Empfehlung 644 etwas erstaunt, arbeite allerdings noch nicht lange mit WordPress und bin für solche Diskussionen dankbar. 😉

    aus irgendwelchen Gründen WILL das Forum hier meinen Post nicht veröffentlichen. Und ich habe keine Ahnung warum.

    Falls du mit einer Firefox-Version kleiner 47.0 arbeiten solltest, liegt es daran (s. letzten Beitrag). Bei der aktuellen Version besteht dieses Problem nicht mehr.
    Edit: Verrückterweise hatte ich das Problem eben auch mal wieder, trotz der aktuellen FF-Version, konnte also nicht posten und musste über den Edit-Workaround gehen… 😉

    P.S. Ich freue mich auf deine Antwort, muss jetzt aber leider in die Federn und melde mich spätestens morgen am späten Abend wieder.

    Moderationshinweis: Hier gilt das gleiche: Einmal posten reicht völlig. 🙂
    Die Dubletten habe ich gelöscht. Viele Grüße, Bego

    Thread-Starter jalo93

    (@jalo93)

    Hallo allerseits,

    erstmal vielen Dank für die zahlreichen Ratschläge und Tips!

    ich habe WordPress jetzt mehrmals gelöscht und neu installiert… Und hier ist mir aufgefallen, dass es bei der Installation überhaupt gar nicht nach meinen Zugangsdaten zum Server fragt! Wenn ich das richtig interpretiere, KANN wordpress also gar nicht der Besitzer der Verzeichnisse und Dateien sein und dementsprechend bei 755 auch nichts schreiben oder editieren…

    Die häufigste Lösung welche ich hier und im restlichen Netz gefunden habe (die vielen anderen User mit demsselben Problem scheinen ein Indiz zu sein für einen Fehler bei WordPress, bzw. ein fehlender (oder übersehener) Installationsschritt) war, einmalig auf 777 stellen, etwas uploaden und wieder zurück stellen… Allerdings erzeugt das bei monatlicher Sortierung der Uploads jeden Monat aufs neue wieder Probleme und außerdem hat das bei mir nur dann funktioniert, wenn ich im letzten Unterordner die Berechtigung auf 777 lasse – und das ist ja aus Sicherheitsgründen nicht sinnvoll…

    Ein zielführender Ratschlag scheint mir dieser hier zu sein (aus dem von Flower33 verlinkten Thread:

    Just got this figured out.

    In simpler terms:

    Create a phpinfo page, if you don’t already have one.
    Scroll down to „apache2handler“ and look for „User/Group.“
    Remember the name listed for the user. My entry was apache(#)/#, the name was „apache.“
    Log into a terminal as the root user. Google this step if you need help here.
    Navigate to the folder just above where your WP is installed. Mine is installed to the root directory (httpdocs), so it was at var/www/vhosts/mydomain.com
    Type chown -R (your the username from earlier) (your wp directory)/ – for me, chown -R apache httpdocs/. This changes the ownership of the directory to apache.
    Navigate to your wp-content folder: httpdocs/wp-content/
    Type chmod -R 766 uploads/. This changes permissions so that apache can read, write, and execute there.
    This worked for me. Hopefully others who find this thread through Google (like I did) will find this useful.

    leider kann ich mit dem Punkt „Log into a terminal as the root user.“ nichts anfangen… Ist mit Terminal meine FTP-Struktur gemeint? Und was meint „als root einloggen?

    Aber dem Rest der Aneleitung entnehme ich, dass die Besitzrechte „Apache“ zugesprochen werden, worunter wiederum WordPress versucht Uploads zu tätigen. Das erscheint mir wie gesagt sinnvoll, da dann die Schreibrechte begrenzt bleiben können.

    Ich wiederum bin einen anderen Weg gegangen:
    Habe ich WordPress vorher immer „wordpress-seitig“ installiert (also runterladen, uploaden, entpacken, konfigurieren etc.), habe ich herausgefunden, dass mein Server (all-inkl.com) „serverseitig“ die Installation verschiedener CMS darunter auch WordPress anbietet. Darüber installiert, hat alles wunderbar funktioniert und ich kann uploaden…

    @jalo : Ja, die Nutzer/Gruppenrechte bei all-inkl. sind in der Tat etwas strange gesetzt, was WP-Installationen angeht.

    @flower: Ich geb Dir recht. Ich hatte „Ordner“-Rechte überlesen. Und „Dateirechte“ reininterpretiert. Es war schon spät 😉

    @bego: Sorry. Mir wurd kein Grund genannt. Eigentlich sogar eher gar nichts. Es passierte einfach nur nichts. Entschuldige mich für die Mehrfachpostings!

    Hallo Thomas,

    @flower: Ich geb Dir recht. Ich hatte „Ordner“-Rechte überlesen. Und „Dateirechte“ reininterpretiert. Es war schon spät 😉

    alles klar, war wirklich schon sehr spät, danke für die Rückmeldung!

    @flower33:

    Wenn ich deinem Ratschlag folge und es mache kommt bei mir die Fehlermeldung beim Aufruf der phpinfo.php Seite:
    Warning: phpinfo() has been disabled for security reasons in /kunden/184415_13407/webseiten/phpinfo.php on line 1

    Was heisst das?

    Hallo, @vani2708

    kommt bei mir die Fehlermeldung beim Aufruf der phpinfo.php Seite:
    Warning: phpinfo() has been disabled for security reasons in /kunden/184415_13407/webseiten/phpinfo.php on line 1
    Was heisst das?

    Das heißt, dass diese Abfragemöglichkeit bei deinem Webhoster (zumindest an dieser Stelle) aus Sicherheitsgründen deaktiviert ist. Entweder hast du die Datei im falschen Verzeichnis abgelegt oder es ist bei diesem Anbieter grundsätzlich nicht möglich. Dann kannst du immer noch im Kundenmenü des Webhosters nachschauen oder, falls du dort nicht fündig wirst, die Details per Mail oder Telefon erfragen.
    Noch eine Möglichkeit, falls es nur an der falschen Platzierung der Datei liegen sollte und die Abfragemöglichkeit dort grundsätzlich besteht: Abfrage per Plugin.

    Nachtrag: Dass diese Abfragemöglichkeit bei DF (wo deine Sites laut deiner Aussage gehostet werden) grundsätzlich nicht besteht, halte ich für sehr unwahrscheinlich. Eine weitere denkbare Ursache: Wurden deine Sites vielleicht kürzlich gehackt? Auch dann könnte obige Meldung Sinn ergeben.

    Hast du mal einen Sicherheitscheck via Sucuri gemacht? Was für ein Ergebnis liefert der denn?

    Hallo zusammen.
    Ich habe auch o.g. Problem.

    Leider hilft bei mir aktuell nur 777 zu setzen. Nur dann geht es. Bei allen anderen versuchen hat leider nix geholfen.
    Hat vielleicht noch jemand eine Idee woran es liegen könnte?
    Danke im voraus
    einfach112

    Unser Erfahrung zeigt, dass „genau das selbe Problem“ in nahezu allen Fällen doch andere Hintergründe hat. Deswegen bitten wir immer, zu Fragen einen neuen Thread zu starten und die eigene Installation und das Problem möglichst genau zu schildern. Welche Informationen wir von dir benötigen, haben wir in unserer FAQ beschrieben.

    Ich schließe den Thread hier. Bitte stell deine Frage neu.

Ansicht von 8 Antworten – 16 bis 23 (von insgesamt 23)
  • Das Thema „Upload-Fehler wegen fehlender Rechte“ ist für neue Antworten geschlossen.