Support » Allgemeine Fragen » Bilder Upload mit Meldung „HTTP-Fehler“

  • Hallo,
    ich habe seit kurzem das Problem beim Upload von Bildern im Medienbereich. Es erscheint immer die Fehlermeldung „HTTP-Fehler“. Bei den neu hinzugefügten Bildern gibt es keine Bildvorschau mehr sondern nur das Standard Icon.
    Die Bildergalerie in den Blogbeiträgen werden erst nach erneutem Laden der Website richtig dargestellt.
    Vom Webhoster (webgo) kommt die Info, dass ich eventuell an das RAM (512MB) Limit stoße. Bislang hatte ich allerdings noch nie Probleme und nutze auch keine größer Bilderdateien als sonst.
    Was könnte der Grund für da Problem sein?
    VG Christian

    • Dieses Thema wurde geändert vor 1 Jahr, 6 Monaten von christianfo.
Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Da kann man nur raten. Kommst du an das Log-File von PHP ran?
    Die 512 MB sollten eigentlich genug sein, wenn du nicht gerade gigantisch große Bilder uploaden willst.

    … so weit ich mich erinnere, hatte ich das Problem auch mal bei webgo.
    Das Limit kannst Du aber über den webspace admin (unter php.ini Konfiguration) erhöhen. Es kann aber sein, dass eine Erhöhung mit Kosten verbunden ist.
    Einfach mal testen oder bei webgo nachfragen.

    @bscu: Die Bildergrößen liegen so bei 100 bis 500 kb, sollten also kein Problem darstellen.

    Die Vorgehensweise hat in den letzen 8 Monaten immer geklappt.
    Bildergröße, Bilderanzahl, Bilderformat… alles annähernd gleich. Nur beim letzen Blogbeitrag sind die Probleme aufgetaucht

    Im PHP.ini steht folgendes

    Admin:
    mysqli.default_socket = /var/run/mysqld/mysqld.sock
    mysql.default_socket = /var/run/mysqld/mysqld.sock
    pdo_mysql.default_socket = /var/run/mysqld/mysqld.sock
    pdo_mysqli.default_socket = /var/run/mysqld/mysqld.sock
    mysql.allow_persistent = Off
    mysqli.allow_persistent = Off
    curl.cainfo = /etc/ssl/certs/ca-certificates.crt
    upload_max_filesize = 150M
    post_max_size = 150M
    display_errors = Off
    memory_limit = 256M
    session.save_path = /tmp
    error_reporting = E_ALL & ~E_NOTICE
    date.timezone = ‚Europe/Berlin‘
    expose_php = Off
    [Zend]
    zend_extension=/usr/local/ioncube/ioncube_loader_lin_[php].so
    zend_extension=/usr/local/sourceguardian/ixed.[php].lin
    zend_extension=/usr/local/ZendGuardLoader-php-[php]-linux-glibc23-x86_64/ZendGuardLoader.so

    Eigene Nachträge:
    memory_limit = 512M
    apc.enabled = Off

    Nochmal die Frage: Kommst du an das Log-File von PHP ran?

    Welche PHP Version ist hinterlegt?
    Stimmen die Rechte auf dem Verzeichnis Upload? (755)

    Grüße

    Stephan

    Ich hatte vor kurzem dasselbe Problem, habe alles ausprobiert: htaccess, function.php, Plugins deaktiviert , Rechte gecheckt und das Memorylimit auf 512M. Hat alles nichts geholfen. Schlussendlich hat bei mir das Plugin hier: https://schnurpsel.de/wordpress-plugins/123-image-resize/ geholfen. Vielleicht hilft es dir ja auch.
    Grüße
    Ivo

    @bscu: Ich muss mal sehen, ob ich irgendwie an den PHP Log-File heran komme.

    @redrice: PHP Version 5.6; die Rechte im Upload Ordner liegen bei 755

    • Diese Antwort wurde geändert vor 1 Jahr, 6 Monaten von christianfo.

    @robertmarte: Vielen Dank für die Info. Ich werde es mal ausprobieren.
    Hast du das mit der „eindeutige Zeichenkette“ ohne Problem hinbekommen?
    Viele Grüße
    Christian

    Der Tipp mit dem 123 image resize Plugin hat geholfen. Im Media Bereich werden wieder alle Bilder auch als Vorschaubild angezeigt.

    Ich habe nun nur noch das Problem in der Bildergalerie (Post Grid) meiner Blogbeiträge. Hier werden die Bilder nicht in voller Vorschaugröße geladen, sondern werden nur als schmale Balken angezeigt. Erst nach wiederholtem Laden ist die Galerie wieder vollständig…
    Kennt jemand das Problem?

    VG Christian

    Hört sich nach einem Cache-Problem an. Hast Du irgendwelche Caching-Plugins im Einsatz ? – wenn ja, einfach mal deaktivieren und dann mal testen.
    Und falls es das sein sollte, die Einstellungen bei den Caching-Plugins mal ändern.

    @hage Ich habe kein Caching Plugin im Einsatz. Aber vielleicht ist ja genau das das Problem…

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Bilder Upload mit Meldung „HTTP-Fehler““ ist für neue Antworten geschlossen.