Support » Installation » upload_max_filesize Änderung wird auf WordPress Website Zustand nicht angezeigt

  • Gelöst wupsberger

    (@wupsberger)


    Ich habe mir auf ionos eine selbstverwaltete WordPress Site angelegt. Über php.ini kann ich die maximale Upload Filesize ändern (aktuell 990MB), diese Änderung wird über eine index.php Datei mit phpinfo(); nach der Änderung auch korrekt angezeigt. Meine php.ini Änderung:

    upload_max_filesize=990M;
    post_max_size=990M;
    memory_limit=512M;
    max_execution_time = 60;

    Gehe ich danach in WordPress auf Werkzeuge->Website Zustand und schaue mir da die Parameter an, hat sich da merkwürdigerweise nichts geändert:

    Maximale PHP-Ausführungszeit (max_execution_time)30
    PHP-Speicher-Limit (memory_limit)1024
    Maximale Dateigröße beim Upload (upload_max_filesize)128M
    Maximale Größe der PHP-Post-Daten (post_max_size)128M

    Frage, gibt es neben php.ini auf ionos eine weitere Konfigurationsdatei die ich ändern muss, damit die php.ini Parameter auch von WordPress genutzt werden können?

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)
  • Das solltest du den Support von ionos fragen.

    Außerdem können wir deine WordPress-Installation ohne Website-Bericht und URL zur Website kaum beurteilen.

    Thread-Starter wupsberger

    (@wupsberger)

    Meine Frage bezog sich auf die Konfigurationsdateien, die bei WordPress nach php.ini zum tragen kommen, ich glaube da ist ein Link zu meiner Website oder der Website Bericht nicht wesentlich.
    ionos Support hab ich bisher keine Kontaktadresse gefunden, daher die Frage hier, da ich vermute dass ich nicht der einzige mit diesem Problem bin.

    Thread-Starter wupsberger

    (@wupsberger)

    Ich hab gerade einen ionos Mitarbeiter über die Telefon Hotline erreichen können, die Lösung der Frage ist neben der /php.ini auch die /wp-admin/php.ini zu ändern.
    Sonst ändern sich zwar die Parameter im PHP selbst. WordPress übernimmt sie aber nur, wenn man auch die /wp-admin/php.ini ändert.

    Die Lösung überrascht mich zwar, zeigt aber auch, dass dein Problem nur durch den Support des Webhosters gelöst werden konnte.

    Wenn du meinst, „ein Link zu meiner Website oder der Website Bericht [wären] nicht wesentlich“, hast du höchstwahrscheinlich ein Problem, das nichts mit WordPress zu tun hat – selbst wenn du WordPress nutzt.
    WordPress wird inzwischen so individuell verschieden eingesetzt, dass wir Fragen zu WordPress ohne die URL zur Website und den Website-Bericht nur sehr allgemein beantworten können. Du entscheidest, ob du die Daten zur Verfügung stellst. Wir entscheiden, ob wir dann auf die Frage überhaupt noch eingehen.

    Ich kann da Bego (wie fast immer) nur zustimmen. Das mit wp-admin/php.ini ist ein serverseitiges Konstrukt und kommt in WordPress nicht vor.

Ansicht von 5 Antworten - 1 bis 5 (von insgesamt 5)