Support » Allgemeine Fragen » Uploadgrenze für Medien erhöhen

  • Guten Morgen,
    Ich habe eine Frage zu einem sicherlich sehr bekannten Problem: Anhebung der Upload-Begrenzung für Mediendateien. Ich bekomme es trotz intensiver Suche für mich nicht gelöst.
    Ich hoste WordPress selbst auf meinem Synology NAS.

    Problem: Ich möchte die Uploadbegrenzung von 32M auf 128M anheben.

    Was habe ich schon versucht?
    1. WP Plugin „Wp Maximum Upload File Size“ installiert und ausgeführt, ohne Erfolg
    2. Die Variablen post_max_size sowie upload_max_filesize in den PHP-Einstellungen auf 128M erhöht.

    Symptome:
    1. WordPress selbst sagt beim Upload: Maximale Dateigröße für Uploads: 128 MB
    2. Das Plugin sagt: „Maximum Upload Limit Set By Hosting Provider“: 32M
    3. phpinfo() sagt: memory_limit, post_max_size sowie upload_max_filesize: 128M
    4. WPinfo sagt: post_max_size: 32M und upload_max_filesize: 32M

    Der Upload von Dateien >32M schlägt fehl.

    Wo muss noch herumgeschraubt werden, wo könnte die Beschränkung auf 32M versteckt sein?

    Beste Grüße, Dirk

    
    <blockquote>
    ### wp-core ###
    
    version: 5.8.3
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: undefined
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 3
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /volume1/web/wordpress
    wordpress_size: 18,61 GB (19983048143 bytes)
    uploads_path: /volume1/web/wordpress/wp-content/uploads
    uploads_size: 6,45 GB (6920811059 bytes)
    themes_path: /volume1/web/wordpress/wp-content/themes
    themes_size: 10,60 MB (11119173 bytes)
    plugins_path: /volume1/web/wordpress/wp-content/plugins
    plugins_size: 48,14 MB (50479265 bytes)
    database_size: 7,48 MB (7840296 bytes)
    total_size: 25,12 GB (26973297936 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Ten (twentyten)
    version: 3.6
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, editor-style, editor-styles, wp-block-styles, editor-color-palette, post-formats, post-thumbnails, automatic-feed-links, menus, custom-background, custom-header, widgets
    theme_path: /volume1/web/wordpress/wp-content/themes/twentyten
    
    ### wp-themes-inactive (5) ###
    
    Twenty Nineteen: version: 2.3, author: WordPress-Team
    Twenty Seventeen: version: 3.0, author: WordPress-Team
    Twenty Sixteen: version: 2.7, author: WordPress-Team
    Twenty Twenty: version: 2.0, author: WordPress-Team
    Twenty Twenty-One: version: 1.6, author: WordPress-Team
    
    ### wp-mu-plugins (1) ###
    
    Disable XML-RPC Pingback: version: 1.1, author: Samuel Aguilera
    
    ### wp-plugins-active (4) ###
    
    Akismet Anti-Spam: version: 5.0.1, author: Automattic
    Photo Gallery: version: 1.8.0, author: Photo Gallery Team
    UpdraftPlus - Backup/Restore: version: 1.22.23, author: UpdraftPlus.Com, DavidAnderson
    Wp Maximum Upload File Size: version: 1.0.9, author: CodePopular
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-27 Q8 x86_64 2021-03-02 https://imagemagick.org
    imagick_version: 3.4.4
    file_uploads: File uploads is turned off
    post_max_size: 32M
    upload_max_filesize: 32M
    max_effective_size: 32 MB
    max_file_uploads: 20
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, BMP
    ghostscript_version: not available
    
    ### wp-server ###
    
    server_architecture: Linux 3.10.105 x86_64
    httpd_software: Apache/2.4.43 (Unix)
    php_version: 7.4.9 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 240
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 32M
    php_post_max_size: 32M
    curl_version: 7.54.0 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.29-MariaDB
    client_version: mysqlnd 7.4.9
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /volume1/web/wordpress/wp-content
    WP_PLUGIN_DIR: /volume1/web/wordpress/wp-content/plugins
    WP_MEMORY_LIMIT: 128M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    
    • Dieses Thema wurde geändert vor 3 Monaten, 1 Woche von Hans-Gerd Gerhards. Grund: Formatierung als Code korrigiert

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Hast du nach der Änderung der PHP-Einstellungen den Server neu gestartet?

    Hallo,
    vermutlich sind die entsprechenden Einstellungen (php.ini), etc. nicht korrekt eingestellt. Prüfe doch bitte mal, ob einer der entsprechenden Methoden in dem folgenden Beitrag zum Ziel führt.

    Akismet Anti-Spam ist übrigens nicht datenschutzkonform und sollte deaktiviert werden.
    WordPress ist nicht aktuell und sollte upgedatet werden.

    Viele Grüße
    Hans-Gerd

    Bei der Gelegenheit würde ich das Plugin Wp Maximum Upload File Size ebenfalls deaktivieren und löschen.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)