Support » Installation » URL geändert, nach Korrekturversuch Datenbank nicht erreichbar

  • Gelöst yazzys

    (@yazzys)


    Hallo,
    ich habe beim Hoster ein SSL-Zertifikat gekauft. Habe aber anscheinend den Prozess der Einrichtung nicht verstanden. Habe in WordPress die URL’s in zwei Feldern auf https geändert und jetzt ist die Seite nicht mehr aufrufbar. Nach der Anleitung habe ich per FTP in die Datei wp-config.php den in der Anleitung genannten Text eingesetzt. Seitdem ist die Datenbank nicht mehr erreichbar. Ich habe den Text wieder aus der Datei entfernt. Datenbank trotzdem nicht erreichbar. Lt. Hoster kann es bis zu 48 Stunden dauern, bis meine Seite über https erreichbar ist. Aber ich vermute, das ist nicht das Problem. Aber was habe ich falsch gemacht?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 42)
  • Moderator Michi91

    (@michi91)

    Schau noch nochmal in deine wp config Datei. Ich vermute ganz stark dass du dort versehentlich was geändert oder gelöscht hast. In der wp config findest du die Daten für die Datenbankverbindung. Kannst auch gerne den Inhalt der wp config hier einmal posten, bitte aber ohne das DB passwort 🙂

    Thread-Starter yazzys

    (@yazzys)

    <?php
    /**
     * In dieser Datei werden ein paar Grundeinstellungen f�r WordPress vorgenommen.
     *
     * Zu diesen Einstellungne geh�ren: MySQL Einstellungen, Tabellenpr�fix,
     * Secret Keys, Sprache und ABSPATH. Mehr Informationen zur wp-config.php gibt es auf de {@link http://codex.wordpress.org/Editing_wp-config.php
     * wp-config.php editieren} Seite im Codex. Die Informationen f�r die MySQL-Datenbank bekommst du von deinem Webhoster.
     *
     * Diese Datei wird von der wp-config.php-Erzeungsroutine verwendet. Sie wird ausgef�hrt, wenn noch keine wp-config.php (aber eine wp-config-sample.php) vorhanden ist,
     * und die Installationsroutine (/wp-admin/install.php) aufgerufen wird.
     * Man kann aber auch direkt in dieser Datei alle Eingaben vornehmen und sie von wp-config-sample.php in wp-config.php umbenennen und die Installation starten.
     *
     * @package WordPress
     */
    
    // ** MySQL Einstellungen ** //
    define('DB_NAME', '');    // Ersetze putyourdbnamehere mit dem Namen der Datenbank, die du benutzt.
    define('DB_USER', '');     // Ersetze usernamehere mit deinem MySQL-Datenbank-Benutzernamen.
    define('DB_PASSWORD', ); // Ersetze yourpasswordhere mit deinem MySQL-Passwort.
    define('DB_HOST', 'localhost');    // In 99% der F�lle musst du hier nichts �ndern. Falls doch ersetze localhost mit der MySQL-Serveradresse.
    define('DB_CHARSET', 'utf8');	// Der Datenbankzeichensatz sollte nicht ge�ndert werden
    define('DB_COLLATE', '');
    
    // �ndere jeden KEY in eine beliebiege, m�glichst einzigartige Phrase. Du brauchst dich sp�ter
    // nicht mehr daran erinnern, also mache sie am besten m�glichst lang und kompliziert.
    // Auf der Seite https://api.wordpress.org/secret-key/1.1/ kannst du dir alle KEYS generieren lassen.
    // Bitte trage f�r jeden KEY eine eigene Phrase ein.
    define('AUTH_KEY', ''); // Trage hier eine beliebige, m�glichst zuf�llige Phrase ein.
    define('SECURE_AUTH_KEY', ''); // Trage hier eine beliebige, m�glichst zuf�llige Phrase ein.
    define('LOGGED_IN_KEY', ''); // Trage hier eine beliebige, m�glichst zuf�llige Phrase ein.
    define('NONCE_KEY', ''); // Trage hier eine beliebige, m�glichst zuf�llige Phrase ein.
    
    // Wenn du verschiedene Pr�fixe benutzt, kannst du innerhalb einer Datenbank
    // verschiedene WordPress-Installationen betreiben.
    $table_prefix  = 'zo_';   // Nur Zahlen, Buchstaben und Unterstriche bitte!
    
    // Hier kannst du einstellen, welche Sprachdatei benutzt werden soll. Die entsprechende
    // Sprachdatei muss im Ordner wp-content/languages vorhanden sein, beispielsweise de_DE.mo
    // Wenn du nichts eintr�gst, wird Englisch genommen.
    define ('WPLANG', 'de_DE');
    putenv('TMPDIR='. $_SERVER['DOCUMENT_ROOT'] .'/wp-content/tmp');
    define('WP_TEMP_DIR', ABSPATH . 'wp-content/tmp');
    
    /* Das wars schon, ab hier bitte nichts mehr editieren! Viel Spa� beim bloggen. */
    
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    require_once(ABSPATH . 'wp-settings.php');
    ?>
    • Diese Antwort wurde geändert vor 2 Jahren, 2 Monaten von Hans-Gerd Gerhards. Grund: Bitte den Code immer als "Code" formatieren, alle relevanten Daten gelöscht
    • Diese Antwort wurde geändert vor 2 Jahren, 2 Monaten von Hans-Gerd Gerhards.
    • Diese Antwort wurde geändert vor 2 Jahren, 2 Monaten von Hans-Gerd Gerhards.

    Hallo,
    du hast das wahrscheinlich unter Einstellungen > Allgemein geändert.
    Kannst du per FTP-Programm auf deinen Webspace zugreifen?
    Dann verwende bitte einen geeigneten Editor (z.B. Atom Editor oder Notepad++, bitte nicht Windows Notepad oder Mac Texteditor und füge in der Datei wp-config.php oberhalb von
    /* That's all, stop editing! Happy blogging. */ folgendes ein:
    define( 'RELOCATE', true );
    Lies dazu bitte auch mal die folgende sehr gute Anleitung, in der du noch weitere Informationen und Möglichkeiten zur Korrektur findest.

    Wenn du die wp-config.php hier postest, bitte alle relevanten Daten löschen (auch Datenbankname, etc.).

    Viele Grüße
    Hans-Gerd

    Thread-Starter yazzys

    (@yazzys)

    Hallo Hans-Gerd,

    erst mal Danke, dass du meinen Post korrigiert hast. Was du mir vorschlägst, in die wp-config.php den Text eintragen, habe ich ja gemacht, mit „Visual Studio Code“. Und es hat nicht funktioniert, stattdessen habe ich jetzt die Meldung eines Datenbankfehlers. Deshalb bat Michi91 oben, den Inhalt der wp-config hier zu posten.
    Hast du eine Idee, an was der Fehler liegen könnte?

    Hallo,
    sorry, aber ich kann weder in deiner Frage noch in der wp-config.php entdecken, dass du diesen Eintrag define( 'RELOCATE', true ); bereits vorgenommen hast.
    Daher meine Frage: Hast du das bereits getestet?
    Die Meldung „Fehler beim Aufbau einer Datenbankverbindung“ deutet darauf, dass die Zugangsdaten für die Datenbank in der wp-config.php nicht korrekt sind. Die Daten hast du auch noch mal überprüft?
    Viele Grüße
    Hans-Gerd

    Moderator La Geek

    (@la-geek)

    @yazzys sieht der Inhalt der wp-config.php bei dir genauso aus, also mit diesen Hieroglyphen? (weißes Fragezeichen vor schwarzer Raute)

    Dann wurde die Datei mit einem verkehrten Text-Editor gespeichert und verkehrt kodiert. Siehe dazu: https://software-lupe.de/tipp/utf-8-ohne-bom-mit-notepad/

    Moderator La Geek

    (@la-geek)

    Eine aktuelle wp-config.php sieht so aus, du brauchst weder WPLANG, noch TEMP_DIR und am Ende auch nicht ?>

    <?php
    /**
     * Grundeinstellungen für WordPress
     *
     * Zu diesen Einstellungen gehören:
     *
     * * MySQL-Zugangsdaten,
     * * Tabellenpräfix,
     * * Sicherheitsschlüssel
     * * und ABSPATH.
     *
     * Mehr Informationen zur wp-config.php gibt es auf der
     * {@link https://codex.wordpress.org/Editing_wp-config.php wp-config.php editieren}
     * Seite im Codex. Die Zugangsdaten für die MySQL-Datenbank
     * bekommst du von deinem Webhoster.
     *
     * Diese Datei wird zur Erstellung der wp-config.php verwendet.
     * Du musst aber dafür nicht das Installationsskript verwenden.
     * Stattdessen kannst du auch diese Datei als wp-config.php mit
     * deinen Zugangsdaten für die Datenbank abspeichern.
     *
     * @package WordPress
     */
    
    // ** MySQL-Einstellungen ** //
    /**   Diese Zugangsdaten bekommst du von deinem Webhoster. **/
    
    /**
     * Ersetze datenbankname_hier_einfuegen
     * mit dem Namen der Datenbank, die du verwenden möchtest.
     */
    define( 'DB_NAME', 'hier_eintragen' );
    
    /**
     * Ersetze benutzername_hier_einfuegen
     * mit deinem MySQL-Datenbank-Benutzernamen.
     */
    define( 'DB_USER', 'hier_eintragen' );
    
    /**
     * Ersetze passwort_hier_einfuegen mit deinem MySQL-Passwort.
     */
    define( 'DB_PASSWORD', 'hier_eintragen' );
    
    /**
     * Ersetze localhost mit der MySQL-Serveradresse.
     */
    define( 'DB_HOST', 'hier_eintragen' );
    
    /**
     * Der Datenbankzeichensatz, der beim Erstellen der
     * Datenbanktabellen verwendet werden soll
     */
    define('DB_CHARSET', 'utf8mb4');
    
    /**
     * Der Collate-Type sollte nicht geändert werden.
     */
    define('DB_COLLATE', '');
    
    /**#@+
     * Sicherheitsschlüssel
     *
     * Ändere jeden untenstehenden Platzhaltertext in eine beliebige,
     * möglichst einmalig genutzte Zeichenkette.
     * Auf der Seite {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * kannst du dir alle Schlüssel generieren lassen.
     * Du kannst die Schlüssel jederzeit wieder ändern, alle angemeldeten
     * Benutzer müssen sich danach erneut anmelden.
     *
     * @since 2.6.0
     */
    HIER DEN aktuellen secret-key eintragen
    
    /**#@-*/
    
    /**
     * WordPress Datenbanktabellen-Präfix
     *
     * Wenn du verschiedene Präfixe benutzt, kannst du innerhalb einer Datenbank
     * verschiedene WordPress-Installationen betreiben.
     * Bitte verwende nur Zahlen, Buchstaben und Unterstriche!
     */
    $table_prefix = 'wp_';
    
    /**
     * Für Entwickler: Der WordPress-Debug-Modus.
     *
     * Setze den Wert auf „true“, um bei der Entwicklung Warnungen und Fehler-Meldungen angezeigt zu bekommen.
     * Plugin- und Theme-Entwicklern wird nachdrücklich empfohlen, WP_DEBUG
     * in ihrer Entwicklungsumgebung zu verwenden.
     *
     * Besuche den Codex, um mehr Informationen über andere Konstanten zu finden,
     * die zum Debuggen genutzt werden können.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define('WP_DEBUG', false);
    
    /* Das war’s, Schluss mit dem Bearbeiten! Viel Spaß beim Bloggen. */
    /* That's all, stop editing! Happy blogging. */
    
    /** Der absolute Pfad zum WordPress-Verzeichnis. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Definiert WordPress-Variablen und fügt Dateien ein.  */
    require_once(ABSPATH . 'wp-settings.php');
    Thread-Starter yazzys

    (@yazzys)

    Hallo Angelika,
    ja, genau so sieht der Text aus. Da ich in den letzten Tagen so viel trouble mit der Seite hatte, lag auf meinem Rechner noch eine wp-config von vor 3 Tagen. Ich habe obige Datei mal auf „alt“ gesetzt und die Datei von vor 3 Tagen geladen – und siehe da, alles läuft.

    Meinst du, Visual Studio Code hätte ich nur anders einstellen müssen?

    Hallo Hans-Gerd,
    wie oben in meinem Starttext geschrieben, hatte ich die Zeile in die wp-config eingefügt und da ich danach einen Datenbankfehler gemeldet bekam, die Zeile wieder gelöscht. Deshalb ist sie oben bei dem Code nicht mehr zu sehen.

    Meinst du, Visual Studio Code hätte ich nur anders einstellen müssen?

    Genau das. Soweit mir bekannt ist, sollte man mit Visual Studio Code auch Dateien im UTF-8 Format ohne BOM speichern können.

    Thread-Starter yazzys

    (@yazzys)

    Visual Studio Code bietet an:
    UTF 8
    UTF 8 with BOM

    Was gibt es am Mac für eine Alternative? Notepad++ ist für windows, richtig?

    Hallo,

    wie oben in meinem Starttext geschrieben, hatte ich die Zeile in die wp-config eingefügt

    naja, welche Zeile du genau eingefügt hast, war mir nicht klar. Schreibe doch bitte beim nächsten Mal rein, welche Zeile du genau in die wp-config.php eingefügt hast.
    @la-geek hatte die richtige Idee mit der falschen Codierung.
    Die Seite wird jetzt richtig geladen, aber weiterhin als unsicher eingestuft, weil du wohl offensichtlich die Umstellung auf https trotz SSL-Zertifikats (noch) nicht umgesetzt hast.
    Die Umstellung auf https bei vorhandenem SSL-Zertifikat habe ich in dem folgenden Beitrag beschrieben. Vielleicht ist das hilfreich für dich.
    Viele Grüße
    Hans-Gerd

    Thread-Starter yazzys

    (@yazzys)

    Hallo Hans-Gerd,

    der Hoster schreibt heute mittag: Aufgrund der notwendigen DNS-Änderungen kann es allerdings bis zu 48 Stunden dauern bis die Webseite korrekt per https erreichbar ist.
    Das wäre dann übermorgen.Ich warte wohl am besten mal ab. Oder?
    Wenn ich den admin-Bereich aufrufe, ist das Schloß vor der Adresse da, rufe ich nur die Seite selbst auf, dann ist es keine sichere Verbindung.

    Hans-Gerd, deine Anleitung ist was für Profis. Ich weiß nicht, ob ich da durch komme.

    Moderator La Geek

    (@la-geek)

    @yazzys

    Editoren wie bspw. Notepad++ unter Windows und TextWrangler auf dem Mac erlauben in der Dialogbox „Speichern unter…“ die Zeichencodierung zu wählen. Dort gibt es die Optionen UTF-8 mit oder ohne BOM. Wählen Sie die Optionen ohne BOM und speichern Sie die Datei.

    https://www.w3.org/International/questions/qa-byte-order-mark.de

    Aufgrund der notwendigen DNS-Änderungen kann es allerdings bis zu 48 Stunden dauern bis die Webseite korrekt per https erreichbar ist.

    Hahahaha, wechsele den Hoster, der hat ja selber keine Ahnung. Die Seite ist ja per https erreichbar und die Umstellung auf https sollte eigentlich sofort funktionieren, sobald das Zertifikat installiert ist.

    deine Anleitung ist was für Profis.

    Noch einfacher kann man das nicht erklären. Wenn du dir das selber nicht zutraust, dann solltest du jemanden finden, der dich dabei unterstützt. In einem Forum kann man dir nur die nötigen Hinweise geben, umsetzen musst du das schon selber.

    Hallo,

    Hans-Gerd, deine Anleitung ist was für Profis.

    Schade, dann werde ich mir meinen Beitrag daraufhin noch mal ansehen. Mittlerweile geht das wirklich sehr einfach. Die Anleitung von mir enthält natürlich auch Hinweise auf eventuell auftretende Probleme. In der Regel klappt das aber eigentlich ganz gut.
    Übrigens sind solche SSL-Zertifikate (Lets Encrypt ist vollkommen ausreichende) bei den meisten Hostern kostenfrei. Mich wundert, dass dein Hoster das in Rechnung stellt.

    Viele Grüße
    Hans-Gerd

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 42)
  • Das Thema „URL geändert, nach Korrekturversuch Datenbank nicht erreichbar“ ist für neue Antworten geschlossen.