Support » Installation » URL geändert, nach Korrekturversuch Datenbank nicht erreichbar

  • Gelöst yazzys

    (@yazzys)


    Hallo,
    ich habe beim Hoster ein SSL-Zertifikat gekauft. Habe aber anscheinend den Prozess der Einrichtung nicht verstanden. Habe in WordPress die URL’s in zwei Feldern auf https geändert und jetzt ist die Seite nicht mehr aufrufbar. Nach der Anleitung habe ich per FTP in die Datei wp-config.php den in der Anleitung genannten Text eingesetzt. Seitdem ist die Datenbank nicht mehr erreichbar. Ich habe den Text wieder aus der Datei entfernt. Datenbank trotzdem nicht erreichbar. Lt. Hoster kann es bis zu 48 Stunden dauern, bis meine Seite über https erreichbar ist. Aber ich vermute, das ist nicht das Problem. Aber was habe ich falsch gemacht?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 12 Antworten - 31 bis 42 (von insgesamt 42)
  • Sieh mal dort:

    https://www.hosteurope.de/faq/webhosting/webpack/informationen-zu-mod-rewrite/

    Das Modul ist auf unseren WebPacks ab WebPack 4 M, auf unseren WebHosting Paketen ab WebHosting Basic und unseren WebServern verfügbar. Damit Sie das Modul nutzen können, muss dieses mit der folgenden Zeile in einer .htaccess Datei aktiviert werden: RewriteEngine On

    Wenn du ein älteres Paket hast, könnte es durchaus gar nicht vorhanden sein.

    Thread-Starter yazzys

    (@yazzys)

    Hab ich nicht geschafft. Konnte die Datei mit Punkt speichern, aber auf dem Server blieb sie in der alten Form. Wusste auch nicht, wie ich sie auf den server bekomme, ich habe sie noch nicht mal gefunden. Dann habe ich die vorhandene Datei in Filezilla mit Rechtsklick umbenannt und eine alte htaccess-datei mit Punkt hochgeladen, in dieser den Text ausgetauscht. Dann war die Seite wieder nicht mehr erreichbar. Also habe ich die neu hochgeladene Datei wieder gelöscht und meine Datei ohne Punkt wieder in htaccess zurück benannt. Kann ich nicht auch hier in Filezilla mit einem Rechtsklick sagen „umbenennen“ und den Punkt davor setzen? Wenn ich jetzt meine Seite aufrufe, ist das https davor. Die Test Results sagen aber immer noch den gleichen Fehler.

    Thread-Starter yazzys

    (@yazzys)

    @angelika:
    Ich habe seit heute das Webhosting Basic Paket. Die erste Zeile in htaccess lautet : RewriteEngine On
    Ich höre für heute auf. Danke für alles.

    Filezilla, Menü oben -> Server -> im Untermenü „Auflistung versteckter Dateien erzwingen“ ist ein Häkchen vor? Da muss ein Häkchen davor sein, wenn nicht, dann anklicken.

    Was ist mit deinem Webhostingpaket, ist es älter?

    https://de.wordpress.org/support/topic/url-geaendert-nach-korrekturversuch-datenbank-nicht-erreichbar/page/3/#post-123018

    Kann ich nicht auch hier in Filezilla mit einem Rechtsklick sagen „umbenennen“ und den Punkt davor setzen?

    Ja, das geht ohne Weiteres. Es sei denn du hast statt wpxxxx-user den ftpxxxx-user, oder umgekehrt. Es kommt darauf an, welche Zugriffsberechtigung für die Datei notwendig ist, siehe:
    https://www.hosteurope.de/faq/webhosting/hochladen-von-webinhalten-ftp/ftp-zugaenge-anlegen/
    Kapitel Benutzer. Lege dir zusätzlich den anderen ftp-/oder wp- User an und log damit ein und versuch es noch einmal.

    Thread-Starter yazzys

    (@yazzys)

    Hallo,

    in meinen Logfiles steht:
    AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‚LimitInternalRecursion‘ to increase the limit if necessary. Use ‚LogLevel debug‘ to get a backtrace.

    Den Fehler habe ich hier im Forum gesucht und einen Eintrag gefunden, in dem ein Link zu dieser Seite steht.
    Mein Englisch ist mangelhaft und meine Kenntnisse, wie der Code in der .htaccess aussehen soll, ebenfalls.
    Wäre der Vorschlag von der Seite:

    Instead of changing the rewrite rule, 
    Change:
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    
    To:
    
    RewriteCond %{ENV:REDIRECT_STATUS} 200 [OR]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]

    auch für mich anwendbar? Ist das ein allgemeingültiger Code?

    Bevor wir hier immer neue Baustellen bearbeiten, wäre es sicher sinnvoll, wenn die noch offenen Fragen erst einmal geklärt werden.

    1.) Ist sichergestellt, dass du wirklich alle Dateien siehst?

    2.) Ist Filezilla so eingerichtet, dass es alle Dateien anzeigt?

    3.) Hast du einmal, wie von mir vorgeschlagen, einen wp- oder ftp-User angelegt und damit versucht, eine neue .htaccess-Datei hochzuladen bzw. die alte zu ändern (dann auch verifizieren, dass die Änderungen drin stehen):

    Thread-Starter yazzys

    (@yazzys)

    Hallo,

    Filezilla: Auflistung versteckter Dateien erzwingen ist angehakt
    Zusätzlich zum ftp-User einen wp-User angelegt.
    Die .htaccess-Datei hat den Punkt vorne und nur die Basis-Daten stehen drin.

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
    Thread-Starter yazzys

    (@yazzys)

    Ich sehe gerade, Filezilla gibt an:

    Befehl:      	CWD /
    Antwort:    	250 CWD command successful
    Befehl:      	TYPE A
    Antwort:    	200 Type set to A
    Befehl:      	PASV
    Antwort:    	227 Entering Passive Mode (5,175,14,167,199,60).
    Befehl:      	STOR .htaccess
    Antwort:    	550 .htaccess: Permission denied

    In der Dateiberechtigung dieser Datei ist lesen + schreiben aktiv. Ausführen nicht.

    Thread-Starter yazzys

    (@yazzys)

    Habe nochmal Hosteurope kontaktiert. Sie haben die .htaccess modifiziert, was auch immer das heißt, haben das Datenbankpasswort geändert, weil es nicht korrekt war und ein PlugIn deaktiviert. Seite erreichbar, sieht jetzt schlimm aus. Na, das kann ich ja jetzt richten.
    Nochmals vielen Dank für die Unterstützung.

    Hallo,
    an das hört sich ja zumindest hoffnungsvoll an 😉
    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.
    Viele Grüße
    Hans-Gerd

    Nochmals vielen Dank für die Unterstützung.

    Gerne. Und danke für die Rückmeldung. Schön dass es letztendlich noch gelöst werden konnte.

Ansicht von 12 Antworten - 31 bis 42 (von insgesamt 42)
  • Das Thema „URL geändert, nach Korrekturversuch Datenbank nicht erreichbar“ ist für neue Antworten geschlossen.