Support » Allgemeine Fragen » URL not found nach umstieg auf https (SSL Zertifikat

  • Gelöst freaky2003

    (@freaky2003)


    Hey,
    Ich habe gerade meine Website, welche mit WordPress läuft auf https gesetzt bzw. das SSL zertifikat in Worpress „aktiviert“.
    Dafür habe ich mit dem Plugin Better Search & Replace, in der Datenbank, http://karaoke-doke.de zu https://karaoke-doke.de geändert.
    Normalerweise ging auch immer alles gut, nur diese mal nicht…
    Ich wurde dannach direkt ausgeloggt bzw. bekam einen Error: Requested URL not found on this Server.
    Jetzt kommt beim Öffnen der Seite immer der
    Diese Domain wurde freigeschaltet
    Es wurden noch keine Inhalte hinterlegt
    Screen von meinem Hoster…

    Was kann ich tun?
    Wenn ich WP neuinstallieren muss, gibt es dann imerhin eine Möglichkeit den Inhalt der Website wiederzubekommen/wiederherzustellen?

    Liebe Grüße

    Timothée

    EDIT: Wenn ich irgendeine Seite (auch wenn sie nicht bei WordPress exisistiert) aufrufe, z.B. http://karaoke-doke.de/instrumentals kommt eine WordPress Seite mit Diese Seite wurde nicht gefunden

    • Dieses Thema wurde geändert vor 1 Jahr, 6 Monaten von freaky2003.
    • Dieses Thema wurde geändert vor 1 Jahr, 6 Monaten von freaky2003.
Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hallo freaky2003,

    Hast du ein Zertifikat beim Hoster liegen?

    Und so wie es aussieht, hast du nur bei Options die Domain geändert. Daher sind die Unterseiten auch nicht per https aufrufbar.

    Schau dir auch noch die wp-config Datei an, ob dort auch alles geändert wurde und lösche mal den Cache deines Browsers.

    Gruß

    Marco

    Schau dir auch noch die wp-config Datei an

    Für eine Umstellung auf verschlüsselte Übertragung mit https muss nichts in der wp-config.php eingetragen werden. Optional kann eingetragen werden, dass das Backend nur verschlüsselt erreicht wird: define( 'FORCE_SSL_ADMIN', true );.

    In der wp-config.php können zwar die Website- und WordPress-URL fest vorgegeben werden, allerdings wird damit der Datenbankeintrag überschrieben. Der Eintrag ist deshalb eigentlich nur bei Verwendung einer Staging-Umgebung sinnvoll, sollte aber bei einer dauerhaften Umstellung auf https unterbleiben.

    Dass bei Aufruf der Startseite eine Platzhalterseite des Webhosters angezeigt wird, deutet auf eine fehlerhafte Konfiguration der Domain im Kundenmen des Webhosters hin.

    Thread-Ersteller freaky2003

    (@freaky2003)

    Hast du ein Zertifikat beim Hoster liegen?

    Ja. Das Zertifikat kommt, laut Hoster, anscheinend von Let’s Encrypt.

    Und so wie es aussieht, hast du nur bei Options die Domain geändert. Daher sind die Unterseiten auch nicht per https aufrufbar.

    Nein, nein die Unterseiten sind ja, bedingt, aufrufbar (nur die Hauptseite nicht).

    Dass bei Aufruf der Startseite eine Platzhalterseite des Webhosters angezeigt wird, deutet auf eine fehlerhafte Konfiguration der Domain im Kundenmen des Webhosters hin.

    Aber die Seite hat doch bis eben funktioniert… Naja, ich gucke nochmal.

    Danke schonmal!

    Thread-Ersteller freaky2003

    (@freaky2003)

    @pixolin @marcoswebprojekte Uff…
    Fehler gefunden! das Zertifikat war für die Domain gar nicht aktiviert…

    Aber vielen Dank trotzdem!!

    LG

    • Diese Antwort wurde geändert vor 1 Jahr, 6 Monaten von freaky2003.

    Hallo,
    wieso „vielen Dank trotzdem“? – Bego hatte doch u. a. darauf hingewiesen. Aber iimmerhin – es läuft.
    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren. Das habe ich jetzt schon gemacht.
    Viele Grüße
    Hans-Gerd

    Dass bei nicht aktiviertem SSL-Zertifikat eine Platzhalterseite des Webhosters angezeigt wird, ist allerdings eine Besonderheit, die mir so nich bekannt war. Normalerweise reicht es, im Browser den Hinweis auf eine unsichere Seite mit Problemen des Zertifikats zu quittieren, um die Webseiten angezeigt zu bekommen.

    Eigentlich ging es mir aber auch zu später Stunde um ein kurzes Feedback zu der Aussage, die wp-config.php müsse bei einer Umstellung auf verschlüsselte Übertragung geändert werden. Hier halten sich hartnäckig falsche Aussagen.

    Tatsächlich ist dieses oft gelesene „trotzdem Danke“ frustrierend und klingt nach „er hat sich stets bemüht. Nicht schön, wenn du dir Gedanken über eine fremde Website gemacht hast und jemand helfen wolltest. Als ob wir aus wenigen Zeilen sofort alle Besonderheiten einer WordPress-Installation ablesen können …

    „Trotzdem“ glaube ich, dass ich weiter Fragen im Forum beantworten werde. 😉

    Thread-Ersteller freaky2003

    (@freaky2003)

    Hallo,
    wieso „vielen Dank trotzdem“? – Bego hatte doch u. a. darauf hingewiesen. Aber iimmerhin – es läuft.
    Denkst du bitte beim nächsten Mal daran, das Thema dann auch als gelöst zu markieren. Das habe ich jetzt schon gemacht.
    Viele Grüße
    Hans-Gerd

    @hage Ja da habe ich wohl seine Antwort falsch verstanden… danke fürs als gelöst markieren

    Tatsächlich ist dieses oft gelesene „trotzdem Danke“ frustrierend und klingt nach „er hat sich stets bemüht. Nicht schön, wenn du dir Gedanken über eine fremde Website gemacht hast und jemand helfen wolltest. Als ob wir aus wenigen Zeilen sofort alle Besonderheiten einer WordPress-Installation ablesen können …

    @pixolin Mit „trotzdem Danke“ war gemeint, das zwar die Antwoprt nicht die Lösung des Problems war, aber ich mich dennoch bedanken, dass du versucht hast mir zu helfen. Deine Antwort entpupte sich aber am Ende doch als richtig, ich hatte sie nur falsch verstanden… Deshalb nochmal ein großes Dankeschön!

    Liebe Grüße

    Timothée

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „URL not found nach umstieg auf https (SSL Zertifikat“ ist für neue Antworten geschlossen.