Support » Allgemeine Fragen » URL vertippt und gespeichert

  • Gelöst koonzie

    (@koonzie)


    Hallo,

    ich bin gerade dabei meine erste Website zu erstellen und habe bereits das erste Problem.

    Weil ich wollte, dass man das www. sehen kann, habe ich in den Einstellungen die beiden URL Namen verändert. Das hat leider nicht zum gewünschten Erfolg geführt. Deswegen wollte ich ein bisschen rumprobieren, was offenbar ein Fehler war. Nun hatte ich nämlich http://www.. eingegeben, also mit zwei Punkten. Musste mich daraufhin wieder neu anmelden und nun sagt es mir, „Die Website ist nicht erreichbar. Die Server-IP-Adresse von http://www..blabla.de wurde nicht gefunden.

    Hilfe, wie kann ich das denn jetzt wieder umstellen und meine Seite weiter bearbeiten?

    Vielen lieben Dank für jegliche Hilfe!!

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    kannst du per FTP-Programm auf deinen Webspace zugreifen?
    Dann verwende bitte einen geeigneten Editor (z.B. Atom Editor oder Notepad++, bitte nicht Windows Notepad oder Mac Texteditor und füge in der Datei wp-config.php oberhalb von
    /* That's all, stop editing! Happy blogging. */ folgendes ein:
    define( 'RELOCATE', true );
    Lies dazu bitte auch mal die folgende sehr gute Anleitung, in der du noch weitere Informationen und Möglichkeiten zur Korrektur findest.

    Evtl. hilft dir auch diese Information.

    Andere Lösungsmöglichkeiten findest du z. B. auf dieser Webseite.
    Ich würde dir aber empfehlen zumindest jetzt noch Sicherungen zu erstellen, z. B. den kompletten WP-Ordner auf Deinen lokalen Rechner kopieren und die Datenbank sichern.

    Hier noch ein Link zu einem Beitrag aus der FAQ, falls du mit den vorherigen Infos nicht weiterkommst.

    Viele Grüße
    Hans-Gerd

    Thread-Ersteller koonzie

    (@koonzie)

    Vielen lieben Dank für diese schnelle Hilfe!

    Hat geklappt und ich bin wieder drin, da fällt mir ein großer Stein vom Herzen.

    Thread-Ersteller koonzie

    (@koonzie)

    Nun hat sich doch noch eine andere Problemsituation aufgetan. Ich hatte beim Webhoster in den options die URL verändert und konnte mich wieder bei WordPress anmelden. Wenn ich nun aber meine Website aufrufen möchte, werde ich immer noch zur Seite mit dem zwei Punkten umgeleitet, weshalb dann da steht:

    Server-IP-Adresse von http://www..blabla.de wurde nicht gefunden

    Hat jemand eine Idee, wie ich das noch ändern kann?

    Moderator Bego Mario Garde

    (@pixolin)

    Was hast du denn in der Datenbanktabelle wp_options geändert?
    siteurl und home?

    Thread-Ersteller koonzie

    (@koonzie)

    genau, die beiden habe ich geändert.

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du denn in der wp-config.php noch Konstanten definiert, mit denen die Adressen überschrieben werden?

    Sowas wie

    define( 'WP_SITEURL', 'http://example.com/' );
    define( 'WP_HOME', 'http://example.com' );

    Dann kannst du viel in der Datenbank ändern – es wird durch die Konstanten überschrieben.

    Thread-Ersteller koonzie

    (@koonzie)

    Entschuldige, ich nutze meinen PC sonst nur für die alltäglichen Dinge… Word, Recherche, etc.

    wo finde ich wp-config.php? ich hatte außer den URL nichts weiter geändert.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    die wp-config.php findest du im Hauptordner deiner WordPress-Installation.
    Noch mal der wichtige Hinweis: Verwende bitte einen geeigneten Editor (z.B. Atom Editor oder Notepad++, bitte nicht Windows Notepad oder Mac Texteditor (das hatte ich dir bereits geschrieben, s. o.) und kopiere die Datei sicherheitshalber vorher auf deinen lokalen Rechner.
    Wie du per FTP auf den Server zugreifen kannst, wird z. B. hier beschrieben.
    Viele Grüße
    Hans-Gerd

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „URL vertippt und gespeichert“ ist für neue Antworten geschlossen.