Support » Allgemeine Fragen » utf 8 – Sonderzeichen als ? dargestellt

  • Gelöst 0000magda0000

    (@0000magda0000)


    seit ich die WordPress Seite von der staging url umgezogen habe (mit plugin), sind die utf einstellungen in phpmyadmin nicht mehr korrekt – in meinem Fall utf8_general_ci.

    Auf meinem Computer werden komischerweise alle Zeichen richtig angezeigt, auch wenn ich den Cache lösche, auf dem meiner Kundin allerdings werden (Sonder)Zeichen als ? dargestellt, auch in ihrem WP-Editor.

    Ich habe das wp-config.php und den meta tag in header.php kontrolliert. Ich habe die Datenbank auf utf8_general_ci umgestellt.

    Leider keine Änderung bei meiner Kundin. Offenbar sind alle Plugins, die diese Problem zu beheben scheinen könnten schon sehr alt und funktionieren nicht mehr mit meiner WP-Version.

    Was könnte ich noch probieren?

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Moderator Bego Mario Garde

    (@pixolin)

    Was ist in der wp-config.php als Datenbank-Kollation angegeben?
    Was passiert, wenn du ein Standard-Theme („Twenty …“) aktivierst?

    Die Umlaute und „ß“ werden in meinem Browser korrekt ausgegeben, nur das Copyrightsymbol © nicht.

    danke für die Antwort!

    gerade eben habe ich in einem Eintrag im Internet gelesen, dass es auch daran liegen kann, dass man den Text zB aus MS Word kopiert hat, was hier wahrscheinlich der Fall war. Ich habe also alle Sonderzeichen nochmal neu eingetippt und es hat geklappt!

    dass es auch daran liegen kann, dass man den Text zB aus MS Word kopiert hat

    Gaaaanz böses Foul, Word ist so ziemlich das Letzte, was man dafür nehmen sollte. Und wenn man Vorlagen in Word hat, dann erst z.B. in Notepad++ reinkopieren und dann aus Notepad++ kopieren und in WordPress einfügen. Dabei gehen auch die sehr merkwürdigen Formatierungen von Word verloren.

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)