Support » WooCommerce » Variationen Auswahl zurücksetzen

  • Gelöst dennispaden1

    (@dennispaden1)


    Hallo, ich habe ohne große Vorkenntnisse einen Shop erstellt. Wenn ich nun bei Woocommerce Variationen im Shop wähle, erscheint immer ein „Auswahl zurücksetzen“ Link. Wie kann ich diesen entfernen?

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    wenn du dann noch die URL oben einträgst, dann können wir uns das auch ansehen und dir sicher besser helfen. Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Ok, hier hänge ich noch etwas dran. Es ist im Moment nur eine Seite für mich zum ausprobieren.

    Installiert ist:
    Wordpress, Woocommerce, Germanized und Variation Swatches.
    Der Hoster ist 1und1.

    
    ### wp-core ###
    
    version: 5.8.2
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/10/d891557815/htdocs/app891558584
    wordpress_size: 58,16 MB (60985951 bytes)
    uploads_path: /homepages/10/d891557815/htdocs/app891558584/wp-content/uploads
    uploads_size: 324,00 kB (331775 bytes)
    themes_path: /homepages/10/d891557815/htdocs/app891558584/wp-content/themes
    themes_size: 5,02 MB (5263880 bytes)
    plugins_path: /homepages/10/d891557815/htdocs/app891558584/wp-content/plugins
    plugins_size: 41,12 MB (43112902 bytes)
    database_size: 9,22 MB (9666560 bytes)
    total_size: 113,83 MB (119361068 bytes)
    
    ### wp-active-theme ###
    
    name: Storefront (storefront)
    version: 3.9.1
    author: Automattic
    author_website: https://woocommerce.com/
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, post-thumbnails, automatic-feed-links, custom-logo, menus, html5, custom-background, custom-header, site-logo, title-tag, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-font-sizes, editor-style, responsive-embeds, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, starter-content, widgets
    theme_path: /homepages/10/d891557815/htdocs/app891558584/wp-content/themes/storefront
    auto_update: Aktiviert
    
    ### wp-mu-plugins (5) ###
    
    1&1 Managed WordPress: version: 1.1.0, author: 1&1
    1&1 Product Subdomain: version: 1.1.0, author: 1&1
    IONOS Assistant: version: 7.1.4, author: IONOS
    IONOS Help: version: 2.0.4, author: IONOS
    IONOS Login: version: 2.0.4, author: IONOS
    
    ### wp-plugins-active (3) ###
    
    Germanized for WooCommerce: version: 3.7.2, author: vendidero, Automatische Aktualisierungen aktiviert
    Variation Swatches for WooCommerce: version: 1.1.19, author: Emran Ahmed, Automatische Aktualisierungen aktiviert
    WooCommerce: version: 5.9.0, author: Automattic, Automatische Aktualisierungen aktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Nicht verfügbar
    imagemagick_version: Nicht verfügbar
    imagick_version: Nicht verfügbar
    file_uploads: File uploads is turned off
    post_max_size: 128M
    upload_max_filesize: 128M
    max_effective_size: 128 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.284-icpu-077 x86_64
    httpd_software: Apache
    php_version: 7.4.25 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 1024M
    max_input_time: -1
    upload_max_filesize: 128M
    php_post_max_size: 128M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.5.10-MariaDB-1:10.5.10+maria~buster-log
    client_version: mysqlnd 7.4.25
    
    ### wp-constants ###
    
    WP_HOME: https://nighthorse.live-website.com/
    WP_SITEURL: https://nighthorse.live-website.com/
    WP_CONTENT_DIR: /homepages/10/d891557815/htdocs/app891558584/wp-content
    WP_PLUGIN_DIR: /homepages/10/d891557815/htdocs/app891558584/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 1024M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: not writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: not writable
    
    
    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Moderator Hans-Gerd Gerhards

    (@hage)

    Teste mal bitte unter Design > Customizer > Zusätzliches CSS:

    a.reset_variations {
        display: none;
    }

    Allerdings denke ich, dass du damit eine Funktionalität beschränkst, die in der Regel notwendig sein sollte.

    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Hat sich nichts geändert. Habe den Code eingegeben und veröffentlicht. Der Link „Auswahl zurücksetzen“ erscheint immernoch.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Bei mir nicht – Browsercache gelöscht?

    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Ja, habe sie gelöscht. Macht es einen Unterschied, welches Theme ich benutze? Ich nutze Storefront

    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Nachdem ich wegen anderer Einstellungen jetzt mehrfach die Browserdaten gelöscht habe, funktioniert es auf einmal doch!

    Ich danke dir für die Hilfe!

    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Ich muss leider korrigieren! Hatte aus Versehen die Farbe der Links auf Weiß gesetzt und es daher nicht mehr gesehen. Also funktioniert es leider immernoch nicht. Da ich die anderen Links benötige, ist es keine Lösung

    Dann teste mal bitte unter Design > Customizer > Zusätzliches CSS:

    a.reset_variations {
        display: none!important;
    }

    An dieser Stelle möchte ich aber noch darauf hinweisen, dass wir hier bei WordPress-Fragen helfen. CSS-Probleme gehören in der Regel nicht dazu.
    Eine gute Möglichkeit, sich mit CSS zu beschäftigen, findest du z. B. hier oder hier.

    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Jawohl, ich danke dir vielmals! Das funktioniert!

    Könnte es an anderer Stelle dadurch Probleme geben, oder bezieht sich die Änderung wirklich nur auf den „Auswahl zurücksetzen“ Button?

    Moderator Bego Mario Garde

    (@pixolin)

    Eine CSS-Regel mit einem Selektor a.reset_variations bezieht sich auf alle Links (HTML-Element a) mit der CSS-Klasse reset_variations.

    Jetzt überleg mal, wo das überall auf der Website vorkommen wird.

    🙂

    Thread-Ersteller dennispaden1

    (@dennispaden1)

    Schande über mein Haupt! Hätte ich en bissl genauer lesen können;-) Alles klar, vielen Dank an die tollen Leute hier

Ansicht von 13 Antworten - 1 bis 13 (von insgesamt 13)