Support » Themes » Verlinkte Fotos öffnen nicht mehr entspr. Seite sondern starten Galerie

  • Gelöst cfredricksen

    (@cfredricksen)


    Eigentlich wollte ich nur Dateien (Fotos, PDF, docx), die ich auf unserer Seite zum Download eingestellt habe, so verlinken, dass sich beim User automatisch der Explorer (oder etwas adäquates auf dem Handy) öffnet, damit die Datei gleich gespeichert werden kann. Das funktioniert am PC nur bei der docx-Datei, auf dem Handy mit docx und PDF. Am PC öffnet sich die PDF-Datei in einem eigenen Fenster, zum Download muss man dann aber noch aufs entsprechende Symbol des Web-Acrobat-Readers klicken.Die Fotos öffnen sich nur in einem eigenen Fenster, wenn ich den Text verlinke. Wenn ich die Fotos selbst verlinke, werden sie über der eigentlichen Seite in einer Lightbox eingeblendet wie eine Galerie (was ich nicht eingestellt habe). In beiden Fällen kann man sie nur über die rechte Maustaste downloaden. Ob man „Anhang-Seite“ oder „Mediendatei“ auswählt, wenn man die Fotos verlinkt, macht im Ergebnis keinen Unterschied. Das hat mich schon gewundert.

    Ich habe nun allerdings in dem Zusammenhang ein viel größeres Problem festgestellt:

    Fotos auf der Seite «Band», die ich auf die Unterseiten der Musiker verlinkt sind, werden nun auch einfach in einer Lightbox geöffnet. Das war früher definitiv nicht so (wie noch der Absatz «Klickt auf die Fotos, um mehr über die Band zu erfahren.» zeigt). Da kam man beim Klicken direkt auf die verlinkten Musikerseiten. Die Links sind auch noch bei den Fotos vorhanden, aber die Aktion wird nicht mehr ausgeführt.

    Hier hat sich also entweder in WordPress oder dem Theme was geändert.Wie kann ich es anstellen, dass sich die Fotos nicht öffnen, sondern wieder (wie eingestellt) zu einer anderen Seite führen?

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Thread-Starter cfredricksen

    (@cfredricksen)

    ich weiß jetzt nicht genau, was ich von all den Sachen falsch gemacht habe, kopiere hier aber mal den Zustandsbericht rein

    ### wp-core ###version: 6.1.1site_language: de_DEuser_language: de_DEtimezone: Europe/Parispermalink: /%year%/%monthnum%/%day%/%postname%/https_status: truemultisite: falseuser_registration: 0blog_public: 1default_comment_status: undefinedenvironment_type: productionuser_count: 1dotorg_communication: true### wp-paths-sizes ###wordpress_path: /var/www/htmlwordpress_size: 52,44 MB (54989028 bytes)uploads_path: /var/www/html/wp-content/uploadsuploads_size: 0,00 B (0 bytes)themes_path: /var/www/html/wp-content/themesthemes_size: 20,37 MB (21360867 bytes)plugins_path: /var/www/html/wp-content/pluginsplugins_size: 269,11 kB (275565 bytes)database_size: 11,66 MB (12222464 bytes)total_size: 84,73 MB (88847924 bytes)### wp-active-theme ###name: Hestia (hestia)version: 3.0.26 (latest version: 3.0.29)author: ThemeIsleauthor_website: https://themeisle.comparent_theme: nonetheme_features: core-block-patterns, widgets-block-editor, title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, custom-header, customize-selective-refresh-widgets, custom-background, themeisle-demo-import, align-wide, header-footer-elementor, starter-content, style, script, editor-color-palette, menus, editor-style, widgetstheme_path: /var/www/html/wp-content/themes/hestiaauto_update: Deaktiviert### wp-themes-inactive (4) ###Lighthouse: version: 22.0, author: lighthouseseo, Automatische Aktualisierungen deaktiviertTwenty Twenty-One: version: 1.7, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviertTwenty Twenty-Three: version: 1.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviertTwenty Twenty-Two: version: 1.3, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert### wp-plugins-active (11) ###Better Search Replace: version: 1.4.2, author: WP Engine, Automatische Aktualisierungen aktiviertCheck & Log Email: version: 1.0.7, author: WPChill, Automatische Aktualisierungen aktiviertFooBox Image Lightbox: version: 2.7.25, author: FooPlugins, Automatische Aktualisierungen aktiviertGwolle Guestbook: version: 4.5.0, author: Marcel Pol, Automatische Aktualisierungen aktiviertLocal Google Fonts: version: 0.20.0, author: EverPress, Automatische Aktualisierungen aktiviertMeow Gallery: version: 4.3.4, author: Jordy Meow, Automatische Aktualisierungen aktiviertMeow Lightbox: version: 4.0.2, author: Jordy Meow, Automatische Aktualisierungen aktiviertReal Cookie Banner (Free): version: 3.6.2, author: devowl.io, Automatische Aktualisierungen aktiviertSTAX Header Builder: version: 1.3.6, author: StaxWP, Automatische Aktualisierungen deaktiviertWP SMTP: version: 1.2.5, author: WPChill, Automatische Aktualisierungen aktiviertYoast SEO: version: 20.3, author: Team Yoast, Automatische Aktualisierungen aktiviert### wp-plugins-inactive (1) ###Akismet Anti-Spam: version: 5.1, author: Automattic, Automatische Aktualisierungen aktiviert### wp-media ###image_editor: WP_Image_Editor_Imagickimagick_module_version: 1691imagemagick_version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.orgimagick_version: 3.6.0file_uploads: File uploads is turned offpost_max_size: 64Mupload_max_filesize: 64Mmax_effective_size: 64 MBmax_file_uploads: 20imagick_limits: imagick::RESOURCETYPE_AREA: 122 MB imagick::RESOURCETYPE_DISK: 1073741824 imagick::RESOURCETYPE_FILE: 393216 imagick::RESOURCETYPE_MAP: 512 MB imagick::RESOURCETYPE_MEMORY: 256 MB imagick::RESOURCETYPE_THREAD: 1imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUVgd_version: bundled (2.1.0 compatible)gd_formats: GIF, JPEG, PNG, WebP, BMPghostscript_version: 9.53.3### wp-server ###server_architecture: Linux 5.10.0-21-amd64 x86_64httpd_software: nginx/1.23.3php_version: 8.0.26 64bitphp_sapi: fpm-fcgimax_input_variables: 1000time_limit: 300memory_limit: 256Mmax_input_time: 1000upload_max_filesize: 64Mphp_post_max_size: 64Mcurl_version: 7.74.0 OpenSSL/1.1.1nsuhosin: falseimagick_availability: truepretty_permalinks: truehtaccess_extra_rules: false### wp-database ###extension: mysqliserver_version: 10.5.15-MariaDB-0+deb11u1client_version: mysqlnd 8.0.26max_allowed_packet: 16777216max_connections: 151### wp-constants ###WP_HOME: undefinedWP_SITEURL: undefinedWP_CONTENT_DIR: /var/www/html/wp-contentWP_PLUGIN_DIR: /var/www/html/wp-content/pluginsWP_MEMORY_LIMIT: 40MWP_MAX_MEMORY_LIMIT: 256MWP_DEBUG: falseWP_DEBUG_DISPLAY: trueWP_DEBUG_LOG: falseSCRIPT_DEBUG: falseWP_CACHE: falseCONCATENATE_SCRIPTS: undefinedCOMPRESS_SCRIPTS: undefinedCOMPRESS_CSS: undefinedWP_ENVIRONMENT_TYPE: Nicht definiertDB_CHARSET: utf8DB_COLLATE: undefined### wp-filesystem ###wordpress: writablewp-content: writableuploads: writableplugins: writablethemes: writable

    ich weiß jetzt nicht genau, was ich von all den Sachen falsch gemacht habe, kopiere hier aber mal den Zustandsbericht rein

    Der Website-Bericht ist leider nicht vollständig:

    Wenn du dann noch die URL oben einträgst, dann können wir uns das auch zunächst im Frontend ansehen und dir sicher besser helfen.

    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Lies bitte auch noch mal: Bevor du ein neues Thema (Thread) erstellst.

    Thread-Starter cfredricksen

    (@cfredricksen)

    Merkwürdig. Ich hatte zwei Wörter verlinkt und oben auch die URL der Webseite eingetragen. Das scheint übers Handy nicht funktioniert zu haben. Jetzt verstehe ich natürlich den Post 😌

    http://www.giant-hogweed.com

    https://www.giant-hogweed.com/veranstalter/

    https://www.giant-hogweed.com/die-band/

    Thread-Starter cfredricksen

    (@cfredricksen)

    hier kommt noch mal der Bericht. Ich habe gewartet und der Zustand wurde als „gut“ angezeigt. In dem grünen Ring war nur ein kleiner Bereich grau. Da tat sich dann aber auch nach mehreren Sekunden nichts mehr. Ich hoffe, dass es nun stimmt.

    Vielen Dank schon mal.

    wp-core
    
    version: 6.1.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Paris
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: undefined
    environment_type: production
    user_count: 1
    dotorg_communication: true wp-paths-sizes wordpress_path: /var/www/html
    wordpress_size: 52,44 MB (54989028 bytes)
    uploads_path: /var/www/html/wp-content/uploads
    uploads_size: 0,00 B (0 bytes)
    themes_path: /var/www/html/wp-content/themes
    themes_size: 20,37 MB (21360867 bytes)
    plugins_path: /var/www/html/wp-content/plugins
    plugins_size: 269,11 kB (275565 bytes)
    database_size: 11,66 MB (12222464 bytes)
    total_size: 84,73 MB (88847924 bytes) wp-active-theme name: Hestia (hestia)
    version: 3.0.26 (latest version: 3.0.29)
    author: ThemeIsle
    author_website: https://themeisle.com
    parent_theme: none
    theme_features: core-block-patterns, widgets-block-editor, title-tag, post-thumbnails, automatic-feed-links, custom-logo, html5, custom-header, customize-selective-refresh-widgets, custom-background, themeisle-demo-import, align-wide, header-footer-elementor, starter-content, style, script, editor-color-palette, menus, editor-style, widgets
    theme_path: /var/www/html/wp-content/themes/hestia
    auto_update: Deaktiviert wp-themes-inactive (4) Lighthouse: version: 22.0, author: lighthouseseo, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.7, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Three: version: 1.0, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert
    Twenty Twenty-Two: version: 1.3, author: Das WordPress-Team, Automatische Aktualisierungen deaktiviert wp-plugins-active (11) Better Search Replace: version: 1.4.2, author: WP Engine, Automatische Aktualisierungen aktiviert
    Check & Log Email: version: 1.0.7, author: WPChill, Automatische Aktualisierungen aktiviert
    FooBox Image Lightbox: version: 2.7.25, author: FooPlugins, Automatische Aktualisierungen aktiviert
    Gwolle Guestbook: version: 4.5.0, author: Marcel Pol, Automatische Aktualisierungen aktiviert
    Local Google Fonts: version: 0.20.0, author: EverPress, Automatische Aktualisierungen aktiviert
    Meow Gallery: version: 4.3.4, author: Jordy Meow, Automatische Aktualisierungen aktiviert
    Meow Lightbox: version: 4.0.2, author: Jordy Meow, Automatische Aktualisierungen aktiviert
    Real Cookie Banner (Free): version: 3.6.2, author: devowl.io, Automatische Aktualisierungen aktiviert
    STAX Header Builder: version: 1.3.6, author: StaxWP, Automatische Aktualisierungen deaktiviert
    WP SMTP: version: 1.2.5, author: WPChill, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 20.3, author: Team Yoast, Automatische Aktualisierungen aktiviert wp-plugins-inactive (1) Akismet Anti-Spam: version: 5.1, author: Automattic, Automatische Aktualisierungen aktiviert wp-media image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1691
    imagemagick_version: ImageMagick 6.9.11-60 Q16 x86_64 2021-01-25 https://imagemagick.org
    imagick_version: 3.6.0
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits:
    imagick::RESOURCETYPE_AREA: 122 MB
    imagick::RESOURCETYPE_DISK: 1073741824
    imagick::RESOURCETYPE_FILE: 393216
    imagick::RESOURCETYPE_MAP: 512 MB
    imagick::RESOURCETYPE_MEMORY: 256 MB
    imagick::RESOURCETYPE_THREAD: 1
    imagemagick_file_formats: 3FR, 3G2, 3GP, AAI, AI, APNG, ART, ARW, AVI, AVIF, AVS, BGR, BGRA, BGRO, BIE, BMP, BMP2, BMP3, BRF, CAL, CALS, CANVAS, CAPTION, CIN, CIP, CLIP, CMYK, CMYKA, CR2, CR3, CRW, CUR, CUT, DATA, DCM, DCR, DCX, DDS, DFONT, DNG, DPX, DXT1, DXT5, EPDF, EPI, EPS, EPS2, EPS3, EPSF, EPSI, EPT, EPT2, EPT3, ERF, FAX, FILE, FITS, FRACTAL, FTP, FTS, G3, G4, GIF, GIF87, GRADIENT, GRAY, GRAYA, GROUP4, H, HALD, HDR, HEIC, HISTOGRAM, HRZ, HTM, HTML, HTTP, HTTPS, ICB, ICO, ICON, IIQ, INFO, INLINE, IPL, ISOBRL, ISOBRL6, J2C, J2K, JBG, JBIG, JNG, JNX, JP2, JPC, JPE, JPEG, JPG, JPM, JPS, JPT, JSON, K25, KDC, LABEL, M2V, M4V, MAC, MAGICK, MAP, MASK, MAT, MATTE, MEF, MIFF, MKV, MNG, MONO, MOV, MP4, MPC, MPG, MRW, MSL, MTV, MVG, NEF, NRW, NULL, ORF, OTB, OTF, PAL, PALM, PAM, PATTERN, PBM, PCD, PCDS, PCL, PCT, PCX, PDB, PDF, PDFA, PEF, PES, PFA, PFB, PFM, PGM, PGX, PICON, PICT, PIX, PJPEG, PLASMA, PNG, PNG00, PNG24, PNG32, PNG48, PNG64, PNG8, PNM, POCKETMOD, PPM, PREVIEW, PS, PS2, PS3, PSB, PSD, PTIF, PWP, RADIAL-GRADIENT, RAF, RAS, RAW, RGB, RGBA, RGBO, RGF, RLA, RLE, RMF, RW2, SCR, SCT, SFW, SGI, SHTML, SIX, SIXEL, SPARSE-COLOR, SR2, SRF, STEGANO, SUN, TEXT, TGA, THUMBNAIL, TIFF, TIFF64, TILE, TIM, TTC, TTF, TXT, UBRL, UBRL6, UIL, UYVY, VDA, VICAR, VID, VIDEO, VIFF, VIPS, VST, WBMP, WEBM, WEBP, WMV, WPG, X, X3F, XBM, XC, XCF, XPM, XPS, XV, XWD, YCbCr, YCbCrA, YUV
    gd_version: bundled (2.1.0 compatible)
    gd_formats: GIF, JPEG, PNG, WebP, BMP
    ghostscript_version: 9.53.3 wp-server server_architecture: Linux 5.10.0-21-amd64 x86_64
    httpd_software: nginx/1.23.3
    php_version: 8.0.26 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 300
    memory_limit: 256M
    max_input_time: 1000
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.74.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false wp-database extension: mysqli
    server_version: 10.5.15-MariaDB-0+deb11u1
    client_version: mysqlnd 8.0.26
    max_allowed_packet: 16777216
    max_connections: 151 wp-constants WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/html/wp-content
    WP_PLUGIN_DIR: /var/www/html/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Nicht definiert
    DB_CHARSET: utf8
    DB_COLLATE: undefined wp-filesystem wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von cfredricksen.
    Thread-Starter cfredricksen

    (@cfredricksen)

    Zusatz: Wenn man auf der Band-Seite lang auf ein Foto drückt und dann die Option „in neuem Tab öffnen“ wählt, öffnet sich korrekt die verlinkte Musiker-Seite und nicht etwa (wie man annehmen könnte) das Foto.

    Das zeigt, dass der Link noch da ist, aber irgendetwas „Übergeordnetes“ verhindert, dass die Aktion durch einfaches Klicken ausgeführt wird.

    • Diese Antwort wurde geändert vor 1 Jahr, 1 Monat von cfredricksen.
    Thread-Starter cfredricksen

    (@cfredricksen)

    Ich habe nun weiter probiert und es scheint an der Meow Lightbox zu liegen, die einfach beim Klick auf egal welches Bild/Foto etc. anspricht. Das war früher allerdings nicht so.
    Wenn man sie deaktiviert, funktionieren die Links bzw. werden die für den Download vorgesehen Bilder wie programmiert in einem eigenen Fenster geöffnet.

    Ich werde mal im Meow-Forum nachfragen, was man da machen kann.

    Danke für die Rückmeldung.
    Es wäre schön, wenn du bei einer evtl. Lösung des Problems die Lösung hier kurz für Mitleser beschreibst.

    Noch einige Hinweise, die aber eher nichts mit dem Problem zu tun haben:

    • Better Search Replace sollte gelöscht werden, wenn es nicht mehr benötigt wird.
    • Inaktive Themes und Plugins sollten schon aus Sicherheitsgründen gelöscht werden

    Das Problem muss nicht unbedingt mit dem Plugin Meow Lightbox zusammenhängen. Es kann auch durchaus sein, dass das durch ein Update bei einem anderen Plugin ausgelöst wird. Deaktiviere doch zunächst bitte alle Plugins und aktiviere dann Plugin für Plugin und am besten das Plugin Meow Lightbox zuerst. Teste danach jeweils, ob das Problem behoben ist. Sobald es dann nach Aktivierung eines Plugins das beschriebene Problem gibt, weißt du, welches Plugin evtl. das Problem verursacht.

    Thread-Starter cfredricksen

    (@cfredricksen)

    Durch weiteres testen kann ich nun mit Sicherheit sagen: Der Grund war Meow Lightbox. Hier gibt es in den Settings eine Spalte für „Selectors“. Darin standen: .entry-content, .gallery, .mgl-gallery, .wp-block-gallery, .wp-block-image
    Nachdem ich .wp-block-image gelöscht hatte, funktioniert wieder alles, wie es sollte.

    Was das Löschen von Plugins betrifft, war ich anfangs noch am Austesten, welche Lightbox ich bspw. benutzen soll. Die Entscheidung ist nun auf alle Fälle gefallen, da die Meow sich unaufdringlich einfügt.

    Danke für die Rückmeldung.

    Kannst du das Thema dann bitte als gelöst markieren, wenn das Problem damit für dich behoben ist:
    Gelöst
    Die Option findest du rechts in der Sidebar. Danke.

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Das Thema „Verlinkte Fotos öffnen nicht mehr entspr. Seite sondern starten Galerie“ ist für neue Antworten geschlossen.