Support » Allgemeine Fragen » Veröffentlichen mit dem Customizer funktioniert nicht

  • Hallo Zusammen,

    ich habe das Problem, dass wenn ich im Customizer auf die Schaltfläche „Veröffentlichen“ klicke kurz ein Ladesymbol angezeigt wird und dann aber nichts passiert. Wiederhole ich das klicken auf die Schaltfläche wird dort Planung angezeigt. Das speichern der Änderungen funktioniert. Schließe ich nach Änderungen den Customizer und kehre danach wieder zurück wird folgende Meldung angezeigt: Deine geplanten Änderungen wurden gerade veröffentlicht
    Das scheint aber ein Fehler zu sein, denn veröffentlicht wurde nichts. Es bleiben alle Änderungen nur in der gespeicherten Version vorhanden. Geplante Änderungen werden ebenfalls nicht veröffentlicht.

    Server: vServer von Strato mit ausreichend Ressourcen.
    Die WordPress Installation habe ich über Plesk voll automatisch durchgeführt.
    Auf dem Server läuft sonst nur ein Webshop (Module wie PHP sollten sich nicht in die Quere kommen).
    Es sind keine Plugins installiert oder aktiviert.
    Ich benutze das Standard Twenty Seventeen Theme.
    Die Website ist absolut frisch installiert und trotzdem habe ich diesen Fehler.

    Ich habe dann eine ältere Version von WordPress installiert (4.9.8). Das hat das Problem behoben. Ich konnte alles wie erwartet ohne Fehler nutzen. Habe dann auch mal direkt aus WordPress das Update gemacht statt durch Plesk, danach tritt der Fehler wieder auf.
    Dadurch konnte ich den Fehler mit Sicherheit angrenzender Wahrscheinlichkeit WordPress zuordnen. Es muss sich zwischen Version 4.9.8 und meiner aktuellen 5.4.2 verändert haben.

    Weitere Abnormitäten konnte ich nicht feststellen.
    Egal wie ich die neue Version installieren, ob mit oder ohne Plesk bleibt der Fehler. Jedoch nur auf der neusten WordPress Version (5.4.2).
    Uhrzeit und Datum habe ich auf den deutschen Standard (Berlin) eingestellt.

    Vielleicht kennt jemand von euch das Problem. Wäre sehr an einer Lösung interessiert. Ganz vielen Dank schonmal im Voraus an alle die sich mit meinem Problem beschäftigen. 🙂

    LG Janek

    • Dieses Thema wurde geändert vor 2 Jahre, 2 Monaten von janek007.
    • Dieses Thema wurde geändert vor 2 Jahre, 2 Monaten von janek007.
    • Dieses Thema wurde geändert vor 2 Jahre, 2 Monaten von janek007.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hallo,
    das Problem kenne ich persönlich so nicht.
    Aber du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website und kannst den Bericht über den Button „Bericht in die Zwischenablage kopieren“ und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Du kannst außerdem nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Zusätzlich ist als theme (falls vorhanden) ein Standardtheme wie z. B. twenty twenty aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung eines Plugins, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise ein Plugin finden, dass das Problem verursacht. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag Health Check durch.
    Viele Grüße,
    Hans-Gerd

    Ist zwar schon eine Weile Her
    Gibt es eine Lösung

    Ich habe das selbe Problem
    Eine clean Installation
    Ohne Themen außer die die dabei sind
    Classic Editor ( der andere gefällt mir nicht )
    und seit heute WP Control
    Dies ist eine
    Multisite
    die ich gerade aufbauen will
    Deswegen noch Ohne
    SSL
    Teschter.de
    ist die Adresse

    Hier der Bericht
    ———————–

    
    ### wp-core ###
    
    version: 5.5.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: false
    multisite: true
    user_registration: false
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    site_count: 1
    network_count: 1
    dotorg_communication: true
    
    ### wp-active-theme ###
    
    name: Twenty Nineteen (twentynineteen)
    version: 1.7
    author: WordPress-Team
    author_website: https://de.wordpress.org/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-logo, customize-selective-refresh-widgets, wp-block-styles, align-wide, editor-styles, editor-style, editor-font-sizes, editor-color-palette, responsive-embeds, widgets
    theme_path: /hp/bt/ac/ur/www/tescht/wp-content/themes/twentynineteen
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (2) ###
    
    Twenty Seventeen: version: 2.4, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.5, author: WordPress-Team,Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (2) ###
    
    Classic Editor: version: 1.6, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    WP Crontrol: version: 1.8.5, author: John Blackbourn & crontributors, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 2048M
    upload_max_filesize: 2048M
    max_effective_size: 2 GB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 6144
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: 2.2.5
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-112-generic x86_64
    httpd_software: Apache
    php_version: 7.2.24-0ubuntu0.18.04.7 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 512M
    max_input_time: 60
    upload_max_filesize: 2048M
    php_post_max_size: 2048M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.32-0ubuntu0.18.04.1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /hp/bt/ac/ur/www/tescht/wp-content
    WP_PLUGIN_DIR: /hp/bt/ac/ur/www/tescht/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8mb4
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    —————————————

    Es nervt wenn ich etwas veröffentlichen will dann jetzt

    Moderationshinweis:
    @richy1967 Crosspostings nerven auch. Lass das bitte.

    Nun Sorry aber ich verstehe das nicht als Crossposting sonder nur als Nachfrage
    Aber egal ne Lösung wäre besser

    Denke Ich zumindest
    ABer egal
    Sorry

    Habe es mittlerweile gelöst bekommen
    Bin bei 1Blu als Hoster
    hier muss man die PHP Version aktualisieren auf die Neuste
    geht über eine Info.php die man bei dennen direkt bei 1blu auch Downloaden kann

    Grüße

    Es kann auch an CentOS7 liegen. Eine UTC Datei auf welche WordPress sich bezieht scheint fehlerhaft zu sein. Ich habe eine Lösung im englischen Forum verfasst:

    https://wordpress.org/support/topic/cant-customize-the-theme-2/#post-13631678

    The problem is CentosOS7 related. The UTC time file is wrong or causes the issue with wordpress.

    following this link:
    https://talk.plesk.com/threads/utc-time-issue-plesk-php-7-3-7-4-on-centos7.356169/

    and then this link:
    https://talk.plesk.com/threads/utc-time-issue-plesk-php-7-3-7-4-on-centos7.356169/

    I found that you need to replace the /usr/share/zoneinfo/UTC file. The second link contain a file that you can use to replace (you have to register to be able to download). As described after replacing the file you can immediately publish in wordpress without reboot of the server.

    Hope this will help some of you!

    Vielleicht hilft es dem einen oder anderen

    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von alexllll.
    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von alexllll.
    • Diese Antwort wurde geändert vor 1 Jahr, 10 Monaten von alexllll.

    danke für die Info.

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Veröffentlichen mit dem Customizer funktioniert nicht“ ist für neue Antworten geschlossen.