Support » Allgemeine Fragen » Veröffentlichung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.

  • Gelöst frankae

    (@frankae)


    Hallo Zusammen,
    ich weiß, dieses Thema gibt es schon mal, jedoch finde ich keine passende Lösung…

    Ich kann keine Seiten anlegen oder speichern. Bekomme immer die Fehlermeldung „Veröffentlichung fehlgeschlagen. Die Antwort ist keine gültige JSON-Antwort.“

    Unter Website-Zustand kommt folgende Meldung
    „die REST-API kam zu einem unerwarteten Ergebnis“
    Die REST-API ist eine Möglichkeit, wie WordPress und andere Anwendungen mit dem Server kommunizieren. Ein Beispiel ist der Bildschirm des Block-Editors, der darauf aufbaut, deine Beiträge und Seiten anzuzeigen und zu speichern.

    Der Aufruf der REST-API führte zu folgendem unerwarteten Ergebnis: (404) <!DOCTYPE HTML PUBLIC „-//IETF//DTD HTML 2.0//EN“> <html><head> <title>404 Not Found</title> </head><body> <h1>Not Found</h1> <p>The requested URL was not found on this server.</p> </body></html> .`

    Ich habe bereits versucht:
    – die Permalinks neu zu speichern
    – WordPress neu aufgesetzt
    – die htaccess neu erstellt

    Ich hoste bei: https://homepagecenter.telekom.de/

    Kann mir irgendjemand helfen?

    Vielen, lieben Dank vorab
    Herzliche Grüße
    Franka

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Schade, mit dem „Coming-Soon“-Bildschirm kann ich mir die Website nicht anschauen.

    Hast du Permalinks eingerichtet?

    Sind unter Einstellungen > Allgemein beide URLs identisch (mit https://…)?

    Thread-Ersteller frankae

    (@frankae)

    Sorry, jetzt geht es 🙂

    Ja Permalinks: Beitragsname

    Ja, beide URLs identisch

    Da scheint aber ewas mit den Permalinks nicht zu stimmen. Ich bekomme bei Aufruf der Seite „Über uns“ nur ein „Not found“. Schau mal per FTP, ob eine .htaccess angelegt wurde.

    Bei Fragen zu gekauften Themes (hier: Divi) können wir dir nicht weiterhelfen, weil sie uns für einen kostenlosen Support nicht kostenlos zur Verfügung stehen.

    Bitte wende dich bei Fragen zu diesem Theme an die Entwickler.

    Thread-Ersteller frankae

    (@frankae)

    Ja, htaccess ist vorhanden:

    # BEGIN WordPress
    # Die Anweisungen (Zeilen) zwischen „BEGIN WordPress“ und „END WordPress“ sind
    # dynamisch generiert und sollten nur über WordPress-Filter geändert werden.
    # Alle Änderungen an den Anweisungen zwischen diesen Markierungen werden überschrieben.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Es funktioniert auch nicht mit dem Standard-Theme. Gleiche Fehler, gleiche Meldung.

    Laut diesem Hilfedokument musst du für die Nutzung einer .htaccess erst eine Serverkonfigurationsdatei httpd.conf anlegen – hast du das gemacht?

    (Vielleicht hast du ja auch noch die Möglichkeit, einen geeigneteren Webhoster zu suchen und die Website dort einzurichten? Ein Webhoster, der seine Kunden nötigt, eine httpd.conf anzulegen um eine .htaccess zu nutzen, erscheint mir nicht zeitgemäß.)

    Thread-Ersteller frankae

    (@frankae)

    Danke habe ich nun gemacht…

    leider funktioniert das immer noch nicht nicht 🙁

    Danke habe ich nun gemacht…

    Erzähl doch bitte mal genauer, was du jetzt gemacht hast.

    Thread-Ersteller frankae

    (@frankae)

    eine httpd.conf erstellt (wie in der Beschreibung) und in den Ordner etc gelegt

    Und danach nochmals die Permalinks gespeichert

    • Diese Antwort wurde geändert vor 3 Monaten, 3 Wochen von frankae.

    Du kannst nochmal testen, ob es tatsächlich an den Permalinks liegt: .htaccess wieder löschen und im Backend die Permalinks auf „einfach“ stellen. Lässt sich damit die Seite „Über uns“ ohne Fehlermeldung aufrufen? Dann liegt es eindeutig an den Permalinks und du solltest den Support des Webhosters anrufen. Oder wie gesagt einen geeigneteren Webhoster auswählen.

    Thread-Ersteller frankae

    (@frankae)

    also habe die .htaccess gelöscht und auf Permalinks „Einfach“ gestellt. Die Seite über uns lässt sich zwar nicht aufrufen aber ich kann nun neue Seiten erstellen…

    Was muss ich dem Webhoster nun sagen?

    Leider liegt die Wahl des Webhosters nicht in meiner Hand 🙁

    Die Seite über uns lässt sich zwar nicht aufrufen

    Für mich schon. Browser-Cache geleert? Nochmal ausprobiert?

    Leider liegt die Wahl des Webhosters nicht in meiner Hand 🙁

    In dem Fall rasch den Kunden wechseln oder die Aufgabe ablehnen. 🙂

    Was muss ich dem Webhoster nun sagen?

    Dass sie ihren Webserver in Ordnung bringen sollen.
    Die freundlichere Formulierung wäre, dass du WordPress installieren möchtest, aber die Einrichtung von Permalinks nicht funktioniert. Der/die Supportmitarbeiter/-in wird dir dann erklären, dass sie für Webanwendugen nicht zuständig wären. In dem Fall hilft ein Verweis auf das Hilfedokument, dass du erfolglos umgesetzt hast.

    Die Website hast du unter /home/www/public_html angelegt?

    Thread-Ersteller frankae

    (@frankae)

    Ok, vielen lieben Dank!!!

    Lies dir dazu bitte noch diesen Beitrag von Marc durch, der auch einen Link zu einem Workaround enthält:

    Deutsche Telekom: .htaccess nicht möglich

    Workaround: Permalinks bei T-Online

    Thread-Ersteller frankae

    (@frankae)

    ich habe den Support nochmals angeschrieben und warte nun auf Antwort.

    Der Workaround ist keine Alternative für mich 🙁

    Ich werde es voraussichtlich mit einer anderen Domain (bei einem anderen Hoster) und Umleitungen lösen.

    Vielen, herzlichen Dank dir nochmal!

    Dann markiere ich den Thread mal als „gelöst“. Meld dich, wenn wir dir noch weiterhelfen können … oder schreib einen neuen Thread. Ich drück‘ die Daumen, dass sich eine für alle Beteiligten befriedigende Lösung findet.

    Kleine Argumentationshilfe: Es gibt schon für 60,– Euro im Jahr ganz brauchbares Shared Hosting, das für eine einfache Firmenpräsenz ausreichen sollte. Das sind Werbekosten, die auch steuerlich berücksichtigt werden. Wir sprechen hier also von Beträgen aus der sprichwörtlichen Portokasse. Es gibt auch Webhoster, die sich auf WordPress spezialisiert haben, dann aber etwas teurer ausfallen. Macht dann aber wegen der zusätzlichen Leistungen unter Umständen Sinn.

    Eine Domain lässt sich umziehen, aber zur Not reicht auch eine Weiterleitung.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)