Support » Allgemeine Fragen » Verückte Formatierung

  • catacas

    (@catacas)


    Hallo,
    Ich habe auf meinem PC, mit XAMPP, eine WordPress seit
    erstellt. Wenn ich von dem selben Computer versuche darauf
    zuzugreifen funktioniert das einwandfrei.
    Sobald ich einen anderen PC in Netzwerk nutze habe ich
    das Gefühl, das die komplette Formatieren futsch ist.

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Moderator espiat

    (@espiat)

    Hallo,

    vielleicht hast du für die CSS im header einen absoluten und keinen relativen Pfad genommen. Das vermute ich nur, da ich das Szenario, so wie du es beschreibst nicht kenne.

    catacas

    (@catacas)

    Ich kenn mich mit solchen sachen nicht alzu gut aus, wie könnte ich das denn änder?

    Moderator espiat

    (@espiat)

    Findest du die header.php des Themes?

    Steht dort sowas?

    <link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />

    Was bedeutet eigentlich ganz genau? “ … Formatieren futsch ist.“

    Als Einstieg kann ich dir dieses Tutorial empfehlen.
    http://learncss.tutsplus.com/

    catacas

    (@catacas)

    Die gennante Zeile habe ich in der Datei nicht gefunden.
    Hier habe ich aber 2 Screenshots

    wie es aussehen sollte: https://www.dropbox.com/s/cwv0bcz3ff4xcyi/Unbenannt12.PNG

    wie es aussieht: https://www.dropbox.com/s/ncb8wmpful57s0l/Screenshot_2013-02-13-18-00-53.png

    Moderator espiat

    (@espiat)

    Poste hier bitte mal den gesamten Inhalt der header.php deines templates.

    Hast du das Theme selbst installiert oder gro? verändert?

    Wer hat die WordPress installation gemacht mit xampp und so?

    Wie gesagt, so eine Umgebung (Xampp -> Netzwerkzugriff) habe ich selbst noch nicht getestet.

    catacas

    (@catacas)

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <meta charset="<?php bloginfo('charset'); ?>" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title><?php wp_title(); ?></title>
    <link rel="profile" href="http://gmpg.org/xfn/11" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    <?php wp_head(); ?>
    </head>
    
    <body <?php body_class() ?>>
    	<div id="wrapper">
    		<header id="header">
    			<<?php pinboard_title_tag( 'site' ); ?> id="site-title">
    				<?php if ( ( '' != get_header_image() ) &&  ( false != get_header_image() ) ) : ?>
    					<a href="<?php echo home_url( '/' ); ?>" rel="home">
    						<img src="<?php header_image(); ?>" alt="<?php bloginfo( 'name' ); ?>" width="<?php echo ( pinboard_get_option( 'retina_header' ) ? absint( get_custom_header()->width / 2 ) : get_custom_header()->width ); ?>" height="<?php echo ( pinboard_get_option( 'retina_header' ) ? absint( get_custom_header()->height / 2 ) : get_custom_header()->height ); ?>" />
    					</a>
    				<?php endif; ?>
    				<a class="home" href="<?php echo home_url( '/' ); ?>" rel="home"><?php bloginfo( 'name' ); ?></a>
    			</<?php pinboard_title_tag( 'site' ); ?>>
    			<?php if( ! is_active_sidebar( 1 ) ) : ?>
    				<<?php pinboard_title_tag( 'desc' ); ?> id="site-description"><?php bloginfo( 'description' ); ?></<?php pinboard_title_tag( 'desc' ); ?>>
    			<?php endif; ?>
    			<?php get_sidebar( 'header' ); ?>
    			<div class="clear"></div>
    			<nav id="access">
    				<a class="nav-show" href="#access">Show Navigation</a>
    				<a class="nav-hide" href="#nogo">Hide Navigation</a>
    				<?php wp_nav_menu( array( 'theme_location' => 'primary_nav' ) ); ?>
    				<div class="clear"></div>
    			</nav><!-- #access -->
    		</header><!-- #header -->

    Ich habe das Theme mit dem WordPress eigenen Themeinstaller installiert.
    Ich habe die Standart dateien in den Htdocs ordner eingefügt und mich dann schritt für Schritt durch die installation gearbeitet.

    Moderator espiat

    (@espiat)

    Hallo,

    sage mir mal welches Theme das ist- ich teste das theme dann mal selber.

    Es fehlt definitiv der Verweis zur CSS, von daher kann das Design eigentlich gar nicht funktionieren, auch nicht lokal.

    catacas

    (@catacas)

    Das Design ist von One Design und heißt: Pinboard

    Moderator Frank Neumann-Staude

    (@fstaude)

    Hallo,

    wie greifst du auf deinem Hauptrechner auf WordPress zu?
    Per Namen? und von dem Remoterechner per IP?
    Dann wird der Remoterowser evt versuchen unter http://deinname&#8230;. die CSS Datei zu liefern und die kann er nicht laden, weil auf dem Rechner der Name nicht aufgelöst werden kann.

    Gruß
    Frank

Ansicht von 9 Antworten - 1 bis 9 (von insgesamt 9)
  • Das Thema „Verückte Formatierung“ ist für neue Antworten geschlossen.