Support » Allgemeine Fragen » Video wird nicht abgespielt

  • Gelöst WM_SSV

    (@wm_ssv)


    Guten Tag,

    ich wollte ein selbst erstelltes mp4-Video in einen Beitrag oder eine Seite einbinden mit dem in WP integrierten Player.

    Beim Aufruf von Seite oder Beitrag wird der Player zwar angezeigt, aber das Video nicht abgespielt, auch nicht beim Betätigen der Play-Taste.

    Zum Beweis, dass es kein Problem meines Hosters und dass der von mir verwendete Player mit der Hostingplattform kompatibel ist, hat mir der Hoster die Beispielseite des MediaElement.js-Players auf meinem Paket in ein Verzeichnis installiert. So habe ich nun eine Version des Video-Players, die funktioniert, und eine, die nicht funktioniert.

    Der Hoster empfiehlt mir nun, beide Versionen zu vergleichen und damit den Fehler zu finden. Auf Seite der Hostingplattform könne nichts weiter getan werden. Die Ursache müsse an der Einbindung des Players (oder Player-Plugins) in meinem WordPress liegen.

    Wie debugge ich das jetzt bzw. woran könnte das jetzt noch liegen? Etwa an dem verwendeten Theme (ich beutze zBench).

    Vielen Dank für jegliches Feedback!

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Edi

    (@psychosopher)

    Der Hoster empfiehlt mir nun, beide Versionen zu vergleichen und damit den Fehler zu finden.

    Hast Du das gemacht? Welche Unterschiede bestehen (Einbindung des Players usw.)?

    Vielen Dank für die schnelle Antwort.

    Ich muss gestehen, dass ich (noch) nicht ganz kapiert habe, was ich da jetzt genau tun soll. Den HTML-Code aus der Installation, wo es läuft, in meine Seite, wo es nicht läuft, kopieren und gucken, ob das Testvideo von MediaElement.js läuft?

    Erst mal wollte ich jetzt durch simples Umswitchen auf ein WP-Standard-Theme testen, ob es am Theme liegt? Eine sinnvolle Maßnahme?

    Es liegt augenscheinlich an meinen mp4-Videos selbst, die ich mit einer Freeware aus wmv konvertiert habe. Irgendwas scheint mit denen nicht zu stimmen, ich weiß nur nicht was und wie ich das korrigiert bekomme bzw. richtig mache.

    Ich habe nämlich aus dem WWW von einer Seite ein MP4-Testvideo heruntergeladen, dieses in das WP-Medienverzeichnis hochgeladen und mittels „Datei einfügen“ in meine Test-Seite eingefügt.

    Funktioniert einwandfrei. Wird wie gewünscht abgespielt, wenn ich im Browser die Play-Taste betätige.

    So, andere Freeware für die Konvertierung von wmv nach mp4 installiert und verwendet.

    Außer, dass die mp4-Datei gegenüber der zuvor verwendeten Konvertierungs-Software jetzt nur noch ein Viertel so groß ist, funktioniert es jetzt auch mit dem simplen Dateieinfügen in eine Seite oder einen Beitrag.

    Edi

    (@psychosopher)

    Gut, dass Du das herausgefunden hast! „Fernwartung“ wäre da schwierig gewesen.

    Ich bin immer noch verblüfft, dass „Freemake Video Converter“ die Konvertierung im Gegensatz zu „Free MP4 Video Converter“ vernünftig schafft, um die beiden Produkte auch mal beim Namen zu nennen – für den Fall, dass noch jemand solche Phänomene feststellen sollte.

Ansicht von 6 Antworten - 1 bis 6 (von insgesamt 6)
  • Das Thema „Video wird nicht abgespielt“ ist für neue Antworten geschlossen.