Support » Allgemeine Fragen » Viele „Seiten nicht gefunden“ in den Webmastertools

  • Hallo,
    ich habe kürzlich meine Website auf WordPress umgestellt. Die alten Seiten habe ich per redirect auf die neuen Seiten geleitet. Jettz melden mir die Webmastertools viele (über 1000) Fehler mit „Seite nicht gefunden“. Beispielsweise:

    http://www.kaiserstuhl.eu/Orte/Sasbach/Sabach/sasbacher-wein.htm/Natur/Jechtingen/Wein/php/formular_vermietung.htm

    Was mixen die da zusammen? Der Teil http://www.kaiserstuhl.eu/Orte/Sasbach/Sabach/sasbacher-wein.htm/ gibt es als Seite in WP. Der Rest ist aus der alten Domain, teilweise wahllos zusammen gestückelt.

    Ich hatte erst die .htaccess in Verdacht und habe alle redirects gelöscht. Aber die Fehler blieben, bzw. sind wieder gekommen nachdem ich sie in den Webmastertools entfernt hatte.

    Die ersten Zeilen der htccess:

     
    # BEGIN WordPress
        <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteRule ^index\.php$ - [L]
        RewriteCond %{REQUEST_FILENAME} !-f
        RewriteCond %{REQUEST_FILENAME} !-d
        RewriteRule . /index.php [L]
        </IfModule>
        # END WordPress
    
    RedirectPermanent /Aktiv/aktiv-am-kaiserstuhl.htm http://www.kaiserstuhl.eu/aktiver-urlaub-am-kaiserstuhl/
    RedirectPermanent /Aktiv/angeln.htm http://www.kaiserstuhl.eu/aktiver-urlaub-am-kaiserstuhl/angeln/
    

    Ist da irgend ein Fehler? Wo könnte ich ansetzen um diese Fehler wegzubekommen? Hat da jemand eine Idee?

    Viele Grüße

    Rolf

    • Dieses Thema wurde geändert vor 5 Jahre, 10 Monaten von rolch.
Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Die WordPress-Regeln sollten am Ende stehen, weil sonst die nachfolgenden Regeln nicht mehr greifen.

    Thread-Ersteller rolch

    (@rolch)

    Die nachfolgenden Regeln funktionieren aber wunderbar. Alle alten Seiten die in der .htaccess gelistet sind werden korrekt umgeleitet (ich habe zwar nicht alle probiert, aber stichprobenartig). Von daher glaube ich nicht, dass dies das Problem ist.

    Ich kann das aber gerne mal ändern, nur muss ich jetzt wieder ein paar Tage warten um dann die Webmastertools zu kontrollieren, ob diese falschen Links immer noch dabei sind. Da läuft mir so langsam die zeit davon. Oder gibt es eine andere Möglichkeit das zu testen?

    Du kannst deine Website in der Search Console doch neu crawlen lassen?

Ansicht von 3 Antworten - 1 bis 3 (von insgesamt 3)
  • Das Thema „Viele „Seiten nicht gefunden“ in den Webmastertools“ ist für neue Antworten geschlossen.