Support » Allgemeine Fragen » Visuell-Editor häufig leer

  • Hallo,

    für meinen Blog, der bei all-inkl gehostet ist, nutze ich als CMS WordPress 5.6.

    Leider habe ich in letzter Zeit immer häufiger Probleme mit dem Editieren von Beiträgen. Mein Problem ist, dass häufig im Editor-Fenster für einen Blog-Beitrag kein Inhalt erscheint (Editor-Fenster „Visuell“ ist leer, im „Text“-Fenster sehe ich jedoch den HTML-Code). Erst durch mehrfaches Drücken von F5 sind die Inhalte in dem Visuell-Editor wieder zusehen. Manchmal muss ich die Editor-Seite mehrfach laden, um weiterarbeiten zu können, was häufig recht zeitaufwändig ist.

    Könnt Ihr mir bei diesem Problem helfen? In der Vergangenheit ist dieses Problem nicht aufgetreten, daher wäre eine meiner Vermutung, dass durch die vielen Inhalte, die ich in letzter Zeit ergänzt habe, es zu Auslastungsproblemen bei all-inkl kommt (z.B. Rechenleitung, Speicherplatz). Ich habe auch versucht, alle Plug-Ins zu deaktivieren, aber das hat leider nicht geholfen. Vielleicht haben Sie eine Idee. Eine weitere Idee, die ich habe, ist, dass der Classic-Editor diese Probleme verursacht.

    Vielen Dank.

    Beste Grüße,

    Chris

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Auch wenn du bereits alle Plugins deaktiviert hattest, kannst du ja mal nach einer Sicherung das plugin Health Check & Troubleshooting installieren. Wenn du auf den Button „Problembehandlungsmodus aktivieren“ unter Problembehandlung klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller zubr

    (@zubr)

    Danke, anbei der Bericht (habe nur die URL anonymisiert):

    
    ### wp-core ###
    
    version: 5.6
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 4
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/MEINEURL
    wordpress_size: 52.10 MB (54628570 bytes)
    uploads_path: /www/htdocs/MEINEURL/wp-content/uploads
    uploads_size: 6.72 GB (7210406311 bytes)
    themes_path: /www/htdocs/MEINEURL/wp-content/themes
    themes_size: 13.77 MB (14441811 bytes)
    plugins_path: /www/htdocs/MEINEURL/wp-content/plugins
    plugins_size: 108.71 MB (113995092 bytes)
    database_size: 21.71 MB (22768684 bytes)
    total_size: 6.91 GB (7416240468 bytes)
    
    ### wp-dropins (1) ###
    
    advanced-cache.php: true
    
    ### wp-active-theme ###
    
    name: Nisarg (nisarg)
    version: 1.2.9
    author: Falguni Desai
    author_website: https://www.falgunithemes.com
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, html5, post-formats, custom-background, custom-header, infinite-scroll, widgets, menus
    theme_path: /www/htdocs/MEINEURL/wp-content/themes/nisarg
    auto_update: Deaktiviert
    
    ### wp-themes-inactive (5) ###
    
    Twenty Nineteen: version: 1.5, author: WordPress-Team (latest version: 1.9), Automatische Aktualisierungen deaktiviert
    Twenty Seventeen: version: 2.3, author: WordPress-Team (latest version: 2.5), Automatische Aktualisierungen deaktiviert
    Twenty Sixteen: version: 2.1, author: WordPress-Team (latest version: 2.3), Automatische Aktualisierungen deaktiviert
    Twenty Twenty: version: 1.2, author: WordPress-Team (latest version: 1.6), Automatische Aktualisierungen deaktiviert
    Twenty Twenty-One: version: 1.0, author: WordPress-Team (latest version: 1.1), Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-active (18) ###
    
    Akismet Anti-Spam: version: 4.1.8, author: Automattic, Automatische Aktualisierungen deaktiviert
    Antispam Bee: version: 2.9.3, author: pluginkollektiv, Automatische Aktualisierungen deaktiviert
    Async JavaScript: version: 2.20.12.09, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Autoptimize: version: 2.8.1, author: Frank Goossens (futtta), Automatische Aktualisierungen deaktiviert
    Better Search Replace: version: 1.3.4, author: Delicious Brains, Automatische Aktualisierungen deaktiviert
    Classic Editor: version: 1.6, author: WordPress Contributors, Automatische Aktualisierungen deaktiviert
    Google Analytics for WordPress by MonsterInsights: version: 7.15.0, author: MonsterInsights, Automatische Aktualisierungen deaktiviert
    Interactive Geo Maps: version: 1.4.5, author: Carlos Moreira, Automatische Aktualisierungen deaktiviert
    Prosodia VGW OS: version: 3.24.11, author: Prosodia – Verlag für Musik und Literatur, Automatische Aktualisierungen deaktiviert
    Smush: version: 3.8.2, author: WPMU DEV, Automatische Aktualisierungen deaktiviert
    Social Media and Share Icons (Ultimate Social Media): version: 2.6.3, author: UltimatelySocial, Automatische Aktualisierungen deaktiviert
    UpdraftPlus - Backup/Restore: version: 1.16.46, author: UpdraftPlus.Com, DavidAnderson, Automatische Aktualisierungen deaktiviert
    WordPress Importer: version: 0.7, author: wordpressdotorg, Automatische Aktualisierungen deaktiviert
    WPForms Lite: version: 1.6.4.1, author: WPForms, Automatische Aktualisierungen deaktiviert
    WPGlobus: version: 2.6.0, author: WPGlobus, Automatische Aktualisierungen deaktiviert
    WP Mail SMTP: version: 2.5.1, author: WPForms, Automatische Aktualisierungen deaktiviert
    WP Super Cache: version: 1.7.1, author: Automattic, Automatische Aktualisierungen deaktiviert
    Yoast SEO: version: 15.6.2, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 200M
    upload_max_filesize: 200M
    max_effective_size: 200 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 8
    gd_version: 2.2.5
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-134-generic x86_64
    httpd_software: Apache
    php_version: 7.4.10 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 10000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 200M
    php_post_max_size: 200M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.28-nmm1-log
    client_version: mysqlnd 7.4.10
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/MEINEURL/wp-content
    WP_PLUGIN_DIR: /www/htdocs/MEINEURL/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: true
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### wpforms ###
    
    version: 1.6.4.1
    lite: Mrz 7, 2020 @ 2:20pm
    upload_dir: Writable
    db_tables: glsbf_wpforms_tasks_meta
    total_forms: undefined
    total_submissions: undefined
    
    ### wp_mail_smtp ###
    
    version: 2.5.1
    license_key_type: lite
    debug: Keine Debug-Hinweise gefunden.
    db_tables: glsbf_wpmailsmtp_tasks_meta
    lite_install_date: Jan 18, 2021 @ 10:39am
    
    

    Siehst du hier ein Problem?

    Viele Grüße

    Dieses Problem kenne ich. Für einen Bekannten betreue ich eine Seite, die mehrsprachig aufgebaut ist und auch dort wird das Plugin WPGlobus benutzt. Ich habe dieses Plugin ganz schwer in Verdacht, konnte das aber bisher nicht mit Sicherheit bestimmen. Mir ist aber aufgefallen, dass manchmal die Sprachkennung von WP-Globus, z.B. {:de} im Quellcode ganz kurz erscheint, wenn man im Textmodus arbeitet. Ich vermute daher, dass ein JavaScript nicht sauber arbeitet, aber das ist nur eine Vermutung.

    Hallo,
    neben dem Hinweis von @bscu hier noch einige Vorschläge zur Problemlösung:

    • wie bereits in meiner ersten Antwort beschrieben würde ich das plugin Health Check & Troubleshooting installieren und anschließend den Problembehandlungsmodus aktivieren.
    • Deaktivierung der Cache-Plugins. Dazu gehören die Plugins WP Super Cache, Autoptimize und Async JavaScript. Bezogen auf die letzten beiden Plugins: Siehe dazu auch die umfangreiche Antwort bezogen auf HTTP/2 von Bego in dem folgenden Thread

    Akismet ist nicht datenschutzkonform. Das Plugin solltest du daher nicht einsetzen.
    Viele Grüße
    Hans-Gerd

    Das scheint ein Problem mit WP-Globus in Verbindung mit TinyMCE zu sein

    Uncaught TypeError: n is null
        i https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        each https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        select https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        w https://www.example.com/wp-admin/js/editor.min.js?ver=5.6:2
        r https://www.example.com/wp-admin/js/editor.min.js?ver=5.6:2
        e https://www.example.com/wp-admin/js/editor.min.js?ver=5.6:2
        C https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        d https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        xe https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        bind https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        on https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        vn https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        each https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        on https://www.example.com/wp-includes/js/tinymce/wp-tinymce.js?ver=49110-20201110:3
        e https://www.example.com/wp-admin/js/editor.min.js?ver=5.6:2
        jQuery 13

    Hallo @bscu
    hast du das schon dem Plugin-Entwickler gemeldet? – Wäre sicher hilfreich.
    Viele Grüße
    Hans-Gerd

    @hage
    Nein, habe ich noch nicht, bisher noch keine Zeit gehabt 😉

    Nachtrag: ich bin mir auch nicht sicher, ob das Problem an WPGlobus oder am TinyMCE-Editor liegt.

    • Diese Antwort wurde geändert vor 10 Monaten, 2 Wochen von bscu.

    Eine Notlösung:

    Wenn man ein Seite bearbeiten will und der Editor im Textmodus startet, kann man in den visuellen Modus umschalten und alles ist sichtbar. Startet der Editor aber im visuellen Modus, dann tritt das Problem auf. Die Notlösung ist also, den Editor immer im Textmodus verlassen. Schön ist anders, aber bis zu einer vernünftigen Endlösung besser als nichts.

    • Diese Antwort wurde geändert vor 10 Monaten, 2 Wochen von bscu.

    @hage

    hast du das schon dem Plugin-Entwickler gemeldet? – Wäre sicher hilfreich.

    Ich habe bisher noch nicht herausfinden können, wer der Schuldige ist, WPGlobus oder der TinyMCE-Editor. Solange ich das nicht herausgefunden habe, weiß ich nicht, welchen Entwicklern ich das melden soll.

    Hallo @bscu
    kein Problem – aber grundsätzlich würde ich denken, dass es nicht verkehrt ist, sich an den Entwickler von WP Globus zu wenden.
    Viele Grüße
    Hans-Gerd

    Es liegt definitiv an WPGlobus.

    Ich habe jetzt mal einen Thread unter https://wordpress.org/support/plugin/wpglobus/ aufgemacht, allerdings müssen die Moderatoren diesen erst einmal freigeben, hatte ich ja hier auch. Wird wohl an der Fehlermeldung mit den ganzen Links liegen.

    Bin mal gespannt, wie schnell es eine Lösung gibt, auf Dauer ist das nervig 😉

    Eine Lösung gibt es schon mal: man nehme google Chrome, damit geht es im Gegensatz zum Firefox. Mal sehen, ob es auch noch eine Lösung für den Firefox gibt.

Ansicht von 12 Antworten - 1 bis 12 (von insgesamt 12)
  • Das Thema „Visuell-Editor häufig leer“ ist für neue Antworten geschlossen.