Support » Allgemeine Fragen » Visuelle Editor

  • Der visuelle Editor funktioniert seit dem Update überhaupt nicht mehr, weder bei Seiten, noch bei Beitägen und auch nicht in Etitor-Widgets! Dies ist so bei Neuerstellungen sowie bestehenden Seiten, Beiträgen und Widgets! Tritt bei Firefox und Internet Explorer auf.
    Gib es nächstens ein WordPress-Update, welcher diesen Fehler wieder korrigiert?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 39)
  • Bin zurück zu WordPress 4.2.2, aber das Problem bleibt bestehen!

    Edi

    (@psychosopher)

    Hast Du bereits folgendes versucht?

    1) Alle Plugins deaktivieren, wenn es dann funktioniert, nach und nach die Plugins wieder aktivieren, um zu sehen, welches Plugin Probleme verursacht.

    2) Zu einem Standardtheme wechseln und schauen, ob es dann funktioniert.

    3) Den Debug-Modus aktivieren und schauen, ob eine Fehlermeldung ausgegeben wird. Dazu kannst Du in der Datei wp-config.php „define(‚WP_DEBUG‘, true);“ statt „define(‚WP_DEBUG‘, false);“) verwenden.

    Besten Dank mal für die Tipps, hat aber alles nichts gebracht. Bei den „Fehlermeldungen“ bin ich allerdings nicht ganz sicher; habe zwar keine gefunden, wusste aber auch nicht genau, wo schauen.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Gib es nächstens ein WordPress-Update, welcher diesen Fehler wieder korrigiert?

    Ich glaube nicht, dass es sich um einen WP-Bug handelt.

    Aus dem Changelog von 4.2.3:

    FIX – If the shortcode content contains HTML code, the TinyMCE View no longer works. #32078

    Wilde Shortcodes innerhalb von HTML-Code benutzt?

    Gruß, Torsten

    Ich arbeite mit dem visuellen Editor, weil ich kein HTML-Kenner bin.
    Wenn ich zurück zu WP-Version 4.2.2 gegangen bin, warum hat es dann nicht doch wieder funktioniert?
    Könnten evtl. die Shortcuts von in Seiten oder Beiträgen eingefügten Galerien oder Formulare solche „wilden Shortcuts“ sein? Und wie kann ich diese Sachen (Galerien, Formulare, …) einfügen, ohne solche shortcuts zu verwenden?
    Herzlichen Dank mal für die Infos und liebe Grüsse
    Pesche

    Ich gebe auf; kann meine Zeit sinnvoller nutzen, beispielsweise mit der Suche nach einem Anbieter oder einer Plattform, die sorgfältiger upgraden und es vermeiden, dass solche elementare Funktionen, wie es der Editor ist, plötzlich nicht mehr funktionieren. Auch wenn ich mit WordPress weitermachen würde, bleibt diese Unsicherheit, dass bei allfälligen Updates elementare Funktionen „verschwinden“.
    Wie ich auf englischen Foren gesehen habe, bin ich nicht der Einzige, der sich mit solchen Unzulänglichkeiten herumschlägt, und dazu habe ich keine Lust und will mir auch die Zeit nicht mehr nehmen; kann mir Sinnvolleres vorstellen.
    Pesche

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Die Upgrades werden sorgfältig geprüft, aber 1. sind Sicherheitsaspekte manchmal wichtiger als kaputte Shortcodes und 2. können nicht alle Varianten/Umgebungen/Pluginkombinationen getestet werden.

    Es sieht aber auch gar nicht nach einem WP-Bug aus. Eher nach einem Problem mit deiner Umgebung. Anstatt also WordPress die Schuld zu geben, wäre eine lösungsorientierte Herangehensweise sinnvoller. Denn keine Software ist 100% fehlerfrei und Problem passieren auch bei anderen Systemen.

    Wenn du nicht weiter kommt, hast Du hier ein Forum mit ausgewiesenen Experten (Bego, Frank, Marcus, Edi, …) die hier regelmäßig ihr Wissen kostenlos zur Verfügung stellen und helfen.

    Versorge uns mit Infos über deine Umgebung (installierte Plugins, PHP-Version, Memory Limit, verwendetes Theme, etc.) und wir können helfen oder dich an die richtigen Leute weiter verweisen. Aber aufgeben und WordPress als Problemfall definieren ist weder richtig noch bringt es dich zum Ziel.

    Und das Probleme nach einem Update niemanden Spaß bringen ist klar. Zusammen können wir aber daraus lernen und weiter kommen. Egal wer am Ende die Schuld daran hatte.

    In diesem Sinne: Wir sind da und helfen gerne weiter!
    (Und wie man sieht auch am Wochenende.)

    Gruß, Torsten

    Edi

    (@psychosopher)

    Bis anhin hast Du leider nur sehr rumdimentäre Angaben zu Deiner Installation gemacht. Ohne Angaben zum verwendeten Theme und den verwendeten Plugins und wenn möglich mit der Adresse der Website, ist es fast unmöglich, Support zu leisten.

    Und nur nebenbei: Ein Editor ist alles andere ale eine „elementare“ Funkttion, sondern eine äusserst komplexe Angelegenheit, da eine Content Management System völlig anders funktioniert als ein Textverarbeitungs- oder ein Layoutprogramm. Diese Erfahrung wirst Du auch mit anderen Systemen machen.

    WordPress selbst und viele Themes und Plugins sind zwar kostenlos, das heisst aber nicht, dass es einfach und billig ist. Wie bei jedem Open Source System muss einiges an Zeit für Erfahrungen mit dem System und in seine Wartung investiert werden.

    Wenn es Dir das nicht wert ist, bieten sich Baukästen wie Jimdo oder Wix an. Oder Du lässt Dir Deine Website von einer Fachperson einrichten.

    Aber eben: Wir leisten gerne Hilfe, nur müssten wir dazu etwas mehr Informationen von Dir haben.

    An meinem Compi liegt es mal sicher nicht, da ichs an komplett verschiedenen Arbeitsplätzen ausprobiert habe. Und ich habe dasselbe Problem bei 2 verschiedenen WordPress-Websites, welche jeweils andere Themes und Plugins verwenden.
    Aber lassts gut sein, Eure Argumente mögen stimmen, aber ich schaue mich trotzdem anderswo weiter. Und ein Editor ist wahrscheinlich komplex, aber für den Anwender eben doch elementar.
    Danke und Grüsse
    Pesche

    Edi

    (@psychosopher)

    Niemand hat behauptet, dass es an Deinem Computer liegen würde. Der spielt für WordPress kaum eine Rolle.

    Es steht Dir natürlich frei, Dich nach einem anderen System umzuschauen. Einfacher als WordPress sind aber auch die anderen Content Management Systeme nicht, weder Joomla, Drupal noch Typo3 und wie sie alle heissen. Denn für alle ist ein gewissermassen elementares Verständnis von Web-Technologien Voraussetzung. Oder eben, man begnügt sich mit einem Baukasten oder lässt sich die Website einrichten.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Könnten evtl. die Shortcuts von in Seiten oder Beiträgen eingefügten Galerien oder Formulare solche „wilden Shortcuts“ sein?

    Um diese Frage von dir noch zu beantworten: Nein, eine normale Galerie und die Formular-Shortcodes, die ich kenne (z.B von Contact Form 7) sind okay. Mit „wilden“ Shortcode sind Shortcodes innerhalb von HTML-Attributen und ähnliches gemeint.

    Ist halt nicht so einfach zu debuggen.
    – alle Plugins sind alle deaktiviert worden
    – Standardtheme ist ausgewählt
    – verschiedene Browser getestet
    – verschiedene Rechner getestet
    – Debug-Mode zeigt keine Fehler
    – Problem betrifft nicht nur Posts mit HTML in Shortcodes
    – Downgrade auf 4.2.2 behebt den Fehler auch nicht, schließt aber wohl ein Upload-Problem aus

    Da bleibt nicht mehr so viel übrig, was das Problem sein könnte.

    Falls du doch noch das Problem suchen möchtest:
    Zeigt die Browser-Konsole Fehler an?
    Sind ggf. Virenscanner/Firewall/Extensions/o.ä. überall doch aktiv gewesen, die vielleicht Skripte blockieren?

    Hier kannst testen, ob z.B. Javascript aktiv ist:
    http://supportdetails.com/

    Gruß, Torsten

    Danke für die weiteren Hinweise.
    Vielleicht werde ich bei der einen Website noch versuchen, die WordPress-Installation nochmals komplett vom Hostserver zu löschen, um es mit einer Neuinstalltion zu versuchen; allerdings nicht mehr im August; es warten andere Arbeiten.
    Bei der zweiten Website werde ich dies nicht tun, da diese eigentlich „fertig“ ist und auch funktioniert, allerdings kann ich sie nicht weiter bearbeiten. Für diese werde ich wahrscheinlich eine Alternative suchen.
    Also nochmals danke und freundliche Grüsse

    Hallo Alle,

    ich muß meinen Vorgängern Recht geben

    Da Update hinsichtlich des WYSIWYG Editors ist sehr schlecht!!
    Stunden verloren, im Web keine Hilfe Neuinstallation, Modifizierung des TinyMce Add Ons andere Vorschläge probiert es geht einfacdh nicht mehr.
    Ich sehe auch keine Menüoptionen rechts zur Auswahl.
    Einfach MISERABEL!!

    Ich überlege WordPress zu deinstallieren da keine Lösung in Sicht!!
    Schade

    Trotzdem viele grüße an Alle

    Felix29
    P.S. selbst in diesem Fenster geht WysiWYG nicht!!
    wede Chrome noch Mozilla….

    Edi

    (@psychosopher)

    @felix29 Du kannst selbstverständlich den Updates die Schuld zuschieben. Oder Du kannst das Forum oder eine Fachperson um Hilfe bitten.

    Bei keiner einzigen der zahlreichen Installationen, die ich betreue, habe ich dieses Problem. Offenbar läuft bei mir etwas völlig falsch… 😉

    Und warum sollte hier im Forum WYSIWYG funktionieren? Das Textfeld ist kein WYSIWYG-Editor. Könnte es sein, dass Du auch in Bezug auf den WordPress-Editor etwas missverstehst?

    Hallo Edi,
    Danke für Deine schnelle Antwort

    Ich habe Probleme auf allen Seiten, die ich bearbeiten möchte.
    Ich sehe bei der Bearbeitung nur einen HTML Code und kann nichts mehr mit WYSIWYG –wie früher– editieren.
    Ich habe bisher keine Lösung gefunden.
    WP neu upgedatet, alle Adde ons deaktiviert , neu aktiviert, keine Anderung.
    Bei Bearbeitung derWebseiten kann ich NICH wie früher mit WYSIWYG arbeiten.
    Sorry.
    Vielleicht hast Du eine bessere Läsung für mich .
    viele Grüße

    felix29

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 39)
  • Das Thema „Visuelle Editor“ ist für neue Antworten geschlossen.