Support » Allgemeine Fragen » Visuelle Editor

  • Der visuelle Editor funktioniert seit dem Update überhaupt nicht mehr, weder bei Seiten, noch bei Beitägen und auch nicht in Etitor-Widgets! Dies ist so bei Neuerstellungen sowie bestehenden Seiten, Beiträgen und Widgets! Tritt bei Firefox und Internet Explorer auf.
    Gib es nächstens ein WordPress-Update, welcher diesen Fehler wieder korrigiert?

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 39)
  • Edi

    (@psychosopher)

    Hast Du folgendes schon versucht:

    1) Alle Plugins deaktivieren, wenn es dann funktioniert, nach und nach die Plugins wieder aktivieren, um zu sehen, welches Plugin Probleme verursacht.

    2) Zu einem Standardtheme wechseln und schauen, ob es dann funktioniert.

    3) Den Debug-Modus aktivieren und schauen, ob eine Fehlermeldung ausgegeben wird. Dazu kannst Du in der Datei wp-config.php „define(‚WP_DEBUG‘, true);“ statt „define(‚WP_DEBUG‘, false);“) verwenden.

    P. S. Meinst Du mit Addons Plugins? Mit Addons werden bei WordPress üblicherweise Erweiterungen für Plugins bezeichnet.

    Danke für die Rückmeldung

    hier meine Versuche:
    >>>1) Alle Plugins deaktivieren, wenn es dann funktioniert, nach und nach die Plugins wieder aktivieren, um zu sehen, welches Plugin Probleme verursacht.
    <<< alles gemacht ohne Erfolg
    >>>2) Zu einem Standardtheme wechseln und schauen, ob es dann funktioniert.
    leider auch ohne Erfolg
    >>> 3) Den Debug-Modus aktivieren und schauen, ob eine Fehlermeldung ausgegeben wird. Dazu kannst Du in der Datei wp-config.php „define(‚WP_DEBUG‘, true);“ statt „define(‚WP_DEBUG‘, false);“) verwenden.

    mache ich gerade und trotz auf Standard Theme zu wechseln ändert sich nichts, krieg aber folgende Meldung im debug modus:
    Notice: Undefined offset: 409 in
    … /html/wp/wp-content/themes/techozoic-fluid/functions/tech-widget.php on line 65
    mit
    line 65:

    } elseif ( $page_option[$page->ID] == '1' ) {
                register_sidebar( array(
                    'name' => sprintf( __( '%s Left Sidebar', 'techozoic' ), $page->post_title ),
                    'description' => sprintf( __( 'Sidebar displayed only on %1$s.  Page ID(%2$s)', 'techozoic' ), $page->post_title, $page->ID ),
                    'id' => "page_sidebar_l_$page->ID",
                    'before_widget' => '<div class="hwidget %2$s">',
                    'after_widget' => '</div>',
                    'before_title' => '<h2 class="widgettitle">',
                    'after_title' => '</h2>'
                ) );
                register_sidebar( array(
                    'name' => sprintf( __( '%s Right Sidebar', 'techozoic' ), $page->post_title ),
                    'description' => sprintf( __( 'Sidebar displayed only on %1$s.  Page ID(%2$s)', 'techozoic' ), $page->post_title, $page->ID ),
                    'id' => "page_sidebar_r_$page->ID",
                    'before_widget' => '<div class="hwidget %2$s">',
                    'after_widget' => '</div>',
                    'before_title' => '<h2 class="widgettitle">',
                    'after_title' => '</h2>'
                ) );

    vorerst vielen Dank

    felix29

    PROBLEM GELÖST.
    ==============
    konnte bei den User Einstellungen
    Visueller Editor den Default Haken (Fehler bei WordPress)
    erst nach mehrmaligem Ändern und Speichern entfernen!!!

    X Beim Schreiben den WYSIWYG-Editor nicht benutzen
    ^^

    dies sollte künftig als default

      NICHT

    angekreuzt sein!!

    jetzt erst kann ich WYSIWYG benutzen.

    viele Grüße

    felix29

    Hi Felix,
    wo genau hast du diese Einstellung? Bei mir gibt es unter Einstellungen nur beim TinyMCE Editor einen Haken um ihn zu verwenden. Die von dir gezeigte Einstellung Visueller Editor“ X Beim Schreiben den WYSIWYG-Editor nicht benutzen finde ich nirgends.

    WP V.3.2, TiynMCE Advanced 4.2.3.1

    Danke,
    Steinspecht

    Hallo Steinspecht

    es hat bei mir auch lange gedauert bis ich zur Lösung fand, da WordPress per default an dieser Stelle eine falsche Einstellung hat.

    1. Öffne Dein Dashboard
    2. Öffne Benutzer
    3. Öffne Dein Profil
    4. Entferne das Häckchen unter: Beim Schreiben den WYSIWYG-Editor nicht benutzen

    ( 3.Zeile auf der Seite:
    Profil,Persönliche Optionen,Visueller Editor)

    Ich hoffe es klappt dann bei Dir.

    viele Grüße
    alias Felix29

    Hallo Feelix29,
    danke für den Tipp. Bei mir war das Häkchen schon weg 🙁

    Aber ich habe eine andere Lösung gefunden: den CKEditor for WordPress – der geht und sieht praktisch genauso aus.

    Grüße,
    Steinspecht

    Moderator Torsten Landsiedel

    (@zodiac1978)

    da WordPress per default an dieser Stelle eine falsche Einstellung hat.

    So so, eine falsche Einstellung also. Interessant.

    Gruß, Torsten

    Hallo Steinspecht,
    Danke für Dein Feedback und für den Tipp.
    Bei mir war nach dem Update die Einstellung in WordPress als default angekreuzt, auch wenn manch Anderer es bezweifelt, anstatt Dir geholfen zu haben….

    Trotzdem viele Grüße
    felix29

    Moderator Torsten Landsiedel

    (@zodiac1978)

    auch wenn manch Anderer es bezweifelt, anstatt Dir geholfen zu haben….

    Ich bezweifele nicht, dass das so war, aber ich bezweifele dass das ein generelles WP-Problem ist. Eine Einstellung mag nicht deinen Wünschen entsprechen, aber sie ist nicht per se falsch. Und da es bisher nur diesen einen Fall dieses Problems hier im Forum gibt, tippe ich eher auf ein lokales Phänomen und nicht auf einen globalen WP-Bug. Für ein lokales Problem spricht auch, dass etwas banales, wie eine Checkbox nicht korrekt gespeichert wird. Dann hakt es anderswo …

    WP V.3.2, TiynMCE Advanced 4.2.3.1

    Da das Plugin auf die in WP genutzte TinyMCE-Version passen muss, konnte das in dieser Kombination (WP 3.2 aber aktuelle Version vom Plugin) auch nicht funktionieren.

    Gruß, Torsten

    @ Torsten:

    Da das Plugin auf die in WP genutzte TinyMCE-Version passen muss, konnte das in dieser Kombination (WP 3.2 aber aktuelle Version vom Plugin) auch nicht funktionieren.

    Das war mein Fehler, ich habe mich vertippt. Meine WP-Version ist:

    WordPress-Aktualisierungen

    Zuletzt geprüft am 24. August 2015 um 12:41. Erneut prüfen
    Du benutzt die aktuelle Version von WordPress. Künftige Sicherheitsupdates werden automatisch durchgeführt.

    Wenn du Version 4.3–de_DE neu installieren musst, kannst du das hier erledigen oder das Installationspaket herunterladen und manuell installieren:

    4.3–de_DE herunterladen
    Plugins

    Alle Plugins sind auf dem neuesten Stand.
    Themes

    Alle Themes sind auf dem neuesten Stand.
    Übersetzungen

    Deine Übersetzungen sind alle auf dem neuesten Stand.

    Ob nun ein Häkchen defaultmäßig gesetzt ist oder nicht, der Hinweis von Felix29 hätte durchaus nützlich sein können. Bei mir war das Häkchen _nicht_ gesetzt. Tiny MCE Advanced geht trotzdem nicht. Also habe ich es deaktiviert und den CKEditor installiert, und voilá, er geht.

    Mich interessiert dazu eine Fehlereingrenzung / Behebung.

    Jetzt tritt folgende neue Situation ein:
    Obwohl CKEditor for WordPress funktioniert und bei allen Seiten alles anzeigt – sowohl im Text-, wie auch im visuellen Modus -, anders als TinyMCE, habe ich eine Seite, die nur Fotos enthält,in die ich aber kein weiteres Foto einfügen kann. CKeditor zeigt nichts – weder im Text-, noch im visuellen Modus. Ein leeres Blatt. Wenn ich ein Bild aus der Medienbibliothek einfüge, erscheint – nichts. Wenn ich eine völlig neue Seite anlege und Fotos einfüge, erscheint – nichts.
    Ich verstehe das nicht und es macht mich rasend.

    Also, wenn hier von kundiger Seite ein brauchbarer Hinweis kommt, wäre ich sehr sehr dankbar.
    Steinspecht

    Hallo ihr beiden.

    ich wollte und will hier keine Unruhe reinbringen, wollte nur helfen.

    Steinspecht,
    ich werde die AddOn auch laden und schauen ob ich helfen kann. Dauert leider wahrscheinlich 2 Tage, da ich weg bin…

    viele Grüße euch beiden

    felix29

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Eigentlich gilt hier das Prinzip: eine Frage = ein Thread, aber da die ursprüngliche Frage nie geklärt wurde machen wir hier mal so weiter:

    Mich interessiert dazu eine Fehlereingrenzung / Behebung.

    Eine generelle Vorgehensweise wurde oben von Edi schon geschrieben:

    1) Alle Plugins deaktivieren, wenn es dann funktioniert, nach und nach die Plugins wieder aktivieren, um zu sehen, welches Plugin Probleme verursacht.

    2) Zu einem Standardtheme wechseln und schauen, ob es dann funktioniert.

    3) Den Debug-Modus aktivieren und schauen, ob eine Fehlermeldung ausgegeben wird. Dazu kannst Du in der Datei wp-config.php „define(‚WP_DEBUG‘, true);“ statt „define(‚WP_DEBUG‘, false);“) verwenden.

    Zusätzlich gilt insbesondere für den TinyMCE:

    – (Browser-)Cache löschen
    – Seite neu laden (ggf. per Force Refresh)

    Nicht das noch veraltete Dateien (von älteren TinyMCE-Versionen) aus dem Cache geladen werden.

    In jedem Fall mal verschiedene Browser und soweit möglich anderen Rechner testen.

    Werden Shortcodes in den entsprechenden Artikeln/Seiten benutzt?

    WordPress-Dateien (ohne /wp-content) mal neu hochgeladen? Um ein fehlerhaftes Update/Upload auszuschließen?

    Zeigt die Browser-Konsole (Javascript-)Fehler an?

    Sind ggf. Virenscanner/Firewall/Extensions/o.ä. überall doch aktiv gewesen, die vielleicht Skripte blockieren?

    Wenn das alles nichts hilft:
    Versorge uns mit Infos über deine Umgebung (installierte Plugins, PHP-Version, Memory Limit, verwendetes Theme, etc.) und wir können helfen oder dich an die richtigen Leute weiter verweisen.

    Ein Link zur Website ist auch immer hilfreich.

    Und ein Großteil dieser Tipps/Anweisungen steht schon in diesem Thread. Wir helfen echt gerne, wenn man uns mit Infos versorgt, aber fett gedruckte Sätze wie „Da Update hinsichtlich des WYSIWYG Editors ist sehr schlecht!!“ motiviert hier niemanden. Wir haben das Update nicht gemacht, sondern helfen freiwillig und unentgeltlich in einem öffentlichen Forum. In unserer Freizeit. Da möchte man nicht so gerne für die (womöglich lokalen) Probleme anderer angemacht werden.

    Wir sind aber auch nicht nachtragend. Am Ende möchten wir alle, dass *jedes* WordPress sauber läuft und wir helfen gerne dabei. Und wenn es ein WP-Problem ist, dann kümmern wir uns darum, dass der Bugreport bei den richtigen Leuten ankommt oder helfen euch dabei.

    Lasst uns also an einem Strang ziehen. Okay?

    Gruß, Torsten

    ok.
    Ich finde auch die Hilfe sollte im Vordergrund stehen!

    viele Grüße

    felix29

    @ Torsten
    Danke für die konstruktive Haltung, weiß ich sehr zu schätzen. Die Benachrichtigung über dein Post ist im Spamordner gelandet, deswegen meine Antwort erst jetzt.

    Nun zur Sache.

    1) Alle Plugins deaktivieren, wenn es dann funktioniert, nach und nach die Plugins wieder aktivieren, um zu sehen, welches Plugin Probleme verursacht.

    mit komplett deaktivierten Plugins außer dem Editor geht’s auch nicht

    2) Zu einem Standardtheme wechseln und schauen, ob es dann funktioniert.

    Es funktioniert!! habe Twenty Eleven aktiviert. Aber ich möchte mein derzeitiges Theme beibehalten, wie kriege ich das hin??

    3) Den Debug-Modus aktivieren und schauen, ob eine Fehlermeldung ausgegeben wird. Dazu kannst Du in der Datei wp-config.php „define(‚WP_DEBUG‘, true);“ statt „define(‚WP_DEBUG‘, false);“) verwenden.

    Habe keinen Zugriff auf den debug-Mode, auch nicht auf wp-config.php, verwende WP beim Hoster, nicht lokal, sehe nur Dashboard und die ganze Liste linke Spalte. Wie komme ich dahin??

    – (Browser-)Cache löschen

    Firefox ist so eingestellt, dass bei Exit Cache immer gelöscht wird. Mit anderen Browsern (IE, Edge) geht’s auch nicht.

    anderer Rechner:

    exakt gleicher Verhalten: TinyMCE erscheint gar nicht, CKEditor zeigt auf der Seite „Austellungen“ nichts an (URL meiner Webseite s. unten).

    Shortcodes

    Verwende ich nicht, soweit mir das bewußt ist.

    Dateien hochladen

    Mache ich nur mit Fotos, sonst alles cloudmäßig. Wie gesagt, WP ist nicht lokal bei mir installiert. Alle Fotos korrekt im Media-Bereich drin.
    Zu den weiteren Fragen
    Virenscanner – ja schon immer, auch als TinyMCE noch funktionieerte
    Javascript: aktiviert
    php-Version: weiß ich nicht, wo sieht man das?
    Memory-Limit: weiß ich nicht, wo sieht man das?
    Verwendetes Theme: Nordic by Umbrella, konfiguriert vom ursprünglichen Ersteller meiner Homepage.
    Der Provider heißt Goneo.
    Meine Webseite heißt http://sculptartes.com

    Schlußbemerkung: ich bin in Sachen html-Programmierung vollkommen unbeleckt, Architektur und Konfiguration von Webseiten vershe ich nicht und möchte auch nicht unbeddingt vertiefen. Ich möchte nur gelegentlich neue Inhalte einstellen und manchmal neue Seiten erstellen, das ging alles ganz gut (alles auf sculptartes.com habe ich selbst gemacht, war recht easy), bis diese Sache mit dem Editor nicht mehr funzte. CKEditor geht, aber der Knackpunkt ist jetzt diese verdammte Seite mit „Ausstellungen“, die ich weder ergänzen kann, weil im Editor nichts angezeigt wird, noch kann ich sie neu erstellen, weil auch dann nichts erscheint. MIST!!

    Hallo Steispecht
    ich finde Deine Bilder und Arbeitet toll
    Gratuliere Dir!!

    Viele Grüße
    felix29

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 39)
  • Das Thema „Visuelle Editor“ ist für neue Antworten geschlossen.