Support » Allgemeine Fragen » Visueller Editor funktioniert nicht

  • Mein Problem: Der Editor funktioniert nur noch teilweise. Im Text-Editor kann man noch Posts schreiben und veröffentlichen, im visuellen Editor funktioniert gar nichts mehr. Es wird weder Text angezeigt, noch kann ich Text eingeben noch erscheinen die Toolleiste zur Strukturieren (also all die Buttons für z.B. fett, kursiv, link usw. usf.)

    Noch schlimmer wurde es, als ich auf die aktuelle Version von WP updatete, da ging auch der Text-Editor nicht mehr. Als Lösung haben wir das Back-Up wiederhergestellt und nutzen nun die Version WP 4.6.

    Was ich (bzw. mein Kollege) bereits gemacht haben:

    • Sicherheitslücken und Synchronisationsprobleme zwischen Cloudflare & Cyon (Hosting) geschlossen
    • Alle Plugins aktualisiert
    • Alle Plugins deaktiviert zum Schauen, ob dies einen Effekt hat
    • Jedes Plugin einzeln deaktiviert um zu Schauen, ob sich was ändert
    • Cache auf Cloudflare geleert

    Das Problem scheint was mit TinyMCE zu sein. Nur weiss ich weder was genau noch was ich probieren kann, um es zu lösen.

    Ich freue mich über Ideen, Vorschläge und am allermeisten natürlich über Lösungen 🙂

    Angaben zu meiner Website:
    URL: https://a-cocktail-a-day.com/
    Webhoster: cyon.ch
    PHP-Version: PHP 5.6.29
    Arbeitsspeicher (RAM): shares hosting (?)
    Festplattenspeicher: 25 GB
    WordPress-Version: WordPress 4.6
    Theme: Redwood von SoloPine (angepasst)
    Ist das ein bezahltes Theme? Ja
    Plugins:

    • 404page – your smart custom 404 error page
    • Akismet
    • Basic User Avatars
    • Cloudflare
    • Easy Peasy Google Analytic
    • jQuery Archive List Widget
    • jQuery Pin It Button for Images
    • Post Hit Counter
    • TF Random Numbers
    • VigLink
    • WP Google Maps
    • WP Google Maps – Pro Add-on (bezahlt)
    • WP Instagram Widget
    • WP User Avatar

    Alle nichtaktiven Plugins wurden deinstalliert.

    Wird ein Cache-Plugin verwendet? nein
    Angezeigte Fehlermeldungen: keine

    Fehlermeldungen in den Entwickler-Werkzeugen wenn ich im visuellen Editor bin:

    Bei Chrome von mir:

    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery…:9 
    JQMIGRATE: Migrate is installed, version 1.4.1
    listener.js:6 PV:Chrome: startup
    plugin.min.js Failed to load resource: the server responded with a status of 522 ()
    tinymce.min.js:4 Failed to load: https://a-cocktail-a-day.com/wp-includes/js/tinymce/plugins/paste/plugin.min.js

    Nach einem Hardrefresh erscheint:

    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery…:9 JQMIGRATE: Migrate is installed, version 1.4.1
    listener.js:6 PV:Chrome: startup
    tinymce.min.js?ver=4401-20160726:4 GET https://a-cocktail-a-day.com/wp-includes/js/tinymce/plugins/paste/plugin.min.js?wp-mce-4401-20160726 
    e @ tinymce.min.js?ver=4401-20160726:4
    (anonymous) @ tinymce.min.js?ver=4401-20160726:4
    n @ tinymce.min.js?ver=4401-20160726:3
    p @ tinymce.min.js?ver=4401-20160726:4
    loadScripts @ tinymce.min.js?ver=4401-20160726:4
    loadQueue @ tinymce.min.js?ver=4401-20160726:4
    t @ tinymce.min.js?ver=4401-20160726:11
    render @ tinymce.min.js?ver=4401-20160726:11
    a @ tinymce.min.js?ver=4401-20160726:12
    (anonymous) @ tinymce.min.js?ver=4401-20160726:12
    n @ tinymce.min.js?ver=4401-20160726:3
    d @ tinymce.min.js?ver=4401-20160726:12
    e @ tinymce.min.js?ver=4401-20160726:2
    m @ tinymce.min.js?ver=4401-20160726:2
    a @ tinymce.min.js?ver=4401-20160726:2
    tinymce.min.js?ver=4401-20160726:4 Failed to load: https://a-cocktail-a-day.com/wp-includes/js/tinymce/plugins/paste/plugin.min.js

    Bei Chrome von meinem Kollegen:
    keine

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Moderator Bego Mario Garde

    (@pixolin)

    Vorab: Die von dir verwendete Version von WordPress ist nicht sicher. Es ist keine gute Idee, ein Downgrade auf eine unsichere WordPress-Version durchzuführen. Bitte aktualisiere WordPress sobald wie möglich.

    Hast du mal versucht, die Plugins vorübergehend zu deaktivieren?
    Funktioniert der Editor dann?

    Danke für deine Antwort @pixolin 🙂

    Vorab: Die von dir verwendete Version von WordPress ist nicht sicher. Es ist keine gute Idee, ein Downgrade auf eine unsichere WordPress-Version durchzuführen. Bitte aktualisiere WordPress sobald wie möglich.

    Das habe ich gemacht, dann ging der Editor aber gar nicht mehr, also auch der Text-Editor. Solange dieses Problem nicht gelöst ist, ist für mich ein Upgrade keine Option, da ich sonst ja überhaupt nicht mehr bloggen kann 🙁

    Hast du mal versucht, die Plugins vorübergehend zu deaktivieren?
    Funktioniert der Editor dann?

    Ja, ich habe die Plugins einzeln deaktiviert & getestet und auch alle zusammen deaktiviert & getestet: es funktionierte auf beide weisen nie und es trat keine Änderung auf.

    Moderator Bego Mario Garde

    (@pixolin)

    Solange dieses Problem nicht gelöst ist, ist für mich ein Upgrade keine Option, da ich sonst ja überhaupt nicht mehr bloggen kann

    Was soll ich dir jetzt dazu sagen? „Dann warte eben, bis deine Website gehackt wird“? Abgesehen davon kommen wir so nicht weiter.

    Um den Fehler nach einem Update einzugrenzen, versuchen wir immer erst einmal mögliche Fehlerquellen auszuschließen. Wenn du sicher bist, dass es nicht an den Plugins liegt, müsstest du mal kurz auf ein Standard-Theme (Twenty …) wechseln und schauen, ob der Editor dann funktioniert. Wenn du das auch ausschließen kannst, könnte es an der Server-Konfiguration liegen. Viele Benutzer mit einem HTTP Error 522 berichten von Problemen mit Cloudflare – nutzt du das?

    Was soll ich dir jetzt dazu sagen? „Dann warte eben, bis deine Website gehackt wird“? Abgesehen davon kommen wir so nicht weiter.

    Ok, habe es aktualisiert. Jetzt geht weder der Text-Editor noch der visuelle Editor.

    In der Console erscheint, wenn ich im Editor bin, folgende Fehlermeldung:

    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils,plupload&ver=4.7.2:9 JQMIGRATE: Migrate is installed, version 1.4.1
    tinymce.min.js Failed to load resource: the server responded with a status of 522 ()
    plugin.min.js?ver=4403-20160901:1 Uncaught ReferenceError: tinymce is not defined
        at plugin.min.js?ver=4403-20160901:1
    (anonymous) @ plugin.min.js?ver=4403-20160901:1
    post-new.php:2389 Uncaught ReferenceError: tinymce is not defined
        at post-new.php:2389
    (anonymous) @ post-new.php:2389
    wp-langs-en.js?ver=4403-20160901:235 Uncaught ReferenceError: tinyMCE is not defined
        at wp-langs-en.js?ver=4403-20160901:235
        at wp-langs-en.js?ver=4403-20160901:519
    (anonymous) @ wp-langs-en.js?ver=4403-20160901:235
    (anonymous) @ wp-langs-en.js?ver=4403-20160901:519
    post-new.php:2383 Uncaught ReferenceError: tinymce is not defined
        at Object.load_ext (post-new.php:2383)
        at post-new.php:2394
    load_ext @ post-new.php:2383
    (anonymous) @ post-new.php:2394
    listener.js:6 PV:Chrome: startup

    Um den Fehler nach einem Update einzugrenzen, versuchen wir immer erst einmal mögliche Fehlerquellen auszuschließen. Wenn du sicher bist, dass es nicht an den Plugins liegt, müsstest du mal kurz auf ein Standard-Theme (Twenty …) wechseln und schauen, ob der Editor dann funktioniert.

    Ich habe auf das akutelle TwentyFifteen gewechselt: hat nichts gebracht. (bin jetzt wieder zurück zum RedWood Theme)

    Wenn du das auch ausschließen kannst, könnte es an der Server-Konfiguration liegen. Viele Benutzer mit einem HTTP Error 522 berichten von Problemen mit Cloudflare – nutzt du das?

    Ja, ich nutze Cloudflare. Es erscheint keine Fehlermeldung HTTP Error 522, wenn du das meinst? Was meinst du genau mit der Server-Konfiguration bzw. inwiefern sollen wir diese anpassen?

    • Diese Antwort wurde geändert vor 3 Jahre, 1 Monat von kristinaanna.
    Moderator Bego Mario Garde

    (@pixolin)

    Es erscheint keine Fehlermeldung HTTP Error 522, wenn du das meinst?

    Schau dir die Fehlermeldung doch bitte nochmal an:
    Failed to load resource: the server responded with a status of 522 ()

    Ich nutze Cloudflare nicht, aber hier gibt es ein paar Hinweise, die nützlich sein könnten: https://support.cloudflare.com/hc/en-us/articles/200171906-Error-522-Connection-timed-out

    (unter anderem wird da auf mögliche Probleme mit einer Firewall hingewiesen – nutzt du ein entsprechendes Plugin?)

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Wenn es gar nicht anders geht, dann auf jeden Fall immer die letzte Version des jeweiligen Zweiges einsetzen:

    Releases

    Was mich bei der Problembeschreibung verwirrt ist, dass du den Fehler in der Konsole hast, aber dein Kollege nicht. Ist dort auch der Editor okay? Dann wäre es vielleicht ein lokales Problem. Die von Bego verlinkte Site zählt als Möglichkeit auf, dass eine Clouflare-IP gesperrt wird – hast du vielleicht eine Firewall im Einsatz, die das sperrt?

    Gruß, Torsten

    Also ich nutze die neuste Version von WP.

    Bei mir wird folgenden Fehlermeldung angezeigt:
    https://a-cocktail-a-day.com/wp-content/uploads/2017/02/Bildschirmfoto-2017-02-22-um-10.08.52.png

    Bei meinem Kollegen diese:
    https://a-cocktail-a-day.com/wp-content/uploads/2017/02/Screen-Shot-2017-02-21-at-09.53.37-am.png

    Sein Editor sieht auch anders aus: trotz dem Upgrade funktioniert bei ihm der Text-Editor. Er sieht aber keinen Switch zwischen visuell/text.

    Bei meinem Editor sehe ich den Switch visuell/text, kann aber nichts machen. Auch der Text-Editor funktioniert seit dem Upgrade auf die aktuelle WP-Version nicht mehr.

    Ich nutze kein spezielles Firewall-Plugin. Werde jetzt aber mal den Mac komplett updaten um zu schauen, ob dann evtl der Text-Editor wieder funktioniert (wie bei meinem Kollegen).

    Gibt es irgendeine Möglichkeit, mit einem anderen Editor zu posten? Oder was für Möglichkeiten habe ich noch?

    Als vorübergehende (?) Lösung habe ich diesen Editor installiert: https://wordpress.org/plugins/ckeditor-for-wordpress/

    Das scheint nun zu funktionieren. Spricht irgendwas dagegen, diesen zu verwenden?

    Und falls noch wer Ideen/Vorschläge hat, das Problem zu fixen, dann probiere ich gerne aus. 🙂

    Moderator Bego Mario Garde

    (@pixolin)

    Einige Plugins sind auf den eingebundenen Editor abgestimmt, einen anderen Editor zu nutzen ist unter Umständen nicht optimal.

    Füg mal in der wp-config.php vor /* That's all, stop editing! Happy blogging. */ folgendes hinzu:

    define('CONCATENATE_SCRIPTS', false);

    (Das Plugin mit dem ckeditor müsstest du zum Testen wieder deaktivieren.)

    Ich habe die Zeile hinzugefügt. Meine Fehlermeldung sieht nun so aus:

    https://a-cocktail-a-day.com/wp-content/uploads/2017/02/Bildschirmfoto-2017-02-22-um-17.16.48.png

    Mein Kollege hat immer noch keine Fehlermeldung. Bei uns beiden sieht der Editor gleich wie oben beschrieben aus, d.h. bei mir funktioniert nach wie vor nichts, bei ihm nur der Text-Editor.

    Ah und ich habe gerade gemerkt, dass der Customizer auch nicht mehr funktioniert. Das ist zwar weniger tragisch, hilft aber ja vielleicht, bei der Lösungsfindung 🙂

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Ich nutze kein spezielles Firewall-Plugin.

    Der Browser lädt die Ressource nicht. Die Firewall bzw. die Blockierung kann also auch viel früher passieren. Auf dem Rechner oder über ein Addon.

    Der Editor kann ja nicht funktionieren, wenn seine JS-Datei nicht geladen wird. Die danach kommenden Fehler sind dann nur Folgefehler, weil eben die JS-Datei nicht geladen wurde.

    Da dies aber ein lokales Problem bei dir mit Cloudflare darstellt können wir da nicht weiterhelfen. Vielleicht hilft sonst der Cloudflare-Support oder ein IT-Dienstleister deines Vertrauens sich mal lokal den Rechner anzuschauen, wenn du da alleine nicht weiterkommst.

    Gruß, Torsten

    @zodiac1978 Warum ist es ein lokales Problem? Mein Kollege hat das Problem ja auch, dass er Editor nicht richtig funktioniert und bei ihm erscheint keine Fehlermeldung in der Console.

    Moderator Torsten Landsiedel

    (@zodiac1978)

    Das Problem beim Kollegen scheint ja ein komplett anderes zus ein. Der Editor geht, nur der Switch fehlt. Vielleicht ist der visuelle Editor bei ihm einfach nur im Profil deaktiviert.

    Du hast ein konkretes Problem, da dein Rechner bei der tinymce.min.js einen Status 522 kriegt und deshalb die Datei nicht geladen wird. Und dieses Problem scheint lokal zu sein, da es bei dir auftritt, aber bei ihm nicht. Wäre es eine Netzwerk-Firewall oder ein WP-Problem dann müsste es auch bei dem Kollegen auftreten. Also wäre mein Tipp, dass es ein lokales Problem auf deinem Rechner mit Cloudflare ist. Und da können wir halt schlecht debuggen …

    Gruß, Torsten

Ansicht von 14 Antworten - 1 bis 14 (von insgesamt 14)
  • Das Thema „Visueller Editor funktioniert nicht“ ist für neue Antworten geschlossen.