Support » Allgemeine Fragen » Vollbildmodus, vorformatierter Text, Beitragsbild bei GP

  • Gelöst 8ung

    (@8ung)


    Hallo Miteinander,
    3 Probleme treiben mich um:

    1. Wie bekomme ich den vermaledeiten Haken aus dem „Vollbildmodus“ heraus, und zwar für IMMER?
    Seit irgendeinem Update stört er meinen Arbeitsfluss. Ich brauche beim Arbeiten die volle Übersicht. Nicht die ganze Breite zum Schreiben, sondern sowohl die linke Spalte, um schnell in Medien usw hineinzukommen, als auch die rechte Spalte für den aktuellen Beitrag. Ich nehme den Haken zwar immer sofort raus, aber sobald ich mich umdrehe, ist er wieder drin. Und mit ihm ist entweder die linke oder die rechte Spalte verschwunden – im schlimmsten Falle sogar beide.
    Meine Hoffnung, dass er nach einem Update als Option wiederkommt, habe ich schon aufgegeben.

    2. Der „vorformatierte Text“ kommt auf dieser Seite https://xaver-paul-thoma.de/xpt-195-das-streichtrio-erstes-repertoire-fur-violine-viola-cello genau so hin, wie ich ihn brauche, siehe graues Kästchen. Auf einer anderen Seite habe ich die Schrift „Courier“, die ich nicht ändern kann, weder den Schrifttyp noch die Größe, noch den Hintergrund. Ich habe sowohl direkt in den Text geschrieben als auch aus einer Worddatei kopiert – alles eins!
    Wie und wo kann ich das so formatieren, wie ich es brauche?
    Ich habe nicht Gutenberg installiert, weil es sich mit Rankmath zankt(e), sondern nutze das normale Blocksystem von WordPress.

    3. Die gleiche Seite wie oben. Das Notenbild habe ich als Beitragsbild gespeichert. Im PC (Frontend) steht das Bild am Anfang, in Mobil und Tablet ist es verschwunden. Wenn ich das Notenbild auch noch in den Beitrag hineinsetze, ist es doppelt gemoppelt und nimmt zu viel Platz weg. Wie kommt das Beitragsbild auch in Mobil und Tablet?
    Ich verwende GeneratePress Premium, aber ich glaube, es ist kein Premium-Problem.

    Hoffe sehnsüchtig auf euren Rat 🙂

    LG Dorle

    • Dieses Thema wurde geändert vor 1 Jahr, 4 Monaten von 8ung.
    • Dieses Thema wurde geändert vor 1 Jahr, 4 Monaten von 8ung.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Grubdsätzlich wäre es schön, wenn du für Fragen einzelne Threads stellst. Wir möchten so vielen Anwender:innen wie möglich helfen und da sind „Gemischtwarenläden“ nicht so ideal.

    Um die Vollansicht zu aktivieren, reicht eigentlich, das Häkchen über das Drei-Punkte-Menü zu entfernen:

    Screenshot Einstellungen
    (zum Vergrößern anklicken)

    Die Einstellung wird über ein Cookie im Browser gespeichert. Reicht dir das nicht, z.B. weil du öfters den Browser wechselst, kannst du auch mit einem Filter den Vollbildmodus deaktivieren. Dieser Beitrag enthält den notwendigen Code:

    Auf einer anderen Seite habe ich die Schrift „Courier“, die ich nicht ändern kann, weder den Schrifttyp noch die Größe, noch den Hintergrund.

    … und was ist „die andere Seite“?

    Wahrscheinlich hast du einmal einen Block „Code“ und einmal einen Block „Vorformatiert“ verwendet.

    Wie kommt das Beitragsbild auch in Mobil und Tablet?
    Ich verwende GeneratePress Premium, aber ich glaube, es ist kein Premium-Problem.

    Doch, ich glaube schon, dass das eine Einstellung ist, die dir nur in der bezahlten Version zur Verfügung steht. In der kostenlos erhältlichen Fassung ist für Blogbeiträge nur eine Einstellung vorhanden, ob du Textauszüge oder den kompletten Inhalt sehen möchtest.

    Thread-Ersteller 8ung

    (@8ung)

    Danke Bego Mario Garde (@pixolin)

    >>Um die Vollansicht zu aktivieren, reicht eigentlich, das Häkchen über das Drei-Punkte-Menü zu entfernen:<<
    Die Vollansicht ist ständig aktiviert. Ich möchte sie deaktivieren.

    >>kannst du auch mit einem Filter den Vollbildmodus deaktivieren. Dieser Beitrag enthält den notwendigen Code: <<
    Wo, bitte, ist der Code?
    ——————-
    >>Wahrscheinlich hast du einmal einen Block „Code“ und einmal einen Block „Vorformatiert“ verwendet.<<
    Ich verwende so gut wie nie „Code“. Da bin ich viel zu unsicher.
    Ich habe jetzt einmal verschiedene Blöcke untereinander gestellt in https://www.8ung.info/landesmuseum-stuttgart-ausstellungen/
    Ganz unten.
    Grauer Kasten = Text in Word geschrieben und in „Abschnitt“ hineinkopiert.
    Darunter = „Vorformatiert“
    Darunter = „Classic“
    Darunter „Code“
    Nirgendwo konnte ich etwas verändern, weder Schrift noch Größe noch Hintergrund.
    Im Editor sieht es folgendermaßen aus, siehe Screenshot
    Kann weder einen Link noch ein Bild hochladen!

    LG Dorle

    Hallo,
    packe bitte den folgenden Code in die functions.php deines Child-Themes. Alternativ kannst du auch das Plugin Code Snippets verwenden und den Code als neues Snippet hinzufügen und aktivieren:

    if (is_admin()) { 
        function jba_disable_editor_fullscreen_by_default() {
        $script = "jQuery( window ).load(function() { const isFullscreenMode = wp.data.select( 'core/edit-post' ).isFeatureActive( 'fullscreenMode' ); if ( isFullscreenMode ) { wp.data.dispatch( 'core/edit-post' ).toggleFeature( 'fullscreenMode' ); } });";
        wp_add_inline_script( 'wp-blocks', $script );
    }
    add_action( 'enqueue_block_editor_assets', 'jba_disable_editor_fullscreen_by_default' );
    }

    Quelle: https://www.wpbeginner.com/wp-tutorials/how-to-disable-fullscreen-editor-in-wordpress/
    Bezogen auf das 2. Problem wäre es wirklich besser, wenn du das in einem neuen Thema beschreibst. Bilder kannst du übrigens einfügen – Anleitung siehe hier
    Viele Grüße
    Hans-Gerd

    Die Vollansicht ist ständig aktiviert. Ich möchte sie deaktivieren.

    Sorry, ich meinte deaktivieren. Hätte sich eigentlich auch aus dem Screenshot ergeben sollen.

    Wo, bitte, ist der Code?

    Da hab ich tatsächlich vergessen, den Link einzufügen. Aber es ging um den Beitrag, den Hans-Gerd zitiert hat und den Code, den er in seiner Antwort gepostet hat.

    Kann weder einen Link noch ein Bild hochladen!

    Steht in unseren FAQ: Wie kann man hier Bilder in einen Forenbeitrag einfügen?

    Thread-Ersteller 8ung

    (@8ung)

    @hage Herzlichen Dank!
    Da ich weder weiß, wo sich mein Child Theme befindet, noch ob ich überhaupt eines habe, wählte ich das Plugin.
    Sofort sprang mir die linke Seitenleiste entgegen. Hoffentlich ist es morgen noch genau so 😉

    Den Punkt „Vorformatiert“ nehme ich raus und stelle eine neue Frage.

    LG Dorle

    • Diese Antwort wurde geändert vor 1 Jahr, 4 Monaten von 8ung.

    Hallo,
    denkst du bitte daran, das Thema dann als gelöst zu markieren, wenn das Thema für dich erledigt ist. Danke.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller 8ung

    (@8ung)

    erledigt 🙂

    hmm, das wird eigentlich oben als gelöst markiert. Habe ich jetzt für dich gemacht 😉

Ansicht von 8 Antworten - 1 bis 8 (von insgesamt 8)
  • Das Thema „Vollbildmodus, vorformatierter Text, Beitragsbild bei GP“ ist für neue Antworten geschlossen.