Support » Allgemeine Fragen » Vorschau von Blog auf Startseite einbinden funktioniert nicht richtig

  • Gelöst aspies

    (@aspies)


    Hallo zusammen,

    vielleicht könnt ihr mir weiterhelfen.

    Ich möchte gerne auf meiner Startseite eine Vorschau von 3 ausgewählten Blog Artikel einbetten. In der Bearbeiten Funktion wird Das Bild und ein Ausschnitt der Artikel angezeigt. Wenn ich dann die Seite final ansehe, stehen da nur die Überschriften und die Bilder so wie die Auszüge aus den Artikeln sind nicht mehr zu sehen. Wie kann ich das Problem beheben, bzw. wo mache ich den Fehler?

    Vorschau so wie ich es gerne hätte

    und so wie es aussieht

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Hallo,
    dazu brauchen wir leider noch zusätzliche Angaben: Hast du diese Beiträge über den Block-Editor („Neueste Beiträge“) eingefügt?
    Du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller aspies

    (@aspies)

    Hallo Hans Gerd,

    Dankeschön für deine Antwort. Den Bericht reiche ich nach, sobald ich Zuhause am Laptop bin. Oder ist es auch möglich das über das Smartphone, oder werden die Werte da verfälscht.

    Ich habe auf der Startseite 3 Spalten hinzugefügt in 25%/50%/25%. In diese habe ich dann mittels Einbetten die URL jeweils eingefügt. In der Mobilen Ansicht sind die Beiträge auch zu sehen wie auf dem ersten Bild nur nicht auf dem Desktop.

    Viele Grüße
    Andreas

    Thread-Ersteller aspies

    (@aspies)

    Hier der Bericht über die Mobile Ansicht eingefügt:

    
    ### wp-core ###
    
    version: 5.7
    site_language: de_DE
    user_language: de_DE
    timezone: +00:00
    permalink: /%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: open
    environment_type: production
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/vhosts/hosting107649.a2fa0.netcup.net/httpdocs
    wordpress_size: 511,59 MB (536437941 bytes)
    uploads_path: /var/www/vhosts/hosting107649.a2fa0.netcup.net/httpdocs/wp-content/uploads
    uploads_size: 52,98 MB (55548962 bytes)
    themes_path: /var/www/vhosts/hosting107649.a2fa0.netcup.net/httpdocs/wp-content/themes
    themes_size: 7,91 MB (8292843 bytes)
    plugins_path: /var/www/vhosts/hosting107649.a2fa0.netcup.net/httpdocs/wp-content/plugins
    plugins_size: 85,73 MB (89896912 bytes)
    database_size: 23,25 MB (24379392 bytes)
    total_size: 681,45 MB (714556050 bytes)
    
    ### wp-dropins (1) ###
    
    maintenance.php: true
    
    ### wp-active-theme ###
    
    name: Sydney (sydney)
    version: 1.76
    author: aThemes
    author_website: https://athemes.com
    parent_theme: none
    theme_features: core-block-patterns, siteorigin-panels, automatic-feed-links, title-tag, post-thumbnails, menus, html5, post-formats, custom-background, align-wide, custom-header, infinite-scroll, widgets
    theme_path: /var/www/vhosts/hosting107649.a2fa0.netcup.net/httpdocs/wp-content/themes/sydney
    auto_update: Aktiviert
    
    ### wp-themes-inactive (1) ###
    
    Airi: version: 1.0.15, author: aThemes, Automatische Aktualisierungen aktiviert
    
    ### wp-plugins-active (13) ###
    
    Amazon Associates Link Builder: version: 1.9.3, author: Amazon Associates Program, Automatische Aktualisierungen deaktiviert
    Antispam Bee: version: 2.9.4, author: pluginkollektiv, Automatische Aktualisierungen aktiviert
    BackUpWordPress: version: 3.11, author: XIBO Ltd, Automatische Aktualisierungen aktiviert
    Black Studio TinyMCE Widget: version: 2.6.9, author: Black Studio, Automatische Aktualisierungen aktiviert
    Contact Form 7: version: 5.4, author: Takayuki Miyoshi, Automatische Aktualisierungen deaktiviert
    Google Analytics: version: 2.5.0, author: ShareThis, Automatische Aktualisierungen deaktiviert
    Livemesh SiteOrigin Widgets: version: 2.7.0, author: Livemesh, Automatische Aktualisierungen deaktiviert
    MC4WP: Mailchimp for WordPress: version: 4.8.3, author: ibericode, Automatische Aktualisierungen aktiviert
    MetaSlider: version: 3.20.3, author: MetaSlider, Automatische Aktualisierungen aktiviert
    Page Builder by SiteOrigin: version: 2.11.8, author: SiteOrigin, Automatische Aktualisierungen aktiviert
    SiteOrigin Widgets Bundle: version: 1.17.11, author: SiteOrigin, Automatische Aktualisierungen aktiviert
    TC Custom JavaScript: version: 1.2.3, author: Tiny Code, Automatische Aktualisierungen aktiviert
    Yoast SEO: version: 16.0.2, author: Team Yoast, Automatische Aktualisierungen deaktiviert
    
    ### wp-plugins-inactive (1) ###
    
    Akismet Anti-Spam: version: 4.1.9, author: Automattic, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 8M
    upload_max_filesize: 8M
    max_effective_size: 8 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 393216
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 16
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.9.0-12-amd64 x86_64
    httpd_software: Apache
    php_version: 8.0.1 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 4000
    time_limit: 0
    memory_limit: 128M
    admin_memory_limit: 256M
    max_input_time: 60
    upload_max_filesize: 8M
    php_post_max_size: 8M
    curl_version: 7.52.1 OpenSSL/1.0.2u
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.33
    client_version: mysqlnd 8.0.1
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/vhosts/hosting107649.a2fa0.netcup.net/httpdocs/wp-content
    WP_PLUGIN_DIR: /var/www/vhosts/hosting107649.a2fa0.netcup.net/httpdocs/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,
    ich habe das gerade mal getestet:
    Beispiel
    Die Möglichkeiten für eine Einbettung speziell ausgewählter Beiträge scheinen doch sehr begrenzt zu sein.
    Auf der Grundlage dieses Beitrages habe ich für eine Webseite von uns eine Funktion erstellt, die man z. B. in der functions.php des Child Themes schreiben kann. Da kann man den Beitrag durchaus besser gestalten.
    Evtl. wäre aber noch der Ansatz über den Block „Neueste Beiträge“ zu überdenken: Wenn du den Beiträgen, die du zeigen möchtest eine bestimmte Kategorie zuweist (z. B. „Frontpage“) und die entsprechenden Beiträge dieser Kategorie zuweist, sollte das auch damit funktionieren.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller aspies

    (@aspies)

    Hallo Hans-Gerd,

    Danke für deine schnelle Antwort. Die Option „Neueste Beiträge“ habe ich auch schon probiert. Die Zeigt auch alles richtig an. Nur fehlt mir dort ein Textausschnitt der mit angezeigt wird.

    Im Wesentlichen geht is mir darum das ich Zeit die User auf meiner Seite verbringen erhöhen möchte. Meine Überlegung war, Beiträge auf meiner Startseite zu integrieren um zumindest mal ein Anlesen der Artikel zu ermöglichen und so Neugier zu wecken um Die Beiträge Vollständig zu lesen.

    Ich werde mal testen ob ich es mit deinem Artikel besser hinbekomme.

    Mein Gedanke war das es so angezeigt wird auf der Startseite, wenn es mir im Bearbeitungsmodus schon mal so angezeigt wird.

    Gibt es vielleicht ein Plugin das genau das macht was ich gerne hätte?

    Vielen Dank für deine Unterstützung.

    Viele Grüße
    Andreas

    Hallo,
    schau mal bitte rechts bei den Einstellungen im Block „Neueste Beiträge“. Da findest du genau die Möglichkeit, den Textauszug einzustellen:
    Einstellungen
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller aspies

    (@aspies)

    Hallo Hans-Gerd,

    Danke für den Hinweis, ich habe es jetzt anders gelöst. Habe die Möglichkeit „Medium mit Text“ genutzt. Mein Bild zum Blogbeitrag und einen Ausschnitt aus dem Text mit Link in dem Wort Weiterlesen versehen und mit Trennlinien etwas unterteilt. Macht optisch bissel mehr her finde ich persönlich. Aber die von dir genannte Möglichkeit geht auch und ist weniger Arbeit.

    Danke für deine Zeit.

    Viele Grüße Andreas

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Vorschau von Blog auf Startseite einbinden funktioniert nicht richtig“ ist für neue Antworten geschlossen.