Support » WooCommerce » Warenkorb verlinkt nicht richtig

  • Gelöst berni1969

    (@berni1969)


    Hallo Gemeinde,

    ich habe das Problem, das auf der Kassenseite der Button „Zurück zum Warenkorb“ immer auf den Warenkorb zurück geht, aber ich möchte einen Weiter einkaufen Button haben und das der Käufer auch dort hin geleitet wird, wie mache ich das? Habe mir das Plugin WooCommerce Continue Shopping instaliert, aber damit geht es auch nicht.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)
  • Ich verstehe dein Anliegen nicht richtig. Der Link „zurück zum Warenkorb“ macht ja genau das wie er beschriftet ist. Du willst aber nun an der Stelle einen Link haben, der .. ja, wohin soll der genau führen? Zur Startseite vom Shop?

    Thread-Starter berni1969

    (@berni1969)

    Erstmal danke für deine Rückmeldung, ja er soll nicht in den Warenkorb sondern zurück zum Shop führen

    Dazu müsstest Du das Kassen-Template anpassen. Da Du WooCommerce in seiner neuesten Version nutzt und dein Theme das nicht überschreibt, ist das recht einfach machbar.

    Ruf die Kasse auf und gehe oben auf „Seite bearbeiten“. Dort siehst Du dann wie WooCommerce das Template mit Blöcken aufgebaut hast. Such dir den Block der derzeit „zurück zum Warenkorb“ verlinkt. Das müsste der Block „Aktionen“ sein. Dort kannst Du diesen Link erstmal deaktivieren.

    Danach kannst Du an einer von dir gewünschten Stelle einen neuen Block einfügen. Dazu wählst Du einfach den Paragraph-Block aus und schreibst dort „zurück zum Shop“. Diesen Text verlinkst Du dann mit /shop/ – speichern, fertig.

    Thread-Starter berni1969

    (@berni1969)

    Hallo @threadi erstmal Danke das du mir ein Stück weiter geholfen hast. Ich habe jetzt den Button eingefügt er ist zwar nicht da wo er sein sollte, aber er erfüllt seinen Zweck, ich habe versucht die Position nach links zu ändern unter Kasse, aber irgendwie will es nich so. Schönen Abend noch. Früher war das irgendwie alles einfacher. Gruß

    Moderator Marcus Spanier

    (@espiat)

    Ist das Problem gelöst?

    Thread-Starter berni1969

    (@berni1969)

    Obwohl ich seit Tagen nichts mehr an dem Shop gemacht habe, wird mir die Checkout Seite nicht mehr richtig angezeigt.

    Hier der LINK dazu https://shop.schlagerherzen.com/kasse/

    was ist da passiert?

    Bei mir funktioniert sie. Natürlich muss man etwas in den Warenkorb legen. Sobald das passiert ist, kommt man zum Warenkorb und auch zur Kasse.

    Wie sieht die Ansicht bei dir denn aus? Gerne kannst Du einen Screenshot zeigen, z.B. hier hochladen: https://imgur.com

    Thread-Starter berni1969

    (@berni1969)

    Es fehlen doch aber die Eingabefelder für Adresse, Name und so weiter. Wird das bei dir angezeigt?

    Thread-Starter berni1969

    (@berni1969)

    Das sehe ich im Backend https://imgur.com/a/KpapoX3

    Die Kasse sieht bei mir so aus:

    View post on imgur.com

    Vermutung:
    Du bist mit einem Konto angemeldet. Vielleicht sind in diesem problematische Daten, die das Template nicht verarbeiten kann. Die auf deinem Screenshot angezeigte Fehlermeldung deutet für mich zumindest darauf hin. Welche das sind, kann man natürlich nicht sagen, da dazu keine Info in der Fehlermeldung zu sehen ist.

    Teste die Kasse mal nicht angemeldet, so wie es Neukunden deines Shops machen würden. Wenn das geht, liegt es vlt. an Daten in deinem Konto mit dem Du bisher getestet hast.

    Mir fällt noch auf, dass das Plugin WooCommerce Payments möglicherweise bei dir für Probleme sorgen könnte. Deaktiviere das auch mal testweise.

    Thread-Starter berni1969

    (@berni1969)

    Erst einmal Danke das du dir mal wieder Zeit für mich nimmst. Das komische ist auf meinem Handy wird alles richtig angezeigt, bin ich im Shop nicht angemeldet bekomme ich trotzdem dieses Bild. Jetzt habe ich auch noch das Problem wenn ich auf Kasse, nicht oben im Menue sondern vom Warenkorb aus da hinkomme und dann auf Kasse gehe, komme ich weder auf dem Handy noch auf em PC auf die Kassenseite. Verstehe nicht warum ich aufeinmal solche Probleme habe, weil ich an dem Shop nichts mehr geändert habe. Ausser Aktuallisierungen durch geführt habe die mir angezeigt wurden.

    Ging mir eben beim Testen auch so. Deaktiviere mal WooCommerce Payments. Ich vermute das verursacht hier ein Problem.

    Thread-Starter berni1969

    (@berni1969)

    Habe ich gemacht, habe jetzt nur das Plugin Paypal payments aktiviert gelassen

    Thread-Starter berni1969

    (@berni1969)

    Hallo threadi, den Fehler mit der Kasse habe ich gefunden, es war die falsche ID hinterlegt, leider fehlen immer noch die Eingabefelder für Name und Versandadresse. Bin aber noch dran. Vielleicht hast du noch eine Idee?

    Hast Du es, wie oben geschrieben, mal im nicht angemeldeten Stand angeschaut? So sehe ich alle Felder. Wenn Du sie angemeldet nicht siehst, werden sie vermutlich durch eine Einstellung in irgendeinem von dir genutzten Plugin ausgeblendet da das System davon ausgeht, dass Bestandskunden die Angaben nicht nochmal vornehmen müssen und so der Bestellprozess für diese beschleunigt wird.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 18)