Support » WooCommerce » Warning: array_key_exists(): The first argument should be either a string or an

  • Guten Morgen,

    vorab: ich bin ein „Angelernter“ und nicht vom Fach. Bin zum ersten Mal als „Suchender“ hier. Bisher habe ich alle Probleme mit dem WWW lösen können.

    Nach dem letzten update habe ich folgende Meldung:

    Warning: array_key_exists(): The first argument should be either a string or an integer in /www/htdocs/w01a0dec/kaefertuer.com/wp-content/plugins/woocommerce-germanized/includes/wc-gzd-core-functions.php on line 653

    Diese Meldung ist für den Besteller nach dem Bezahlvorgang sichtbar und hängt wohl mit Rechnungs- und Lieferadresse zusammen. Gibt es hier eine Lösung die auch ich umsetzen kann? Wie gesagt: Ich habe von der Programmierung keine Ahnnung. Danke für hilfreiche Infos.


    Moderationshinweis: In Forum WooCommerce verschoben.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 1 Antwort (von insgesamt 1)
  • Zunächst einmal ist das ein Warnhinweis, der auf einen Programmierfehler im Plugin Germanized aufmerksam machen soll, aber (noch) nicht tragisch ist. Du kannst solche Warnhinweise abschalten, indem du per FTP die Konfigurationsdatei wp-config.php anpasst. In der Datei solltest du eine Zeile define( 'WP_DEBUG', true ); finden, bei der du (bitte mit einem geeigneten Code-Editor oder dem Online-Editor https://vscode.dev/) den Wert true auf false änderst. Direkt darunter kannst du noch ein @ini_set( 'display_errors', 0 ); einfügen.

    Das ist natürlich nur Kosmetik und sorgt erst einmal nur dafür, dass der Fehler nicht mehr angezeigt wird. Du solltest deine Beobachtung dann dem Plugin-Entwickler mitteilen, damit der seinen Fehler beheben kann. Das Support-Forum des Plugins findest du unter https://wordpress.org/support/plugin/woocommerce-germanized/

Ansicht von 1 Antwort (von insgesamt 1)