Support » Allgemeine Fragen » Warning: Cannot modify header information – headers already sent by

  • Hallo zusammen,

    Gleich mal vorneweg. Ich habe vor genau 2 Monaten beschlossen: Ich baue mir jetzt zum ersten Mal in meinem Leben eine Homepage. Soweit bin ich relativ gut vorangekommen. Ich steh drauf alles selbst hinzubekommen. Aber diesmal brauche ich Profis. Also euch. Hier mein Problem zu posten ist wahrlich meine letzte Instanz. Aber ich habe alles ausprobiert was ich im Netz so zu meinem Problem habe finden können. Nichts hat funktioniert. Nochmal mein Problem:

    Warning: Cannot modify header information – headers already sent by (output started at /usr/www/users/finearaf/wp-admin/includes/template.php:2424) in /usr/www/users/finearaf/wp-includes/pluggable.php on line 1265

    Ich habe darauf geachtet, dass keine Leerzeichen o.ä. in der ersten Zeile stehen. (wp-config)
    An utf8 habe ich auch gedacht. Meinen Ocean-Theme mit einem Standard-Theme ausgetauscht. WP-Cache gelöscht, Browser Cache gelöscht. Nichts …
    Von PHP 7.4 runter auf 7.2. Nada.

    Alles komplett platt gemacht und nochmal sauber aufgespielt. Negativ ..

    Hier meine installierten Plugins (die ich natürlich auch mal alle deaktiviert habe uns step by step aktivieren wollte, doch auch ohne Plugins besteht das Problem) und alle anderen relevanten Infos. Ich hoffe, dass mir ein Pro aus der Patsche helfen kann:

    == Active Plugins ==
    CMP – Coming Soon & Maintenance Plugin
    Version: 3.7.2.1
    Author: NiteoThemes

    Elementor
    Version: 2.9.7
    Author: Elementor.com

    Elementor Pro
    Version: 2.9.2
    Author: Elementor.com

    IconPress PRO
    Version: 1.4.6
    Author: IconPress team

    Ocean Elementor Widgets
    Version: 1.2.1
    Author: OceanWP

    Ocean Extra
    Version: 1.6.1
    Author: OceanWP

    Ocean Sticky Footer
    Version: 1.0.10
    Author: OceanWP

    Ocean Sticky Header
    Version: 1.1.12
    Author: OceanWP

    UpdraftPlus – Backup/Restore
    Version: 1.16.22
    Author: UpdraftPlus.Com, DavidAnderson

    WP Fastest Cache
    Version: 0.9.0.4
    Author: Emre Vona

    WPForms Lite
    Version: 1.5.9.5
    Author: WPForms

    ————————————————————————-

    == Server Environment ==
    Operating System: Linux
    Software: Apache
    MySQL version: (Debian) v5.7.29
    PHP Version: 7.4.4
    PHP Max Input Vars: 1000
    PHP Max Post Size: 100M
    GD Installed: Yes
    ZIP Installed: Yes
    Write Permissions: All right
    Elementor Library: Connected

    == WordPress Environment ==
    Version: 5.3.2
    Site URL: https://www.fineartdesign.net
    Home URL: https://www.fineartdesign.net
    WP Multisite: No
    Max Upload Size: 100 MB
    Memory limit: 256M
    Permalink Structure: /%postname%/
    Language: de-DE
    Timezone: Europe/Berlin
    Admin Email: fineartdesign@web.de
    Debug Mode: Inactive

    == Theme ==
    Name: OceanWP
    Version: 1.8.1
    Author: Nick
    Child Theme: No

    Gerne bin ich bereit denjenigen auch die Zigangsdaten zu geben. Ehrensache.

    Vorab schon einmal herzlichen Dank!

    Gruß, Patrick

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 28)
  • Hast du mal die Plugins deaktiviert?
    Browser-Cache und Cookies gelöscht?

    Hi, danke für die schnelle Antwort.
    Ja, wie in meinem Text geschrieben. Seit einer Woche versuche ich das Problem zu lösen. Jetzt brauch ich euch. Komm einfach nicht zur Lösung

    Keiner eine Idee? Das wäre bitter …

    Moderationshinweis: Bumping ist hier unerwünscht. Da wir hier alle freiwillig und unentgeltlich helfen, musst du entweder etwas Geduld mitbringen oder einen Dienstleister beauftragen.

    Das dürfte schwer werden. Irgend ein Script versucht ein Redirect, der in die Hose geht, das könnte durchaus von einem Plugin kommen. Wenn ich mir die Datei wp-includes/pluggable.php ansehe, steht dort bei dieser Zeile (1264 bis 1266)

    if ( is_string( $x_redirect_by ) ) {
      header( "X-Redirect-By: $x_redirect_by" );
    }

    Um jetzt herauszufinden, wer diesen Redirect verursacht, könntest du diese drei Zeilen mal in

    if ( is_string( $x_redirect_by ) ) {
      // header( "X-Redirect-By: $x_redirect_by" );
      debug_print_backtrace();
      die ("X-Redirect-By: $x_redirect_by Redirect gestoppt");
    }

    ändern und hoffen, dass dir dieser Stack etwas weiterhilft.

    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von bscu.
    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von bscu.

    Hi! Danke für deie Antwort. Wie ich ja oben schon geschrieben habe, bin ich ein kopmplett Rooky. Verzeih mir daher bitte die Frage. In welcher Datei muss ich diese Änderung vornehmen?

    Wenn ich mir die Datei wp-includes/pluggable.php ansehe, steht dort bei dieser Zeile (1264 bis 1266)

    Steht doch da. Aber lege vorher eine Kopie an, wenn du nicht so besonders viel Ahnung hast.

    Von Cookies steht da nichts und wenn ich versuche, mich (mit fehlerhaften) Zugangsdaten anzumelden, bekomme ich auch keine Fehlermeldung angezeigt.
    (Das Angebot, dass wir uns in deine Website einloggen sollen, habe ich aus Gründen großzügig ignoriert.)

    Die Fehlermeldung erscheint, wenn es Probleme gibt Cookies zu setzen, weil eine Fehlermeldung dazwischenfunkt. Hast du in der wp-config.php Debugging aktiviert? Poste doch mal den Inhalt der wp-config.php(die Zeilen mit Zugangsdaten und SALT-Keys bitte löschen, alles bitte als [code] formatieren).

    Verallgemeinerungen erschweren die Fehlersuche. Wenn du „alles ausprobiert“, „alles komplett platt gemacht“ und „alle relevanten Infos gesammelt“ hast, ist erfahrungsgemäß die Wahrscheinlichkeit groß, dass du etwas übersiehst. Mit dieser Beschreibung ist es auch schwer, dir zu helfen, weil wir z.B. erst einmal mutmaßen müssen, dass ein Austausch der Core-Dateien bei „alles“ mitgemeint ist. Dass du wiederholst, dass du gerne Hilfe möchtest („ach?!“), macht es dann auch nicht besser.

    @ bscu omg, sorry. Hab ich übersehen. Danke dir! Ich werde es ausprobieren und das Ergebnis hier kundtun.

    @ Bego Mario Garde, Mea culpa und danke für den Hinweis. Hatte das nur angeboten, weil ich über solche Herangehensweisen in Foren gestolpert bin. Aber jetzt nachdem ich das gelesenn habe, bin ich bei dir. Klar.

    Werde jetzt den Code zusammenstellen …

    <?php
    /**
     * The base configuration for WordPress
     *
     * The wp-config.php creation script uses this file during the
     * installation. You don't have to use the web site, you can
     * copy this file to "wp-config.php" and fill in the values.
     *
     * This file contains the following configurations:
     *
     * * MySQL settings
     * * Secret keys
     * * Database table prefix
     * * ABSPATH
     *
     * @link https://codex.wordpress.org/Editing_wp-config.php
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define( 'DB_NAME', '***' );
    
    /** MySQL database username */
    define( 'DB_USER', '****' )
    
    /** MySQL hostname */
    define( 'DB_HOST', '****' );
    
    /** Database Charset to use in creating database tables. */
    define( 'DB_CHARSET', 'utf8' );
    
    /** The Database Collate type. Don't change this if in doubt. */
    define( 'DB_COLLATE', '' );
    
    /**#@+
     * Authentication Unique Keys and Salts.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link https://api.wordpress.org/secret-key/1.1/salt/ WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each
     * a unique prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix = 'wp_';
    
    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     *
     * For information on other constants that can be used for debugging,
     * visit the Codex.
     *
     * @link https://codex.wordpress.org/Debugging_in_WordPress
     */
    define( 'WP_DEBUG', false );
    
    /* That's all, stop editing! Happy publishing. */
    
    /** Absolute path to the WordPress directory. */
    if ( ! defined( 'ABSPATH' ) ) {
    	define( 'ABSPATH', dirname( __FILE__ ) . '/' );
    }
    
    /** Sets up WordPress vars and included files. */
    require_once( ABSPATH . 'wp-settings.php' );

    Das hat wohl nicht geklappt mit dem Code. Damn ^^

    Du könntest mal die Zeile
    define( 'WP_DEBUG', false );
    ändern in
    define( 'WP_DEBUG', true);
    Vielleicht kommen da weitere Infos ans Tageslicht, obwohl ich nicht wirklich daran glaube.

    • Diese Antwort wurde geändert vor 5 Monaten, 3 Wochen von Bego Mario Garde. Grund: typographische Anführungszeichen ausgetauscht

    Also, hier schonmal interessante News:

    #0 wp_redirect(https://www.fineartdesign.net/wp-admin/post.php?post=884&action=elementor) called at [/usr/www/users/finearaf/wp-content/plugins/elementor/core/admin/admin.php:563] 
    #1 Elementor\Core\Admin\Admin->admin_action_new_post() called at [/usr/www/users/finearaf/wp-includes/class-wp-hook.php:288] 
    #2 WP_Hook->apply_filters(, Array ([0] => )) called at [/usr/www/users/finearaf/wp-includes/class-wp-hook.php:312] 
    #3 WP_Hook->do_action(Array ([0] => )) called at [/usr/www/users/finearaf/wp-includes/plugin.php:478]
    #4 do_action(admin_action_elementor_new_post) called at [/usr/www/users/finearaf/wp-admin/admin.php:401] 
    #5 require_once(/usr/www/users/finearaf/wp-admin/admin.php) called at [/usr/www/users/finearaf/wp-admin/edit.php:10] X-Redirect-By: WordPress Redirect gestoppt

    Für mich sieht das alles aus wie die Inschriften im Tal der Könige … bewunderswert, dass ihr das lesen könnt …

    Soll ich trotzdem zusätzlich auf true stellen?

    @pixolin Danke für’s Aufräumen. Und eines wollte ich schon noch loswerden. Ich weiß das tatsächlich überaus zu schätzen, dass sich Leute wie ihr kümmert. Was bekommt ihr dafür? Eben … deshalb vielen Dank!

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 28)