Support » WooCommerce » Warnungen nach Plugin activation

  • Hallo! Ich bekomme viele Warnungen beim aktivieren des Woocommerce Plugins. Kann jemand herauslesen, woran ich arbeiten muss? Ich danke für jegliche Hinweise

    Warning: include_once(/home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/packages/action-scheduler/action-scheduler.php): failed to open stream: No such file or directory in /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php on line 489

    Warning: include_once(): Failed opening ‚/home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/packages/action-scheduler/action-scheduler.php‘ for inclusion (include_path=‘.:/usr/local/php7.3/lib/php‘) in /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php on line 489

    Warning: Cannot modify header information – headers already sent by (output started at /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php:489) in /home/www/nc2129/html/christianemeyer/wp-includes/functions.php on line 6274

    Warning: Cannot modify header information – headers already sent by (output started at /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php:489) in /home/www/nc2129/html/christianemeyer/wp-admin/includes/misc.php on line 1310

    Warning: Cannot modify header information – headers already sent by (output started at /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php:489) in /home/www/nc2129/html/christianemeyer/wp-admin/admin-header.php on line 9

    Warning: Cannot modify header information – headers already sent by (output started at /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php:489) in /home/www/nc2129/html/christianemeyer/wp-includes/option.php on line 1050

    Warning: Cannot modify header information – headers already sent by (output started at /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php:489) in /home/www/nc2129/html/christianemeyer/wp-includes/option.php on line 1051

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)
  • Bisher hat dir noch keiner geantwortet – und hier im Forum sind die Leutz mit Lichtgeschwindigkeit unterwegs beim Antworten.

    Was heißt: Anscheinend kann niemand mit deiner Frage oder den Infos was anfangen!

    Für mich is das auch zu generisch. Ich kenn deine Instanz nicht, und mit den paar Fehlern hier…kann ich nix anfangen.

    Es wird vermutlich nicht mit deinen Plugins/Themes/Anpassungen zusammenspielen.

    Thread-Ersteller miigaa

    (@miigaa)

    Hallo.
    Danke für die Antwort. Nach dem letzten Update von WordPress kommen die Fehler auch nicht mehr sondern generell die Meldung „Kann nicht kopiert“ und daraufhin auch nicht installiert werden.
    Auch meine info.php Seite kann ich nicht aufrufen.
    Wie du sagst muss irgendwas an den Grundeinstellungen nicht stimmen. Ich komm nur nicht drauf bzw weiß nicht, wo ich noch basteln soll. *seufz*

    Ich suche weiter…

    Probier mal alle Plugins zu deaktivieren, wenn das nicht geht, ändere den Namen des Plugin-Ordners per FTP.
    Dann aktivierst du die Plugins der Reihe nach wieder und schaust, ob die Fehler immer noch auftreten.

    Auch meine info.php Seite kann ich nicht aufrufen.

    Was meinst du damit? So etwas?

    Falls ja -> die Datei sollte immer nur kurzfristig auf dem Server sein, also hochladen, Seite/Datei aufrufen und dann wieder entfernen.

    Falls ja 2 -> Dann liegt die Ursache des Problems vermutlich nicht bei WordPress.

    Thread-Ersteller miigaa

    (@miigaa)

    @angelika Reisiger
    Ja, so etwas meinte ich! Habe gehofft, das mir das eine besser Übersicht gibt, wo es haken könnte. Wenn es nicht bei WordPress liegt, wie könnte ich denn deiner Meinung nach an die Sache besser rangehen? Der Support meines Hosts konnte mir bisher nicht weiterhelfen, vielleicht habe ich aber auch nicht die richtige Frage gestellt :/

    Danke für eure Hilfestellung und den Tipp mit der info.php Sobald ich sie einsehen konnte, schmeiss ich sie wieder runter 😉

    Meine neueste Fehlermeldung nach WP Update lautet schlicht:

    Installation fehlgeschlagen: Verzeichnis konnte nicht angelegt werden.

    Uff…Jetzt hast du anscheinend auch keine Schreibberechtigung mehr.

    Hast du Server-Error-Logfiles bei deinem Hoster und kannst du die einsehen?

    Thread-Ersteller miigaa

    (@miigaa)

    Ich kann einige Logfiles via FTP einsehen. Suche ich nach etwas Bestimmtem?

    Das Deaktivieren der Plugins hat leider nicht geholfen. Alle Plugin Aktivierungen führen zu folgender Seite:

    Warning: include_once(/home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/packages/action-scheduler/action-scheduler.php): failed to open stream: No such file or directory in /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php on line 489

    Warning: include_once(): Failed opening ‚/home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/packages/action-scheduler/action-scheduler.php‘ for inclusion (include_path=‘.:/usr/local/php7.3/lib/php‘) in /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/includes/class-woocommerce.php on line 489

    Warning: require(/home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Package.php): failed to open stream: No such file or directory in /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/vendor/jetpack-autoloader/class-php-autoloader.php on line 87

    Fatal error: require(): Failed opening required ‚/home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/packages/woocommerce-blocks/src/Package.php‘ (include_path=‘.:/usr/local/php7.3/lib/php‘) in /home/www/nc2129/html/christianemeyer/wp-content/plugins/woocommerce/vendor/jetpack-autoloader/class-php-autoloader.php on line 87

    Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    du findest unter Werkzeuge > Websitezustand > Info einen Bericht zur Website. Warte bitte einen Moment bis die Ladeanzeige ganz oben abgeschlossen ist und kopiere dann per Button den Website-Bericht in deine Zwischenablage. Über den Button „Bericht in die Zwischenablage kopieren“ kannst du den Bericht unverändert (bitte mit den Akzentzeichen am Anfang und Ende) einfügen und anschließend hier posten. Evtl. ergeben sich dann weitere Anhaltspunkte, ob und wo das Problem liegt.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller miigaa

    (@miigaa)

    @hage Vielen Dank für diese Hilfestellung, Hans-Gerd. Ich bin beeindruckt von der Geschwindigkeit des Forums und eurem Können. Kannst du dem Bericht eventuell richtungsweisende Anhaltspunkte entnehmen?

    Liebe Grüße
    Christiane

    
    ### wp-core ###
    
    version: 5.7.2
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    multisite: false
    user_registration: 0
    blog_public: 0
    default_comment_status: open
    environment_type: production
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /home/www/nc2129/html/christianemeyer
    wordpress_size: 53,73 MB (56337894 bytes)
    uploads_path: /home/www/nc2129/html/christianemeyer/wp-content/uploads
    uploads_size: 458,44 kB (469440 bytes)
    themes_path: /home/www/nc2129/html/christianemeyer/wp-content/themes
    themes_size: 5,59 MB (5862451 bytes)
    plugins_path: /home/www/nc2129/html/christianemeyer/wp-content/plugins
    plugins_size: 25,28 MB (26510305 bytes)
    database_size: 2,88 MB (3014656 bytes)
    total_size: 87,92 MB (92194746 bytes)
    
    ### wp-active-theme ###
    
    name: Ashe (ashe)
    version: 1.9.9.5.6 (latest version: 1.9.9.5.9)
    author: WP Royal
    author_website: https://wp-royal.com/
    parent_theme: none
    theme_features: core-block-patterns, automatic-feed-links, title-tag, post-thumbnails, custom-logo, custom-header, custom-background, menus, html5, responsive-embeds, woocommerce, wc-product-gallery-zoom, wc-product-gallery-lightbox, wc-product-gallery-slider, widgets
    theme_path: /home/www/nc2129/html/christianemeyer/wp-content/themes/ashe
    auto_update: Deaktiviert
    
    ### wp-plugins-inactive (5) ###
    
    Akismet Anti-Spam: version: 4.1.9, author: Automattic, Automatische Aktualisierungen deaktiviert
    Elementor: version: 3.2.4, author: Elementor.com, Automatische Aktualisierungen deaktiviert
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg, Automatische Aktualisierungen deaktiviert
    Polylang: version: 3.0.4, author: WP SYNTEX, Automatische Aktualisierungen deaktiviert
    Widgets for Trustpilot Reviews: version: 6.4.1, author: Trustindex.io <support@trustindex.io>, Automatische Aktualisierungen deaktiviert
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1799
    imagemagick_version: ImageMagick 7.0.7-23 Q16 x86_64 2018-02-23 http://www.imagemagick.org
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.844674407371E+19
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 1
    gd_version: bundled (2.1.0 compatible)
    ghostscript_version: 8.71
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.197-netclusive64 x86_64
    httpd_software: Apache
    php_version: 7.3.27 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 1500
    time_limit: 600
    memory_limit: 386M
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1i
    suhosin: false
    imagick_availability: true
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.5.56
    client_version: 5.1.73
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /home/www/nc2129/html/christianemeyer/wp-content
    WP_PLUGIN_DIR: /home/www/nc2129/html/christianemeyer/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: 386M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    

    Hallo,
    leider kann ich da auch keine schwerwiegenden Probleme entdecken: Statt PHP 7.3.x solltest du PHP 7.4.x aktivieren (normalerweise sollte das über das Kundenmenü des Hosters funktionieren). Außerdem ist Akismet ein Plugin, das nicht der DSGVO entspricht.
    Du kannst auch mal folgendes testen:
    Installiere bitte ein Standardtheme wie z. B. Twenty Twenty oder Twenty Twenty One.
    Anschließend klickst du unter Werkzeuge > Website-Zustand auf Problembehandlung. Auf der folgenden Seite befindet sich unten der Button „Problembehandlungsmodus aktivieren“ . Wenn du auf diesen Button klickst, werden alle plugins deaktiviert und als Standardtheme (wenn vorhanden) twenty twenty oder Twenty Twenty-One aktiviert. Dann kannst du sehen, ob die beschriebenen Probleme noch weiterhin auftauchen. Aktiviere dann zunächst das Theme Ashe und danach Plugin für Plugin im Problembehandlungsmodus und schaue jeweils nach Aktivierung, ob das Problem noch besteht. Auf diese Weise kannst du möglicherweise herausfinden, ob das Problem durch das Theme und/oder ein Plugin verursacht wird. Vorteil dabei ist, dass der Leser deines Blogs die Seite weiter mit allen Infos und plugins sieht, während nur für dich alle plugins deaktiviert sind.
    Lies dir dazu auch mal die Informationen in dem Beitrag zu Health Check durch.
    Viele Grüße
    Hans-Gerd

Ansicht von 10 Antworten - 1 bis 10 (von insgesamt 10)