Support » Allgemeine Fragen » Webseite Admin Login manchmal nach SSL Umstellung nicht erreichbar

  • Gelöst manuelp62

    (@manuelp62)


    Hallo,
    ich bin neu und habe zu diesem Thema nichts passendes gefunden.

    Ich habe vor 1 Monat bei einem Hoster für diese Domain, das SSL Zertifikat (Lets Encrypt) einfach nur aktiviert. Zu dieser Zeit wusste ich noch nicht das man auch in WordPress etwas ändern muss.

    Es hat auf den ersten Blick keinen Problem gemacht bis wir drauf gekommen sind, dass eine Unterseite nicht mehr geladen hat. Damals war noch auf https erzwingen eingestellt. Das habe ich nach dem Problem geändert. Die Unterseite hat zwar wieder funktioniert allerdings kam statt dem Admin Login:
    Not Found
    The requested URL /wp-login.php?redirect_to=http%3A%2F%2Fwww.extrunet.com%2Fwp-admin%2F&reauth=1 was not found on this server.

    Nach dem Einspielen eines älteren Backups funktionierte es wieder bis vor zwei Wochen. Da hat es auch nach 5 Stunden wieder funktioniert ohne das ich etwas geändert habe.
    Heute kam der Fehler auch wieder.
    Da war es so:

    Haupt Admin hat sich angemeldet und mir einen Admin Benutzer erstellt.
    Dann wollte ich den Benutzer testen. Hat nach 3 Versuchen nicht funktioniert. Dann wollte ich das Passwort zurücksetzen und dann kam wieder die Fehlermeldung.

    Etwas später habe ich das Internet gewechselt und dort hat es auch zuerst funktioniert bis ich dort ebenfalls das Passwort zurücksetzen musste.

    Wir hätten bald vor, das wir sowieso ein richtiges SSL Zertifikat installieren aber dafür müssten wir in den Admin Bereich.

    Anmerkung: Die eigentliche Webseite hat immer problemlos funktioniert.

    Mit freundlichen Grüßen
    Manuel

    • Dieses Thema wurde geändert vor 1 Jahr, 8 Monaten von Bego Mario Garde. Grund: Nachname gelöscht

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Vorab: die richtige URL zum Anmelden im Backend ist http://example.com/wp-login.php (mit deiner Domain) – nicht admin und eigentlich auch nicht wp-admin. http://example.com/wp-admin ist die URL zum Backend (admininistrativer Bereich). Rufst du diese Adresse auf und im Browser ist kein (oder der falsche) Authentifikations-Cookie gesetzt, wirst du auf wp-login.php umgeleitet – vorausgesetzt, alles funktioniert richtig.

    So wie du die Vorgehensweise schilderst, würde ich erst einmal vermuten, dass Cache und/oder Cookies im Browser Probleme bereiten. Die würde ich komplett löschen und dann erneut eine Anmeldung versuchen.

    Eine Umstellung auf verschlüsselte Übertragung mit SSL ist eigentlich kein großes Ding und normalerweise in zehn Minuten erledigt:

    • SSL-Zertifikat mit Skript vom Webhoster ausstellen lassen – ein Aufruf von https://example.com darf keine Fehlermeldung „NET::ERR_CERT_COMMON_NAME_INVALID“ erzeugen. Eine Umleitung https -> http muss entfernt werden.
    • Backup der Datenbank
    • In Einstellungen > Allgemein beide URLs auf https ändern.
    • Cookies und Cache löschen und neu anmelden.
    • Mit Plugin Better Search Replace die alte URL (http://extrun) mit der neuen URL (`https://extrun‘) in allen Tabellen ersetzen.

    Zumindest nach deutschem Recht ist nach meinen Kenntnissen (ich bin kein Jurist) die Verwendung eines Kontaktformulars über eine ungesicherte Verbindnung nicht datenschutzkonform. Das dürfte in Österreich durch die europaweit geltende GDPR nicht anders sein.

    Thread-Ersteller manuelp62

    (@manuelp62)

    Hallo pixolin,
    es hat auch nicht funktioniert wenn ich mit dem selben Gerät im Netzwerk auf die Webseite klicke, in anderen Netzwerken schon.

    PS: Kann man im Nachhinein eine Nachricht noch bearbeiten?

    Mit freundlichen Grüßen
    Manuel P

    PS: Kann man im Nachhinein eine Nachricht noch bearbeiten?

    Das ist nur für kurze Zeit möglich.

    Thread-Ersteller manuelp62

    (@manuelp62)

    Und die Frage?

    Ich hab keine?

    Thread-Ersteller manuelp62

    (@manuelp62)

    Nein, ob man das Thema bzw. die Frage auch noch später bearbeiten kann?

    Das kann ich dir nicht sagen, weil ich nicht als Benutzer mit eingeschränkten Rechten arbeite. Wo hakt’s denn?

    Thread-Ersteller manuelp62

    (@manuelp62)

    Könntest du mir den Nachnamen von der Anfangsfrage bei „Mit freundlichen Grüßen…“ weglöschen?

    Mit freundlichen Grüßen
    Manuel P

    Bitte demnächst vorher überlegen, was du im Web veröffentlichst. 😉

    Thread-Ersteller manuelp62

    (@manuelp62)

    Ok danke.
    Warum kommt manchmal die Fehlermeldung 404 und verschwindet nach 4-5 Stunden wieder?

    Thread-Ersteller manuelp62

    (@manuelp62)

    Ich habe bemerkt, das der Fehler Netzwerkunabhängig ist.
    Und es jeden Tag um ungefähr 13Uhr wieder normal ist.
    Ich glaube, es hängt von der IP Adresse ab.
    Ich habe die IP Adresse, die nicht funktionierte in der Datenbank gesucht und unter den Tabellen einen Eintrag gefunden:

    _cerber_sets
    _options
    _usermeta
    _cerber_blocks
    cerber_log
    cerber_qmem
    cerber_traffic
    In welches von diesen Tabellen kann ich die IP problemlos löschen?

    Mit freundlichen Grüßen
    Manuel P

    Thread-Ersteller manuelp62

    (@manuelp62)

    In der Datenbank steht als Eintrag: 701|0|0|0|www.example.com/wp-login.php
    Bevor oft der Eintrag 13|0|0|0|www.extrunet.com/wp-login.php zu lesen ist.

    Das klingt nach Tabellen für ein All-in-One-Security-Plugin (Cerber Security, Anti-spam & Malware Scan?)

    Ich hab das Plugin gerade rasch installiert, wobei diverse Datenbank-Tabellen mit dem Präfix cerber_ angelegt werden. Diese Datenbank-Tabellen werden aber mit Löschen des Plugins auch wieder entfernt. Sollte das bei dir nicht der Fall sein, probier doch mal, das Plugin neu zu installieren und wieder zu deinstallieren.

    Thread-Ersteller manuelp62

    (@manuelp62)

    Danke für die Antwort. Wie kann ich das Plugin löschen.
    Mir wäre es lieber wenn ich nur die IP Adresse rauslösche.
    Ich habe herausgefunden, dass der Fehlercode 404 sein kann, wenn die Webseite den Zugriff blockiert.

    Ich habe dich bisher so verstanden, dass du meinst, ein Eintrag in der Datenbank könnte die Probleme verursachen. Das Plugin Cerber Security (ich gehe davon aus, dass du das verwendet hast?) löscht eigentlich die Datenbank-Tabellen, wenn es ordentlich gelöscht wird (also über das Menü Plugins im WordPress-Backend, nicht durch Entfernen der Dateien per FTP). Falls das nicht der Fall gewesen ist, würde ich über das Menü Plugins das Plugin nochmal neu installieren und dann erneut im Plugin-Menü löschen.

    Manche Plugins haben in den Einstellungen eine Option „Tabellen nach dem Löschen des Plugins entfernen“. Eine solche Option habe ich bei dem Plugin nicht gesehen. In meiner Testinstallation wurden die Tabellen aber beim Löschen des Plugins wieder entfernt.

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 21)
  • Das Thema „Webseite Admin Login manchmal nach SSL Umstellung nicht erreichbar“ ist für neue Antworten geschlossen.