Support » Allgemeine Fragen » Webseite Admin Login manchmal nach SSL Umstellung nicht erreichbar

  • Gelöst manuelp62

    (@manuelp62)


    Hallo,
    ich bin neu und habe zu diesem Thema nichts passendes gefunden.

    Ich habe vor 1 Monat bei einem Hoster für diese Domain, das SSL Zertifikat (Lets Encrypt) einfach nur aktiviert. Zu dieser Zeit wusste ich noch nicht das man auch in WordPress etwas ändern muss.

    Es hat auf den ersten Blick keinen Problem gemacht bis wir drauf gekommen sind, dass eine Unterseite nicht mehr geladen hat. Damals war noch auf https erzwingen eingestellt. Das habe ich nach dem Problem geändert. Die Unterseite hat zwar wieder funktioniert allerdings kam statt dem Admin Login:
    Not Found
    The requested URL /wp-login.php?redirect_to=http%3A%2F%2Fwww.extrunet.com%2Fwp-admin%2F&reauth=1 was not found on this server.

    Nach dem Einspielen eines älteren Backups funktionierte es wieder bis vor zwei Wochen. Da hat es auch nach 5 Stunden wieder funktioniert ohne das ich etwas geändert habe.
    Heute kam der Fehler auch wieder.
    Da war es so:

    Haupt Admin hat sich angemeldet und mir einen Admin Benutzer erstellt.
    Dann wollte ich den Benutzer testen. Hat nach 3 Versuchen nicht funktioniert. Dann wollte ich das Passwort zurücksetzen und dann kam wieder die Fehlermeldung.

    Etwas später habe ich das Internet gewechselt und dort hat es auch zuerst funktioniert bis ich dort ebenfalls das Passwort zurücksetzen musste.

    Wir hätten bald vor, das wir sowieso ein richtiges SSL Zertifikat installieren aber dafür müssten wir in den Admin Bereich.

    Anmerkung: Die eigentliche Webseite hat immer problemlos funktioniert.

    Mit freundlichen Grüßen
    Manuel

    • Dieses Thema wurde geändert vor 1 Jahr, 2 Monaten von Bego Mario Garde. Grund: Nachname gelöscht

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)
  • Thread-Ersteller manuelp62

    (@manuelp62)

    Danke ich komme wieder rein.
    Ich habe das Plugin vom Plugin Ordner gelöscht und installiere es gerade neu.

    Thread-Ersteller manuelp62

    (@manuelp62)

    Nach dem Entfernen von dem Zertifikat kam bei dem ersten Aufruf der Webseite die Meldung „nicht sicher“

    Wie du oben beschrieben hast kam jedesmal nach https Eingabe die Fehlermeldung „Dies ist keine sichere Verbindung“:
    ein Aufruf von https://example.com darf keine Fehlermeldung „NET::ERR_CERT_COMMON_NAME_INVALID“ erzeugen. Eine Umleitung https -> http muss entfernt werden.

    Wie bzw. wo mache ich die Umleitung?

    Mit freundlichen Grüßen
    Manuel P

    Nach dem Entfernen von dem Zertifikat kam bei dem ersten Aufruf der Webseite die Meldung „nicht sicher“

    Wieso hast du das Zertifikat entfernt?
    Wenn du eine Webseite per https aufrufen möchtest und kein Zertifikat zur sicheren Übertragung vorhanden ist, ist die Webseite nicht sicher.

    NET::ERR_CERT_COMMON_NAME_INVALID kann erscheinen, wenn du kein SSL-Zertifikat hast und der Server zur Auslieferung auf ein SSL-Zertifikat des Webhosters zurückgreift, das dann aber nicht zu deiner URL passt.

    Eine automatische Umleitung von http auf https wird meistens im Kundenmenü (und in selteneren Fällen durch einen manuellen Eintrag in der .htaccess vorgenommen.

    Thread-Ersteller manuelp62

    (@manuelp62)

    Weil es Probleme machte und der Anbieter anscheinend kein zertifizierter Aussteller ist.
    Ich brauche eine Umleitung von https auf http nicht umgekehrt.
    Also ist beim Provider noch ein Zertifikat hinterlegt das entfernt werden muss?

    Mit freundlichen Grüßen
    Manuel Prielinger

    Weil es Probleme machte und der Anbieter anscheinend kein zertifizierter Aussteller ist.

    Ich glaube, du wirfst da einiges durcheinander.
    Der Webhoster stellt keine SSL-Zertifikate aus. Er verwendet aber SSL-Zertifikate, um eine verschlüsselte Übertragung zu ermöglichen. Hast du für deine Website kein Zertifikat eingerichtet, fällt der Webserver auf das Zertifikat des Webhosters zurück. Das ist dann aber für deine Webseite nicht geeignet.

    Ich brauche eine Umleitung von https auf http nicht umgekehrt.

    Das ist eher ungewöhnlich, aber mit einer Regel in der .htaccess machbar. Im Web findest du dazu Anleitungen. Serverkonfiguration ist hier off topic, weshalb ich da nicht weiter drauf eingehe.

    Wenn du auf deiner Website ein Kontaktformular verwendest, ohne die Website per https zu verschlüsseln, ist das ein Verstoß gegen den Datenschutz. Zumindest werden aber von Google Webseite, die nur unverschlüsselt übertragen werden, schlechter gerankt und im Browser werden Webseiten ohne https als unsicher angezeigt. Eigentlich nichts, was man sich für seine Webseiten wünscht.

    Thread-Ersteller manuelp62

    (@manuelp62)

    Gibt es dafür ein bestimmtes Plugin oder kann man dafür jedes Redirect Plugin machen? Im Internet steht man soll es bei WordPress über Plugins machen.

Ansicht von 6 Antworten - 16 bis 21 (von insgesamt 21)
  • Das Thema „Webseite Admin Login manchmal nach SSL Umstellung nicht erreichbar“ ist für neue Antworten geschlossen.