Support » Allgemeine Fragen » Webseite nur nach mehrfachem Neuladen erreichbar

  • Gelöst pepe2505

    (@pepe2505)


    (aktuelle WP-Version 5.4.1; PHP 7.0)
    Nachdem ich gestern einige WordPress-Plugins (Advanced Excerpt, Gutenberg, Jetpack, Prosodia VG Wort, Yoast)auf meiner Seite aktualisiert habe, erschien nur noch die weiße Seite, und zwar sowohl im Frontend- wie im Backend-Bereich. Der Debugging-Modus brachte mich nicht viel weiter, stelle allerdings fest, dass nach 1-2-maligem Neuladen der Seite über den Browser-Button (egal, ob Firefox oder Chrome) die Seiten dann doch geladen und korrekt angezeigt wurden. Eine neuerliche, heute angebotene Jetpack-Installation brachte keine Veränderung. Allerdings bekam ich eine automatisch generierte WordPress-Email, dass meine Webseite ein technisches Problem habe, das durch das Plugin BackWPUp verursacht würde. Ich habe dieses Plugin daraufhin deaktiviert (aber nicht gelöscht). Da skizzierte Phänomen (weißte Seite, nach mehrfachem Neuladen korrekte Anzeige) besteht weiterhin.
    Über Rat und Hilfe würde ich mich dankbar freuen.

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)
  • PHP 7.0 ist inzwischen veraltet und wird nicht mehr supported. Dein Webhoster sollte eine aktuellere PHP-Version im Kundenmenü anbieten. Führe bitte den Wechsel durch, teste deine Website und melde dich wieder.

    Ich habe auf PHP 7.4 aktualisiert, das oben skizzierte Problem stellt sich aber weiterhin.

    Deaktiviere doch bitte mal das Cookie-Plugin und schau, was dann passiert.
    Du scheinst auch eine veraltete Version von WordPress zu verwenden – bitte aktualisiere die auch noch.

    Danke für die schnelle Rückmeldung!
    Ich habe das Plugin Cookie Notice deaktiviert und kann mich leider kurzfassen: keine Veränderung des Phänomens, sowohl im Frontend wie im Backend. Nach 2-5 mal Klicken auf den Neuladen-Button im Browser bekomme ich Zugriff, vorher aber immer eine weiße Seite. 🙁

    Ja, habe ich gesehen. Welche WordPress-Version verwendest du? Deaktviere doch bitte mal das Cookie-Plugin – ändert sich dann etwas?

    Ich habe die WP-Version 5.4.1
    Das Plugin „Cookie Notice“ habe ich deaktiviert, ein anderes Cookie-Plugin habe ich nicht. Ich habe allerdings einmal nachgeschaut, ob mit Jetpack eine Cookie-Option anbietet (aber keine gefunden). Festgestellt habe ich aber, dass sich Jetpack nicht aktualisieren lässt mit folgender Fehlermeldung: „Fehler beim Aktualisieren der Einstellungen. JSON.parse: unexpected end of data at line 1 column 1 of the JSON data“. Damit kann ich (als Laie) nichts anfangen, weiß also auch nicht, ob das von Bedeutung ist.

    Hm, dann ist der Fehler doch nicht so einfach zu beheben.

    Installier doch bitte mal das Plugin Health Check – das wurde vom WordPress-Support-Team entwickelt, um die Fehlersuche zu vereinfachen. Unter Werkzeuge > Website-Zustand > Bericht findest du einen Button, um die relevanten Informationen zu deiner Webseite zu kopieren und hier in einer Antwort einzufügen. Bitte warte ab, bis der Bericht komplett geladen ist und füge ihn hier unverändert (also mit den Akzentzeichen an Anfang und Ende) ein. Geh dann auf Problembehandlungsmodus, um damit – nur für dich und nur vorübergehend – alle Plugins zu deaktivieren. Tritt der Fehler dann immer noch auf? Falls nicht, kannst du die Plugins einzeln wieder aktivieren und jeweils das Verhalten testen. Ziel ist, die Fehlerursache herauszufinden.

    Vielen Dank für die erneut so schnelle Antwort. Werde dem Rat folgen und das machen, glaube nur, dass das heute aus Zeitgründen nichts mehr wird. Werde mich nach Umsetzung wieder melden.

    Ich habe es jetzt doch etwas früher geschafft.

    Beim Durchlauf des Problembehandlungsmodus hat sich ergeben, dass offenbar das Plugin Wordfence Security das Problem verursacht. Sobald das aktiviert ist, treten die genannten Phänomene auf.

    Bei der Analyse des Website-Zustands wird auf 2 „kritsche Probleme“ hingewiesen:
    – Beim Wpcom Connection Text von Jetpack wird gemeldet, Peter liest sei „not connected:200“.
    Beim Feld „Hintergrundupdates funktionieren nicht wie erwartet“ wird angemahnt: „Ein Plugin hat Aktualisierungen verhindert, indem es wp_version_check() deaktiviert hat.“ Bei allen anderen Items sind grüne Häkchen.

    Dieses Health Check ist ja ein tolles Tool!

    Bevor ich den Bericht anhänge, schon einmal vielen Dank für die Mühen!!!

    
    ### wp-core ###
    
    version: 5.4.1
    site_language: de_DE
    user_language: de_DE
    timezone: Europe/Berlin
    permalink: /%postname%/
    https_status: false
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 2
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /www/htdocs/w00e6dd8/peter-liest.de
    wordpress_size: 105,87 MB (111011319 bytes)
    uploads_path: /www/htdocs/w00e6dd8/peter-liest.de/wp-content/uploads
    uploads_size: 446,47 MB (468156962 bytes)
    themes_path: /www/htdocs/w00e6dd8/peter-liest.de/wp-content/themes
    themes_size: 10,14 MB (10631770 bytes)
    plugins_path: /www/htdocs/w00e6dd8/peter-liest.de/wp-content/plugins
    plugins_size: 74,38 MB (77997768 bytes)
    database_size: 63,08 MB (66140965 bytes)
    total_size: 699,94 MB (733938784 bytes)
    
    ### wp-active-theme ###
    
    name: Weta (weta)
    version: 1.0.4
    author: Elmastudio
    author_website: http://www.elmastudio.de/en/
    parent_theme: none
    theme_features: editor-style, automatic-feed-links, title-tag, menus, custom-background, post-formats, featured-content, post-thumbnails, woocommerce, infinite-scroll, custom-header, widgets
    theme_path: /www/htdocs/w00e6dd8/peter-liest.de/wp-content/themes/weta
    
    ### wp-themes-inactive (9) ###
    
    Chronus: version: 1.7.1, author: ThemeZee
    Gambit: version: 1.6.5, author: ThemeZee
    Harrison: version: 1.1, author: ThemeZee
    Twenty Fifteen: version: 2.6, author: WordPress-Team
    Twenty Nineteen: version: 1.5, author: WordPress-Team
    Twenty Seventeen: version: 2.3, author: WordPress-Team
    Twenty Sixteen: version: 2.1, author: WordPress-Team
    Twenty Twenty: version: 1.3, author: WordPress-Team
    Weta Child: version: 1.0, author: Peter Peters
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.1
    
    ### wp-plugins-active (19) ###
    
    Advanced Excerpt: version: 4.3.6, author: WPKube
    Annual Archive: version: 1.5.4, author: Twinpictures
    Antispam Bee: version: 2.9.2, author: pluginkollektiv
    Category Order and Taxonomy Terms Order: version: 1.5.7.2, author: Nsp-Code
    Category Sticky Post: version: 2.10.1, author: Tom McFarlin
    Gutenberg: version: 8.2.1, author: Gutenberg Team
    Health Check & Troubleshooting: version: 1.4.4, author: The WordPress.org community
    Jetpack by WordPress.com: version: 8.6.1, author: Automattic
    Limit Login Attempts Reloaded: version: 2.13.0, author: WPChef
    Prosodia VGW OS: version: 3.22.7, author: Prosodia – Verlag für Musik und Literatur
    Shariff Wrapper: version: 4.6.5, author: Jan-Peter Lambeck & 3UU
    Subtitles: version: 3.0.0, author: <a href="https://philip.blog/">Philip Arthur Moore</a>, <a href="https://wecobble.com">We Cobble</a>
    ThemeZee Magazine Blocks: version: 1.1.2, author: ThemeZee
    TinyMCE Advanced: version: 5.4.0, author: Andrew Ozz
    WordPress Popular Posts: version: 5.1.0, author: Hector Cabrera
    WP-Sweep: version: 1.1.3, author: Lester 'GaMerZ' Chan
    WPFront Scroll Top: version: 2.0.2, author: Syam Mohan
    WP Maintenance Mode: version: 2.2.4, author: Designmodo
    Yoast SEO: version: 14.2, author: Team Yoast
    
    ### wp-plugins-inactive (6) ###
    
    BackWPup: version: 3.7.1, author: Inpsyde GmbH
    Classic Editor: version: 1.5, author: WordPress Contributors
    Cookie Notice: version: 1.3.2, author: dFactory
    Regenerate Thumbnails: version: 3.1.3, author: Alex Mills (Viper007Bond)
    Wordfence Security: version: 7.4.7, author: Wordfence
    WordPress Importer: version: 0.7, author: wordpressdotorg
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1687
    imagemagick_version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 31 GB
    	imagick::RESOURCETYPE_DISK: 1.84467440737E+19
    	imagick::RESOURCETYPE_FILE: 786432
    	imagick::RESOURCETYPE_MAP: 31 GB
    	imagick::RESOURCETYPE_MEMORY: 16 GB
    	imagick::RESOURCETYPE_THREAD: 8
    gd_version: 2.2.5
    ghostscript_version: 9.26
    
    ### wp-server ###
    
    server_architecture: Linux 4.15.0-101-generic x86_64
    httpd_software: Apache
    php_version: 7.4.5 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 3000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 200M
    php_post_max_size: 200M
    curl_version: 7.58.0 OpenSSL/1.1.1
    suhosin: false
    imagick_availability: true
    htaccess_extra_rules: false
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.28-nmm1-log
    client_version: mysqlnd 7.4.5
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /www/htdocs/w00e6dd8/peter-liest.de/wp-content
    WP_PLUGIN_DIR: /www/htdocs/w00e6dd8/peter-liest.de/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    ### jetpack ###
    
    site_id: 97022376
    ssl_cert: No
    time_diff: undefined
    version_option: 8.6.1:1591168643
    old_version: 8.6:1591112711
    public: Public
    master_user: #2 Peter Peters (info@peter-liest.de)
    current_user: #2 Peter Peters (info@peter-liest.de)
    tokens_set: Blog User
    blog_token: me0c!SGk%s7Dfkxg*EC8L9I!SVQ4)8uL
    user_token: (Nkt#N%phqCCi!E$@v3Vg@vEV)H#vb1V
    version: 8.6.1
    jp_plugin_dir: /www/htdocs/w00e6dd8/peter-liest.de/wp-content/plugins/jetpack/
    plan: free
    HTTP_HOST: www.peter-liest.de
    SERVER_PORT: 80
    REMOTE_ADDR: 87.161.245.106
    protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
    full_sync: {"started":"Thu, 04 Jun 2020 07:33:54 +0000","finished":"Thu, 04 Jun 2020 07:34:06 +0000","progress":{"options":{"finished":true},"functions":{"finished":true},"constants":{"finished":true},"users":{"total":"1","sent":1,"finished":true,"last_sent":"2"}},"config":{"options":true,"functions":true,"constants":true,"users":[2]}}
    sync_size: undefined
    sync_lag: 0 seconds
    full_sync_size: undefined
    full_sync_lag: 0 seconds
    idc_urls: {"home":"http:\/\/www.peter-liest.de","siteurl":"http:\/\/www.peter-liest.de","WP_HOME":"","WP_SITEURL":""}
    idc_error_option: false
    idc_optin: true
    cxn_tests: {"7":{"name":"test__wpcom_connection_test","label":false,"short_description":"Peter liest ... is not connected.: 200","long_description":false,"severity":"critical","action":"https:\/\/jetpack.com\/redirect?source=jetpack-contact-support&site=www.peter-liest.de","action_label":"Bitte wende dich an den Support von Jetpack.","show_in_site_health":true,"pass":false,"group":["default"],"type":"direct"}}
    
    

    Kleine Ergänzung: Ich habe auch im Normalmodus Wordfence Security deaktiviert, und die Website scheint problemlos zu laufen.

    Jetzt habe ich gerade Folgendes gesehen: Wenn ich bei den installierten Plugins beim (deaktivierten) Wordfence Security den Link anklicke: Details ansehen, zeigt er mir folgende Fehlermeldung:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 81920 bytes) in /www/htdocs/w00e6dd8/peter-liest.de/wp-admin/includes/admin.php on line 80

    Es gab einen kritischen Fehler auf deiner Website. Bitte überprüfe den Posteingang deiner Website-Administrator-E-Mail-Adresse für weitere Anweisungen.

    Erfahre mehr über die Fehlerbehebung in WordPress.

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 81920 bytes) in /www/htdocs/w00e6dd8/peter-liest.de/wp-content/plugins/jetpack/vendor/autoload_packages.php on line 168

    Als Laie kann ich damit leider relativ wenig anfangen.

    Scheint so, als würde WordFence der bei deiner Website zur Verfügung stehende Arbeitsspeicher nicht ausreichen. Also entweder auf das Plugin verzichten oder beim Webhoster gegen kleines Aufgeld mehr Arbeitsspeicher buchen. (Vorher prüfst du aber bitte, ob du den zur Verfügung stehenden Arbeitsspeicher auch wirklich ausnutzt. Die Webhoster stellen gerne einen niedrigeren Wert ein, den du im Kundenmenü hochsetzen kannst.)

    All-in-One-Security-Lösungen sind nicht unumstritten. Sie vermitteln ein falsches Sicherheitsgefühl, wenn „alles angeklickt“ wurde, erklären AnwenderInnen aber nicht unbedingt, weshalb ihre Website trotzdem unsicher ist.

    So einen Fall hatten wir doch neulich erst. Laut WordPress hat PHP einen Speicher von 250MB zur Verfügung, allerdings steigt das Script hier schon bei 64MB aus, obwohl nochmals nur 80 KB angefordert werden. Da dürfte es eigentlich keine Fehlermeldung geben.

    Ich weiß jetzt allerdings nicht mehr, ob es dazu eine Lösung gab, ich würde da auf ein Server-Problem tippen.

    @pixolin
    drum scheint wohl auch
    define( 'WP_MEMORY_LIMIT', '256M' );
    zu helfen

    Ich hab das immer so verstanden, dass du dir mit der wp-config.php was „wünschen“ kannst, du aber die Serverkonfiguration nicht überschreiben kannst.
    Ich hab öfters gesehen, dass Anbieter mit 512MB werben, im Kundenmenü aber 128MB vorgeben – da mag das dann greifen?

Ansicht von 15 Antworten - 1 bis 15 (von insgesamt 17)