Support » Allgemeine Fragen » Webseite soll „englische Version“ zuerst darstellen

  • sigi20

    (@sigi20)


    Hallo, versuche auf diesem Wege eine Lösung für mein Problem zu finden.

    Die „englische Version“ kommt nicht zuerst. Das hätte ich gerne so eingestellt.
    Wer kann mir da auf die Sprünge helfen?

    Vielen Dank einstweilen
    Siegfried Bauer

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    wenn ich das richtig sehe, nutzt du das Plugin TranslatePress. Im folgenden Beitrag findest du vermutlich die Lösung.
    Viele Grüße
    Hans-Gerd

    bscu

    (@bscu)

    Ich habe mal für dich gegooglt:

    https://translatepress.com/docs/settings#default-language

    Edit: zu langsam 🙁

    • Diese Antwort wurde geändert vor 1 Monat von bscu.
    Thread-Ersteller sigi20

    (@sigi20)

    Danke, habe mir das nochmal eingehend zu Gemüte geführt.

    Es hat geklappt! Ich habe nochmal rumprobiert und folgende Einstellungen verwandt.

    Alle Sprachen:
    Englisch
    Default German

    Name Originalsprache:
    Nein

    Unterverzeichnis für die Standardsprache nutzen:
    Ja

    Sprache in individuellen Links erzwingen:
    Nein

    Thread-Ersteller sigi20

    (@sigi20)

    Leider habe ich mich damit anscheinend ausgesperrt…, weil der Browser immer das „en“ für englische Version jetzt vorgibt.

    Komme damit nicht mehr zu meinem Login (www.tipicondice.com/xyz).
    Der Browser ändert immer es immer auf http://www.tipicondice.com/en/xyz

    Was könnte ich tun?

    Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    kannst du per FTP-Programm auf deinen Webspace zugreifen?
    Dann verwende bitte einen geeigneten Editor (z.B. Atom Editor oder Notepad++, bitte nicht Windows Notepad oder Mac Texteditor und füge in der Datei wp-config.php oberhalb von
    /* That's all, stop editing! Happy blogging. */ folgendes ein:
    define( 'RELOCATE', true );
    Das könnte evtl. funktionieren.
    Lies dazu bitte auch mal die folgende sehr gute Anleitung von @pixolin, in der du noch weitere Informationen und Möglichkeiten zur Korrektur findest.
    Viele Grüße
    Hans-Gerd

    Thread-Ersteller sigi20

    (@sigi20)

    1. Ich habe obigen Vorschlag ausgeführt und die wp-config.php bei meinem Hoster all-inkl entsprechend geändert. define( ‚RELOCATE‘, true );

    Weiss aber nicht wie ich dann zum Backend komme…(vorher war es https://tipicondice.com/abcd

    Verstehe wahrscheinlich das „Beispiel“ nicht, was jetzt genau einzugeben ist.
    Hab schon einiges umsonst probiert.

    Grüße vom
    Sigi

    Moderator Bego Mario Garde

    (@pixolin)

    In Einstellungen > Allgemein kannst du eine WordPress-URL und eine Website-URL eintragen. Da meistens die WordPress-Dateien in dem Verzeichnis liegen (WordPress-URL), das auch mit der Domain verknüpft ist (Website-URL), sollten die beiden URLs in den allermeisten Fällen identisch sein und auch das gleiche Schema (http) haben.

    Im Moment sind folgende URLs eingetragen:

    WordPress-URL: http://www.tipicondice.com
    Website-URL: https://www.tipicondice.com/en

    Hier sind also unterschiedliche Verzeichnisse (Web-Stammverzeichnis, Verzeichnis en) und unterschiedliche Schemata angegeben (http und https).

    Um das zurückzusetzen, solltest du im Kundenmenü deines Webhosters die Datenbankverwaltung aufrufen (meistens ist das phpMyAdmin), in die Databank-Tabelle wp_options gehen (die Vorsilbe wp_ heißt bei dir wahrscheinlich anders) und dort die Einträge für siteurl (= URL zu den WordPress-Dateien) und home (= Website-Adresse) korrigieren. (Um den Eintrag home zu finden, musst du in der Datenbanktabelle vermutlich etwas blättern.)

    Selbst wenn die Änderung hier nicht besonders groß ist, ist vor solchen Änderungen ein Backup der Datenbank hilfreich.

    So steht das übrigens alles sinngemäß in meinem Beitrag, den Hans-Gerd freundlicherweise verlinkt hatte. 🙂

    Thread-Ersteller sigi20

    (@sigi20)

    So, jetzt steht in home und in siteurl die identische Adresse: https://www.tipicondice.com drin.

    Leider funktioniert es so nicht und auch mit dem Eintrag define( ‚RELOCATE‘, true ); hatte ich auch keinen Erfolg.

    Mein Hoster empfahl mir die den Plugin-Dateinamen von Translatepress-Multilingual umzubenennen was aber einen fatalen Fehler auslöste und bot mir die Einspielung eines Backups an. Ich habe momentan wieder den Dateinamen richtig korrigiert, der fatale Fehler ist weg, aber es bleibt damit bei meinem Problem:

    Bei Eingabe von tipicondice.com/jufu erscheint im Browser automatisch tipicondice.com/en/jufu und meldet einen 404Error.

    Gibt es noch eine Idee wie man mein Problem lösen könnte?

    Moderator Angelika Reisiger

    (@la-geek)

    Hallo @sigi20

    normalerweise sollte der Adminbereich deiner Website bzw. die Anmeldeseite dorthin doch unter deine-domain.de/wp-login.php aufrufbar sein.

    Hattest du den Pfad geändert? Wenn ja wie und wo? Der Pfad müsste dann vermutlich mit /en ergänzt werden.

    Teste auch einmal, was passiert, wenn du die .htaccess entfernst -> Anleitung

    Thread-Ersteller sigi20

    (@sigi20)

    Mir wurde vom Hoster ein Backup der Datenbank vom 24.10. eingespielt und die .htaccess Datei aus der Sicherung vom 07.10.

    Momentan funktioniert wieder alles NUR DIE WEBSEITE STARTET NICHT WIE GEWÜNSCHT IN ENGLISCH SONDERN IN DEUTSCH.

    Meine Einstellungen:

    Alle Sprachen:
    Default German
    English (UK)

    Name Originalsprache:
    Nein

    Unterverzeichnis für die Standardsprache nutzen:
    Nein

    Sprache in individuellen Links erzwingen:
    Nein`

    Moderator Angelika Reisiger

    (@la-geek)

    Sorry, aber wenn du gestellte Fragen nicht beantwortest und Vorschläge nicht ausprobierst, wie soll man dir dann helfen?

    ¯\_(ツ)_/¯

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)