Support » Installation » Website-Adresse geändert

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Moderator Bego Mario Garde

    (@pixolin)

    Hallo @brandlge und willkommen im Forum,

    nehmen wir an, du richtest einen neuen Webserver ein. Im Web-Stammverzeichnis htdocs (kann auch www, kunde123, www-example-com, etc. heißen) wird eine index.html angelegt, deren Inhalt hello world lautet. Bei Aufruf von https://example.com wird im Browser hello world angezeigt.

    Nehmen wir weiter an, du richtest eine Subdomain https://wp.example.com ein. Dieser Subdomain weist du ein neu eingerichtetes Verzeichnis wordpress als Webstammverzeichnis zu. In diesem Verzeichnis legst du die WordPress-Dateien ab und durchläufst die Installations-Routine.

    Zwischenergebnis:
    https://example.com zeigt weiterhin hello world an,
    https://wp.exmaple.com zeigt eine WordPress-Installation an.

    Nun änderst du in der WordPress-Installation die Website- und WordPress-Adresse.

    Zwischenergebnis:
    https://example.com zeigt weiterhin hello world an,
    https://wp.example.com versucht, die WordPress-Installation anzuzeigen, findet aber z.B. das Style-Sheet nicht unter der inzwischen angegeben Adresse https://example.com (im zugewiesenen Verzeichnis htdocs liegt nur die index.html). Auch ein Aufruf von https://example.com/wp-admin schlägt fehl, weil WordPress nicht im Verzeichnis htdocs sondern unter wordpress installiert wurde.

    Lösung:

    1. Du musst entweder im Kundenmenü deines Webhoster die Zuweisung des Web-Stammverzeichnisses für https://example.com von htdocs auf wordpress ändern oder die Dateien aus dem Verzeichnis wordpress in das Verzeichnis htdocs kopieren.
      • Die in der Datenbank bereits eingetragenen URLs für z.B. hochgeladenen Bilder, interne Verlinkung, Navigationsmenüs, etc. werden von der Änderung der URLs in Einstellungen > Allgemein nicht betroffen. Um auch serialisierte Datenbankeinträge zu ersetzen, kannst du ein Plugin wie Better Search Replace nutzen und dort https://wp.example.com mit https://example.com ersetzen. Achte darauf, alle Tabellen auszuwählen und das Häkchen bei „Testlauf“ herauszunehmen.

    Hallo @pixolin,

    vielen Dank für diese klasse Erklärung. Diesen Schritt, denke ich, kann ich dann ausführen, wenn in meiner wp-Installation die Felder
    – WordPress-Adresse (URL)
    – Website-Adresse (URL)
    wieder jeweils auf dem Wert „http://wp.dornier-siedlung-neuaubing.de/“ stehen. Wo in der DB kann ich diese beiden Felder setzen?

    Vielen Dank im Voraus!
    Gerhard

    Hallo @brandlge,
    falls Dein Problem noch nicht gelöst ist, und Du die Installation auf die alte Subdomain zurücksetzen möchtest, gelingt Dir das, indem Du in der Datei wp-config.php im Stammverzeichnis folgende Zeilen einfügst:

    define('WP_SITEURL', 'http://wp.dornier-siedlung-neuaubing.de/');
    define('WP_HOME', 'http://wp.dornier-siedlung-neuaubing.de/');

    Hallo @pixolin,
    da ich ein ähnliches Problem habe, schließe ich meine Frage hier mit der Bitte um Unterstützung an. Nach Änderung der URL im WP-Backend von der Subdomain auf die Hauptdomain werden die Bilder in der Mediathek, die Vorschaubilder der installierten Themes und einige Plugin-Icons nicht mehr angezeigt.
    Eine Änderung über die wp-config bringt dasselbe Ergebnis.
    Die Aktualisierung der Pfade in der Datenbank mittels better-search-replace-Plugin behebt das Problem auch nicht.
    Deaktivieren sämtlicher Plugins leider auch nicht.
    Da ich immer gleich vorgehe und bisher nie Probleme dieser Art hatte, überlege ich, ob es an neuen Sicherheitseinstellungen der 5.0.1 WP-Version liegen könnte.
    Wäre ein Downgrade einen Versuch wert oder ist das Blödsinn?

    Vielen Dank im Voraus!
    Tina

    Nachtrag: In der Mediathek werden die Bilder nicht angezeigt, kopiere ich allerdings den Pfad in die Browserzeile, ist das Bild zu sehen.

    • Diese Antwort wurde geändert vor 1 Jahr, 2 Monate von flextorat.

    Hallo @pixolin,
    konnte mein Problem lösen – es lag an den Dateiberechtigungen, die durch ein Sicherheits-Plugin (All-in-one-security) eingeschränkt werden.
    Also falls jemand dasselbe Problem hat: Deaktivieren der Einstellungen im Bereich Datei-Berechtigungen hilft.

    Beste Grüße
    Tina

    Hallo,

    vielen Dank für eure Hilfe.

    define('WP_SITEURL', 'http://wp.dornier-siedlung-neuaubing.de/');
    define('WP_HOME', 'http://wp.dornier-siedlung-neuaubing.de/');

    hat leider nicht funktioniert.

    Nun dachte ich mir, dass diese Werte ja schließlich irgendwo in der wp-DB stehen müssen und habe daher in Tabelle wp_options die Felder siteurl und home nach ‚http://wp.dornier-siedlung-neuaubing.de‘ geändert. Das half leider auch nicht. Muss ich da warten bis eine Aktualisierung stattfindet?

    Viele Grüße

    Also was auch immer Du gemacht hast … ich sehe auf der Subdomain die neue und auf der Hauptdomain die alte Seite, beide inkl. Stylesheets, keine zerschossen.
    Insofern: Herzlichen Glückwunsch!

    Hallo @pixolin,
    es hat geklappt. Ich musste erst einiges an Historie in meinen Browser-Settings löschen, bis mir wieder die aktuelle und wieder korrekte sub-domain-Seite angezeigt wurde.
    Nochmal vielen Dank!

    Hallo @flextorat,
    ja korrekt. Sie oben!

    Viele Grüße
    Gerhard

Ansicht von 7 Antworten - 1 bis 7 (von insgesamt 7)
  • Das Thema „Website-Adresse geändert“ ist für neue Antworten geschlossen.