Support » Installation » Website funktioniert nach fehlgeschlagenem Update nicht mehr

  • Liebe WordPress-Community,

    ich bin am verzweifeln :-/
    Ich wollte vorgestern eine Bildergalery über das NexGen-Plugin hochladen (hat vorher auf die Art und Weise wie ich es auch vorgestern gemacht habe immer wunderbar funktioniert), leider habe ich dann aber eine Fehlermeldung erhalten. Anschließend habe ich mich gefragt, woran das liegen kann und habe dann nachgeschaut ob Aktualisierungen vorliegen. Dies war in der Tat der Fall. Nicht nur das Plugin sollte ich aktualisieren sondern auch auf die neuste WordPress-Version updaten.

    Das Update der neuen WordPress-Version ist fehlgeschlagen. Nach drücken der F5-Taste habe ich nur noch die folgende Fehlermeldung:

    Die Website kann diese Seite nicht anzeigen
    HTTP 500

    Wahrscheinlichste Ursachen:
    •Die Website wird momentan gewartet.
    •Die Website enthält einen Programmierfehler.

    Auf die Webseite komme ich nicht mehr, das Dashboard kann ich ebenfalls nicht mehr erreichen.

    Ich bin, wie eingangs schon erwähnt, komplett am verzweifeln. Viele Stunden habe ich bzw. haben wir ehrenamtlich für unseren Schützenverein in die Webseite investiert. Es wäre sehr schade, wenn nun alles verloren gegangen ist (ein Backup wurde nicht vor dem Update gemacht :-/)

    Ich hoffe auf diesem Wege Hilfe zu erhalten und bedanke mich schon jetzt im Voraus.

    Beste Grüße
    Miles

    Die Seite, für die ich Hilfe brauche: [Anmelden, um den Link zu sehen]

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 42)
  • Wenn ich nun versuche das Plugin „NextGEN Gallery – WordPress Gallery Plugin“ erneut über das Backend zu installieren, dann bekomme ich folgende Meldung: „Installation fehlgeschlagen: Verzeichnis konnte nicht angelegt werden.“ Das gleiche passier, wenn ich das Plugin „BackWPup“ installieren möchte.

    Da stimmt scheinbar etwas bei den Dateirechten nicht.
    Du hast schon das Verzeichnis wieder plugins genannt?

    Probier bitte mal folgendes:
    Öffne im FTP-Programm das Web-Stammverzeichnis und suche nach einer Datei wp-blog-header.php. Notier dir den Eintrag in der Spalte „Besitzer/Gruppe“.
    Gehe dann in das Verzeichnis wp-content und vergleiche den Eintrag in der Spalte „Besitzer/Gruppe“ für das Verzeichnis plugins. Stimmen die Einträge überein?
    Danach machst du einen Rechtsklick auf das Verzeichnis plugins und wählst „Dateiberechtigungen“. Ist der numerische Wert, der angezeigt wird, 755?

    ja, das Verzeichnis heißt wieder plugins. Alle anderen Plugins funktionieren auch einwandfrei.

    wp-blog-header.php und das plugins-Verzeichnis im Ordner wp-content haben beide bei der Spalte „Besitzer/Gruppe“ den Eintrag 593685 1110. Nach Rechtsklick auf das Verzeichnis plugins und klick auf „Dateiberechtigungen…“ ist der Wert 755.

    Merkwürdig. Nun scheinen einige Plugins nicht aktuell zu sein, kannst du die im Backend aktualisieren?
    Du verwendest außerdem eine reichlich angestaubte PHP-Version. Kannst du die mal auf PHP 7 ändern? Anleitung findest du hier, ab Abschnitt „Im STRATO Kunden-Login auf PHP 7.0 umstellen“.

    Die Aktualisierung von den installierten Plugins funktioniert.
    Ich habe bei dem Vorstand unseres Vereins die Login-Daten von Strato angefragt. Ich werde sie allerdings erst morgen erhalten.

    Hast du mal versucht, die Browser-Dateien zu löschen?
    Vielleicht klappt die NextGen danach?

    Das habe ich jetzt mal gemacht. Nun ist die Seite http://www.sv-leifede-bs.de nur noch komplett weiß

    Hm? Was hast du gemacht?
    Deine Browser-Dateien (Cache, Cookies) haben doch nichts mit dem Webserver zu tun?

    Es kann nur mit der Aktualisierung der Plugins im Backend zusammenhängen. Vorher lief die Seite

    Dann such mal per FTP-Programm nach der Datei wp-config.php.
    In dieser Datei suchst du im unteren Drittel eine Zeile mit WP_DEBUG. Die Zeile änderst du, sofern vorhanden, auf define( 'WP_DEBUG', true ); (bzw. fügst diese Zeile oberhalb von /* That's all, stop editing! Happy blogging. */ hinzu). Danach lädst du deine Webseite erneut im Browser. Statt der leeren Seite sollte eine Fehlermeldung angezeigt werden, wahrscheinlich eine Pfadangabe zu einem Plugin enthält. Weißt du noch, wie du Plugins deaktivieren kannst, wenn du nicht mehr ins Backend kommst?

    Bis zu der Fehlermeldung bin ich nun gekommen.
    Wie ich ein einzelnes Plugin deaktiviere weiß ich leider nicht.

    Na, du hast doch schon das Plugin-Verzeichnis umbenannt (deaktiviert alle Plugins) und eines gelöscht (deaktiviert und entfernt das einzelne Plugin). Der Fehlerhinweis bezieht sich auf das Plugin „WP Google Calendar Manager – Google Calendar Plugin“. Du müsstest also das Verzeichnis wp-gcalendar umbenennen oder löschen.

    Ah okay. Jetzt habe ich verstanden, was Du meintest 🙂

    Ich habe nun das Verzeichnis „wp-gcalendar“ gelöscht. Allerdings kommt beim Aufruf der Seite immernoch eine Fehlermeldung.

    Also … ich versteh das nicht. Du hattest deine Website doch schon wieder im Griff?
    Sonst musst du die Plugins nochmal alle rausschmeißen (per FTP Plugin-Verzeichnis in no.plugins umbenennen) und mit einem leeren Plugin-Verzeichnis (neues Verzeichnis wp-content/plugins anlegen) neu starten. Dazu gehst du dann in das Menü Plugins und notierst, welche Plugins dekativiert wurden und versuchst anschließend, diese Plugins neu zu installieren.
    Im Moment macht wohl Simple Calendar Ärger.

    Wieso hast du die PHP-Version noch nicht hochgesetzt?
    Wieso verwendest du WordPress 4.7?

    Ich weiß auch nicht was ich falsch gemacht habe :-/

    Ich habe nun das Verzeichnis „plugins“ in „no.plugins“ umbenannt. Nun erscheint zwar die Seite, aber die Fehlermeldung wird über dem Header angezeigt.

Ansicht von 15 Antworten - 16 bis 30 (von insgesamt 42)
  • Das Thema „Website funktioniert nach fehlgeschlagenem Update nicht mehr“ ist für neue Antworten geschlossen.