Support » Allgemeine Fragen » Website öffnet sich nicht ohne www

  • jaz1950

    (@jaz1950)


    Lieber Bego Maria Garde,
    ich muß leider nochmal neu anfangen, denn wenn ich auf deine Postings antworte,
    springt das System automatisch (in der Antwortfunktion!) auf das andere, nicht gewünschte Profil, welches auch nicht gelöscht werden kann.

Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Moderator Hans-Gerd Gerhards

    (@hage)

    Hallo,
    leider fehlt hier die genaue Beschreibung des Problems (wahrscheinlich wohl aufgrund Deiner Probleme mit diesem Forum, die Du hier beschrieben hast, aber die ich leider nicht nachvollziehen kann).
    Daher würde ich Dich bitten, das Problem nochmals hier als Antwort mit Angabe Deiner Seite zu beschreiben.
    Viele Grüße
    Hans-Gerd

    Moderator Bego Mario Garde

    (@pixolin)

    Es geht um diesen Thread:
    https://de.wordpress.org/support/topic/website-oeffnet-sich-nicht-ohne-www/

    Wieso das Thema jetzt nochmal in einem weiteren Thread behandelt werden soll, verstehe ich nicht so ganz. Aber ich heiße auch nicht Maria …

    jaz1950

    (@jaz1950)

    Hallo Hans-Gerd,

    vorweg: ich habe erstmal kein Problem mit dem Forum, sondern ein Problem mit einer Website. Und natürlich mit der Problemlösung, wo Bego Mario Garde und ich schon mitten in der Problem-findung und -Lösung waren und jetzt soll ich alles nochmal erklären?
    Naja, ich versuche es mal:

    Die Website (https://www.icea-germany.com) war mit www nicht zu erreichen. Mit http:// und https:// plus Websitename und nur Websitename öffnete sich die Seite, aber sobald die Seite mit www in jeglicher Kombination eingegeben wurde, kam nur ein weißer Bildschirm.

    Die Seite ist bei STRATO gehostet, SSL-Zertifikat, „erzwungen“ und 301-Weiterleitung. Bei WP ist die URL genauso eingestellt wie oben und die WP-URL ist eingestellt mit dem Zusatz /wordpress7.

    Bei Änderung der URL’s in WP-Einstellungen-Allgemein ohne www ist das o.g. Verhalten anders, d.h. jetzt öffnet sich die Website mit jeglicher Eingabe Kombination, nur nicht, wenn www dabei ist….

    Das ist der jetziger Stand des Problems. STRATO und die Eingaben dort habe ich überprüft, ich kann keine Fehler entdecken und auch keine Unterschiede feststellen im Vergleich mit Einstellungen für andere Websites bei STRATO.
    Die .htaccess-Datei wurde automatisch erstellt und nicht geändert.

    DAZU gekommen ist jetzt noch ein Fehler, daß, wenn ich Änderungen in Einstellungen-Allgemein speichern will, WP nicht speichert, sondern in ein Editor verzweigt auf …\AppData\Local\Temp\options.php und zeigt an:

    <!DOCTYPE HTML PUBLIC „-//IETF//DTD HTML 2.0//EN“>
    <html><head>
    <title>503 Service Unavailable</title>
    </head><body>
    <h1>Service Unavailable</h1>
    <p>The server is temporarily unable to service your
    request due to maintenance downtime or capacity
    problems. Please try again later.</p>
    </body></html>

    Jedesmal wenn man klickt wird angezeigt: \options1.php, options2.php, usw.

    Das ist momentan der Stand der Dinge. Ich hoffe, das es dafür eine Problemlösung gibt.

    Viele Grüße
    Hans

    Moderator Hans-Gerd Gerhards

    (@hage)

    @pixolin: ah, ok – danke für die Info

    jaz1950

    (@jaz1950)

    Lieber Bego Mario Garde,
    weil wenn ich ANTWORTE in dem Thread die Antwort automatisch auf das Profil hz50 springt, welches ich nicht benutzen darf… (und diesen Profil auch nicht löschen kann) und auf gar keinen Fall die Gefahr laufen will, ausgeschlossen und nicht mehr gehört zu werden in diesem Forum wg. dieser Puppen mit Socken-Regel (oder so)…

    Moderator Bego Mario Garde

    (@pixolin)

    Du brauchst dich ja nur aus dem Account hz50 abmelden.

    Schau mal als erstes, ob bei Strato noch „Serverside Security“ aktiviert ist. Mehr Informationen findest du in der Strato-Hilfe: https://www.strato.de/faq/hosting/fehler-503-error-service-unavailable-bei-der-verwendung-von-post-requests/

    Dann steige ich im Moment nicht ganz durch, welche URL (mit oder ohne „www“?) in WordPress eingetragen ist. Die Weiterleitungsregeln im Strato-Kundenmenü sind für mich auch nicht ganz transparent.

    Denk bitte daran, dass wir deine Installation nicht kennen. Raten bringt meistens wenig, stiftet eher noch zusätzliche Verwirrung.

    jaz1950

    (@jaz1950)

    Serverside Security ist aktiviert. Soll das aus?
    Die 301-Weiterleitung ist quasi die Option: „SSL erzwingen“.
    Eingetragen bei WP ist:
    Wordpress-URL: https://icea-germany.com/wordpress7
    Website-Adresse: https://icea-germany.com

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du dir die angegebene Hilfe-Seite von Strato angeschaut?

    Sofern Sie bei der Verwendung von POST-Requests in Ihren Skripten oder Ihrem Content-Management-System, den Fehler 503 „Service Unavailable“ erhalten, prüfen Sie bitte ob Sie in Ihrem STRATO Kunden-Login die Option Filter gegen Gästebuch-Spam aktiviert haben und deaktivieren Sie diese gegebenenfalls.

    Welcher Teil davon ist unklar?

    jaz1950

    (@jaz1950)

    Hast du in meinen Ausführungen irgendetwas gelesen, daß ich den Fehler 503 „Service Unavailable“ erhalte?

    Welcher Teil meiner Problembeschreibung ist unklar?

    Moderator Bego Mario Garde

    (@pixolin)

    Hast du in meinen Ausführungen irgendetwas gelesen, daß ich den Fehler 503 „Service Unavailable“ erhalte?

    Ja, habe ich:

    DAZU gekommen ist jetzt noch ein Fehler, daß, wenn ich Änderungen in Einstellungen-Allgemein speichern will, WP nicht speichert, sondern in ein Editor verzweigt auf …\AppData\Local\Temp\options.php und zeigt an:

    <!DOCTYPE HTML PUBLIC „-//IETF//DTD HTML 2.0//EN“>
    <html><head>
    <title>503 Service Unavailable</title>
    </head><body>
    <h1>Service Unavailable</h1>

    Moderator Angelika Reisiger

    (@la-geek)

    Hallo @jaz1950

    Serverside Security ist aktiviert. Soll das aus?

    Ja, das solltest du auf jeden Fall mal testen. Nach Deaktivierung Caches und Cookies löschen. Siehe dazu

    https://www.strato.de/faq/hosting/fehler-503-error-service-unavailable-bei-der-verwendung-von-post-requests/

    Alternativ kannst du versuchen, eine eigene Redirect per .htaccess zu erstellen.

    # permanently redirect from www domain to non-www domain
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^www\.domain\.de$ [NC]
    RewriteRule (.*) https://domain.de/$1 [R=301,L]
    
    RewriteCond %{HTTPS} !on
    RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]

    domain noch mit deiner Domain ersetzen und entsprechend .de mit .com, als Beispiel mal
    wordpress.org

    das wäre dann:

    # permanently redirect from www domain to non-www domain
    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^www\.wordpress\.org$ [NC]
    RewriteRule (.*) https://wordpress.org/$1 [R=301,L]
    
    RewriteCond %{HTTPS} !on
    RewriteRule (.*) https://%{HTTP_HOST}/$1 [R=301,L]
Ansicht von 11 Antworten - 1 bis 11 (von insgesamt 11)
  • Das Thema „Website öffnet sich nicht ohne www“ ist für neue Antworten geschlossen.